Your message dated Sun, 01 Sep 2013 17:00:10 +0000
with message-id <e1vgb0u-0001tm...@franck.debian.org>
and subject line Bug#699079: fixed in mapnik 2.2.0+ds1-1
has caused the Debian Bug report #699079,
regarding libmapnik2-2.0: rfe: make AsBinary() forward compatible with the 
PostGIS 2.0 API
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
699079: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=699079
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libmapnik2-2.0
Version: 2.0.0+ds1-3+b4
Severity: wishlist


Hi,

the libmapnik2-2.0 package currently in Sid includes a bug
fixed in later versions of libmapnik but not yet in the
Debian archives.

Namely, it's not actually compatible with PostGIS 2.0 due to
the presence of an old API call. AsBinary() should be renamed
ST_AsBinary() for /usr/lib/mapnik/2.0/input/postgis.input.

Since Wheezy is shipping PostGIS 1.5 this isn't a RC bug by any
means, but over the life of Wheezy it will cause confusion and
force installation of 3rd party updates for people using the
newer PostGIS, who think the library will be compatible but
it actually isn't.

So probably a wontfix for the current release, but at least a
head's up to anyone else banging their head against the wall &
searching the BTS when trying to use it with PostGIS 2.0.

The easy work around by the way is to run psql -f legacy.sql
or legacy_minimal.sql which comes with PostGIS 2.0.


regards,
Hamish

--- End Message ---
--- Begin Message ---
Source: mapnik
Source-Version: 2.2.0+ds1-1

We believe that the bug you reported is fixed in the latest version of
mapnik, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 699...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jérémy Lal <kapo...@melix.org> (supplier of updated mapnik package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Tue, 27 Aug 2013 10:16:08 +0200
Source: mapnik
Binary: libmapnik2.2 libmapnik2-dev libmapnik-dev mapnik-utils python-mapnik 
python-mapnik2 mapnik-doc
Architecture: source amd64 all
Version: 2.2.0+ds1-1
Distribution: unstable
Urgency: low
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: Jérémy Lal <kapo...@melix.org>
Description: 
 libmapnik-dev - C++/Python toolkit for developing GIS applications (devel)
 libmapnik2-dev - C++/Python toolkit for developing GIS applications (dummy)
 libmapnik2.2 - C++/Python toolkit for developing GIS applications (libraries)
 mapnik-doc - C++/Python toolkit for developing GIS applications (doc)
 mapnik-utils - C++/Python toolkit for developing GIS applications (utilities)
 python-mapnik - C++/Python toolkit for developing GIS applications (Python)
 python-mapnik2 - C++/Python toolkit for developing GIS applications (dummy)
Closes: 662425 665798 699079
Changes: 
 mapnik (2.2.0+ds1-1) unstable; urgency=low
 .
   [ Andrew Harvey ]
   * Change debian/rules to use top level font directory (Closes: #665798)
 .
   [ David Paleino ]
   * New upstream version 2.1
     - fixed compatibility with PostGIS 2.0 (AsBinary() → ST_AsBinary())
       (Closes: #699079)
   * Switch debian/watch to github tags
   * debian/patches/:
     - 02-fix_FTBFS_binutils-gold.patch refreshed
     - 03-fix_ImportError_mips.patc, 03-fix_big-endian.patch and
       04-port_to_new_boost.patch removed
   * Python bindings testsuite temporarily disabled
   * Adapt debian/rules get-orig-source target to new upstream layout
   * Build-Depends on libpng-dev instead of libpng12-dev (Closes: #662425)
   * Bump debhelper compatibility to 9
   * Bump Standards-Version to 3.9.4, no changes needed
 .
   [ Jérémy Lal ]
   * New upstream version 2.2
   * control:
     + Transition libmapnik2 to libmapnik (#674587)
     + Transition python-mapnik2 to python-mapnik
     + Canonicalize Vcs fields
   * copyright:
     + entire tarball review
     + switch to copyright 1.0 format
     + DFSG-exclude tests/data/fonts/XB\ Zar.ttf (missing license)
     + conveniently exclude scons, fonts, and some test files for the
       sake of copyright simplification.
   * rules:
     + update input plugins list, remove geos, kismet and add csv,
       geojson, python.
     + disable building demo
     + remove unneeded workarounds in some targets
     + call epydoc directly instead of fiddling with build script
     + pass hardening build flags to mapnik SConstruct,
       thanks to YunQiang Su.
   * patch: 1001 patch to link mapnik lib to dl.
Checksums-Sha1: 
 8c58f1814f7268262d151c8df841c2acdf0c5eed 2797 mapnik_2.2.0+ds1-1.dsc
 a648ebea22de5dd71971278a4b1f8804f016dff9 11589800 mapnik_2.2.0+ds1.orig.tar.gz
 dbe477da9c1da6350aaedec305bcb2ba69ca6d8d 15205 mapnik_2.2.0+ds1-1.debian.tar.gz
 066d2f64d56d6fde1ccc1a883e16710a6a8d835e 1767292 
libmapnik2.2_2.2.0+ds1-1_amd64.deb
 b504a276c05bb9c46e7c9f0d538884a055a7004b 10612 
libmapnik2-dev_2.2.0+ds1-1_all.deb
 9d92a16d22283fa59ecb5c505cf0801be524669d 295012 
libmapnik-dev_2.2.0+ds1-1_amd64.deb
 0a1ae9b0200ac571b6a2c646115081e7a8753b5a 57224 
mapnik-utils_2.2.0+ds1-1_amd64.deb
 4b7f73ccb5c2c32dd1cadcd23fdbb35e5399a349 781754 
python-mapnik_2.2.0+ds1-1_amd64.deb
 22f2c7f6a0abd130fe0e89d798870229d57b857b 10600 
python-mapnik2_2.2.0+ds1-1_all.deb
 5f1163b737322f49c66da361958e554a788185c7 2208570 mapnik-doc_2.2.0+ds1-1_all.deb
Checksums-Sha256: 
 b01d9b6e649ffaeb8fe0cadf1f1d41ea356f3ccd91c1cda0ec349a0b705b51e9 2797 
mapnik_2.2.0+ds1-1.dsc
 2e6307e900f01d7b1f64724d65a5ecff83092bd5af1b066fd803a65b0046c801 11589800 
mapnik_2.2.0+ds1.orig.tar.gz
 e229eea80dda170468c9dd946acd0850e149e103a77b080d808f3a6eb5716677 15205 
mapnik_2.2.0+ds1-1.debian.tar.gz
 ebb26ee4c69f6812c41696186c3962e5ff88bd330dd1c5ae3fce78b20fe0ebfd 1767292 
libmapnik2.2_2.2.0+ds1-1_amd64.deb
 38b15153da04e261773219bd47e49c8bd419cf435e41590d6a1f1e2bf2623154 10612 
libmapnik2-dev_2.2.0+ds1-1_all.deb
 cbdc1da363486004392f934c062c9f96bbb204336ad21bf53ad1714360bc7814 295012 
libmapnik-dev_2.2.0+ds1-1_amd64.deb
 d16211cfc2578085ddda0895293eeffcc99c01e92c34be5b2de08953bcf84931 57224 
mapnik-utils_2.2.0+ds1-1_amd64.deb
 bbb866a3e1d59699a93e814ce4824f417b4917107c5749323b8c018f88d9f5ab 781754 
python-mapnik_2.2.0+ds1-1_amd64.deb
 ed7b649a0b2b73906ae0d7ba01d4012ce660bc565984982abc295e62cc1d9fe6 10600 
python-mapnik2_2.2.0+ds1-1_all.deb
 61389c9f4d5ce8c7e4483856bedf60cb8a45ae44ba608ab839f19c46c70582fb 2208570 
mapnik-doc_2.2.0+ds1-1_all.deb
Files: 
 865fcef985098dbc11462488e045d5b7 2797 libs optional mapnik_2.2.0+ds1-1.dsc
 02fee8d66edc83021e2e0682b3f95cd6 11589800 libs optional 
mapnik_2.2.0+ds1.orig.tar.gz
 65e9203179338cb7a20bee596999a40c 15205 libs optional 
mapnik_2.2.0+ds1-1.debian.tar.gz
 8b40cef2c5f73a9f314927e029c885eb 1767292 libs optional 
libmapnik2.2_2.2.0+ds1-1_amd64.deb
 5cce135cbe1276b70949f8e2e9cddd10 10612 oldlibs extra 
libmapnik2-dev_2.2.0+ds1-1_all.deb
 c5a32e064667ecf15bec09f28e931d70 295012 libdevel optional 
libmapnik-dev_2.2.0+ds1-1_amd64.deb
 1798ac80d6e71d8904681ccfcfa412b0 57224 utils optional 
mapnik-utils_2.2.0+ds1-1_amd64.deb
 fa12dbed9e674903e09052478b738615 781754 python optional 
python-mapnik_2.2.0+ds1-1_amd64.deb
 36c5e056bf6e72f6f09a9dbaaf44d581 10600 oldlibs extra 
python-mapnik2_2.2.0+ds1-1_all.deb
 0fb48ba9395796bf883d7582e0a9ec19 2208570 doc optional 
mapnik-doc_2.2.0+ds1-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)

iQIcBAEBCAAGBQJSIdafAAoJEGYRwF7dOfN0y/IQAKZI0Xgx8vEJmlKba0/VkSa7
C5CvbDlYL8lAIFiEDwKDBa+CU8VxOb4j8JsJfgOmMzFb8VnMbqIziWrm+1GpnHFR
/9jV6At5tZlYFlYLvwc8HV+xLMLmWpRPBcOUTOGVGwiPDY22EJWUktuIkPEcUymj
S5lvxZXSed0C6QxujQzlyq1Q2/VDDbnAHFc+NpL3wwrb9PMjXhJO2xUC+7gWs8kX
3p8ZkSQ+NwxcS9Oj2uZhCLVniwsI8vdhSZ9uc/dZjQJeCmik9x7HZ9l8G9mq+27t
jotTxJH/ces98mKB7Yh0dVbK/BRSeiu1larpzY0/ukpH4MMfQ4mA5pObbR6RR8aC
AXg1gh9XREt3ewC+qdPgO8Bd1nLdVRflylkAlsjq2/nG6AfEu7IZ53l93He6fKD0
YN53zh5xY54gAbS7PmZCiMVJyLCyHHBuBMWRozirYSHqGd4194/NaO8WoRtmNb/5
1TF1ZuVD8EMm8zEa0f+Nvw3x43/b9Jor5G6UYxaG+uoy7od7S7YlIkFfA5no2bmB
gt3JLgW3MY6OgCuw1B7xYop+Fj9Pwev5ssLSg9txCWhiNS6rKo9+DE3AEbBYsgL9
oJ9jgiQPzcCaFXVac1Y0hIevxweSUZC09Eb8KQECoMAolsIqP3U7Q2B8EgrCfp9l
7tCBbI/fZ4jmWnS42kd9
=hV4M
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to