Source: mapnik
Version: 2.2.0+ds1-1
Severity: serious
Justification: fails to build from source (but built successfully in the past)

Builds of mapnik (as on the autobuilders, or with dpkg-buildpackage -B)
covering only its architecture-dependent binary packages have been failing:

  # build Python API documentation
  # and trick epydoc into loading the shlib too
  LD_LIBRARY_PATH=/«BUILDDIR»/mapnik-2.2.0+ds1/debian/libmapnik2.2/usr/lib/ 
epydoc --no-private \
      --no-frames \
      --no-sourcecode \
      --name mapnik \
      --url http://mapnik.org \
      --css /«BUILDDIR»/mapnik-2.2.0+ds1/utils/epydoc_config/mapnik_epydoc.css \
      /«BUILDDIR»/mapnik-2.2.0+ds1/bindings/python/mapnik \
      -o 
/«BUILDDIR»/mapnik-2.2.0+ds1/debian/mapnik-doc/usr/share/doc/mapnik-doc/python
  ERROR: ld.so: object 'libfakeroot-sysv.so' from LD_PRELOAD cannot be 
preloaded: ignored.
  
  UNEXPECTED ERROR:
  [Errno 2] No such file or directory: 
'/«BUILDDIR»/mapnik-2.2.0+ds1/debian/mapnik-doc/usr/share/doc/mapnik-doc/python'

Please accommodate such builds; I'd suggest arranging to skip this step
altogether for them.

Thanks!

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to