Your message dated Mon, 09 Sep 2013 13:14:01 +0200
with message-id <522dad79.5070...@melix.org>
and subject line Re: mapnik: ftbfs with GCC-4.8
has caused the Debian Bug report #701318,
regarding mapnik: ftbfs with GCC-4.8
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
701318: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=701318
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: src:mapnik
Version: 2.0.0+ds1-3
Severity: important
Tags: sid jessie
User: debian-...@lists.debian.org
Usertags: ftbfs-gcc-4.8

The package fails to build in a test rebuild on at least amd64 with
gcc-4.8/g++-4.8, but succeeds to build with gcc-4.7/g++-4.7. The
severity of this report may be raised before the jessie release.

  XXX

The full build log can be found at:
http://people.debian.org/~doko/logs-20130217/gcc48/mapnik_2.0.0+ds1-3_unstable_gcc48.log
The last lines of the build log are at the end of this report.

To build with GCC 4.8, either set CC=gcc-4.8 CXX=g++-4.8 explicitly,
or install the gcc, g++, gfortran, ... packages from experimental.

  apt-get -t experimental install g++ g++-4.7 g++-4.8 libc6-dev

The test rebuild was done with eglibc-2.17 and GCC-4.8, so some issues
might be caused by the updated glibc.

[...]
Checking for Boost version >= 1.41... yes
Found boost lib version... 1_49
Checking for C++ library boost_system... yes
Checking for C++ library boost_filesystem... yes
Checking for C++ library boost_regex... yes
Checking for C++ library boost_program_options... yes
Checking for C++ library boost_thread... no
Could not find required header or shared library for boost thread
Checking if boost_regex was built with ICU unicode support... (cached) yes
Checking for requested plugins dependencies...
Checking for gdal-config --libs... yes
Checking for gdal-config --cflags... yes
Checking for name of gdal library... gdal
Checking for geos-config --ldflags --cflags... yes
Checking if gdal is ogr enabled... yes
Checking for name of ogr library... gdal
Checking for C library curl... yes
Checking for pg_config... yes
Checking for C library rasterlite... yes
Checking for C library sqlite3... yes
Checking for pkg-config... yes
Checking for cairo... yes
Checking for cairomm-1.0... yes
Checking for at least version 1.8.0 for cairomm-1.0... yes
Checking for C++ header file boost/python/detail/config.hpp... yes
Checking for pkg-config... yes
Checking for pycairo... yes

Exiting... the following required dependencies were not found:
   - boost thread (more info see: 
http://trac.mapnik.org/wiki/MapnikInstallation & http://www.boost.org)

See '/«BUILDDIR»/mapnik-2.0.0+ds1/config.log' for details on possible 
problems.

Set custom paths to these libraries and header files on the command-line or in 
a file called 'config.py'
    ie. $ python scons/scons.py BOOST_INCLUDES=/usr/local/include 
BOOST_LIBS=/usr/local/lib

Once all required dependencies are found a local 'config.py' will be saved and 
then install:
    $ sudo python scons/scons.py install

To view available path variables:
    $ python scons/scons.py --help or -h

To view overall SCons help options:
    $ python scons/scons.py --help-options or -H

More info: http://trac.mapnik.org/wiki/MapnikInstallation
make[1]: *** [override_dh_auto_clean] Error 1
make: *** [clean] Error 2
make[1]: Leaving directory `/«BUILDDIR»/mapnik-2.0.0+ds1'
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2

--- End Message ---
--- Begin Message ---
Packages affected by that bug have been fixed.
Closing.

Jérémy.

--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to