Package: libmapscript-ruby
Severity: normal
Usertags: ruby18-removal, update-ruby-policy

Hi Debian GIS Project,

As you may know, during the Wheezy release cycle, the pkg-ruby-extras
team¹ has worked to update the Ruby libraries/modules/gems packages to
follow a new policy, much easier for the maintainers (as we no longer
require a separate package for each interpreter version), to the
archive (as it strongly reduces code duplication), and much more
sensical to the users (as they no longer require to fiddle with which
among many almost-identical binary packages to install).

While we achieved a quite good success level during the Wheezy cycle²,
we decided to act only on the packages maintained by the group — There
are many Ruby library packages maintained by kind people (like
yourself!) which have not yet adopted this new style. According to our
records, you are currently maintaining the package:

  libmapscript-ruby

I am sending this report as part of a mass-bug-filing.³ Some useful
information you might find useful:

• Guidelines for Ruby packaging⁴

  https://wiki.debian.org/Teams/Ruby/Packaging#Guidelines_for_Ruby_packaging

• Ruby team release goals for Jessie⁵

  https://wiki.debian.org/Teams/Ruby/Jessie

• About the Ruby team — Please consider joining!⁶

  https://wiki.debian.org/Teams/Ruby

• Part of the new policy involves running the package's tests. Here is
  a swift introduction on what it means and how to do it:

  https://wiki.debian.org/Teams/Ruby/Packaging/Tests


Thanks a lot for your attention!

--

¹ alioth.debian.org/projects/pkg-ruby-extras/

² http://pkg-ruby-extras.alioth.debian.org/wheezy/

³ https://lists.debian.org/debian-devel/2013/09/msg00196.html

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to