The following commit has been merged in the jessie branch:
commit ee7c5d50a7eddea5b1b9448994353effc09e3903
Author: Bas Couwenberg <sebas...@xs4all.nl>
Date:   Sat Aug 31 23:46:12 2013 +0200

    Drop ruby1.8 mapscript package for ruby1.8-removal transition.
    Rename libruby-mapscript to ruby-mapscript. (closes: #722394)
    Don't install Ruby mapscript in /usr/lib/ruby, use vendor_ruby instead.

diff --git a/debian/changelog b/debian/changelog
index cd0bdc8..27bc391 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,9 @@ mapserver (6.2.1-4) unstable; urgency=low
 
   * Use pkgkde-gensymbols & pkgkde-symbolshelper to handle C++ symbols.
   * Use upstream version without debian revision when generating symbols.
+  * Drop ruby1.8 mapscript package for ruby1.8-removal transition.
+  * Rename libruby-mapscript to ruby-mapscript. (closes: #722394)
+  * Don't install Ruby mapscript in /usr/lib/ruby, use vendor_ruby instead.
 
  -- Bas Couwenberg <sebas...@xs4all.nl>  Thu, 25 Jul 2013 20:25:18 +0200
 
diff --git a/debian/control b/debian/control
index 8d29a2b..c78357c 100644
--- a/debian/control
+++ b/debian/control
@@ -10,13 +10,14 @@ Build-Depends: debhelper (>= 9), dpkg-dev (>= 1.16.1.1), 
autotools-dev,
  libgdal1-dev (>= 1.9.0), libproj-dev, libgeos-dev (>= 3.3.1-1~),
  libfribidi-dev, libcairo2-dev,
  libpq-dev, php5-dev, swig, python-all (>= 2.6.6-3~), python-all-dev (>= 
2.6.6-3~),
- ruby1.8, ruby1.8-dev, ruby1.9.1, ruby1.9.1-dev,
+ ruby1.9.1, ruby1.9.1-dev,
  sharutils, libsdl1.2-dev,
  libfcgi-dev, libxml2-dev, libogdi3.2-dev, libxslt1-dev, libpam0g-dev, 
libreadline-dev,
  libedit-dev, libepsilon-dev, pkg-kde-tools,
  autoconf, dh-autoreconf, chrpath, 
  docbook2x, docbook-xsl, docbook-xml, xsltproc
 Build-Conflicts: libcurl3-openssl-dev
+XS-Ruby-Versions: ruby1.9.1
 Homepage: http://www.mapserver.org
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/mapserver.git
 Vcs-Git: git://anonscm.debian.org/pkg-grass/mapserver.git
@@ -37,7 +38,7 @@ Architecture: any
 Pre-Depends: ${misc:Pre-Depends}
 Depends: ${shlibs:Depends}, ${misc:Depends}
 Suggests: cgi-mapserver, mapserver-bin, mapserver-doc,
- php5-mapscript, python-mapscript, libmapscript-perl, libmapscript-ruby
+ libmapscript-perl, php5-mapscript, python-mapscript, ruby-mapscript
 Description: Shared library for MapServer
  This package contains the shared library.
  .
@@ -61,7 +62,7 @@ Section: libdevel
 Architecture: any
 Depends: libmapserver-6.2.1 (=${binary:Version}), ${misc:Depends}
 Suggests: cgi-mapserver, mapserver-bin, mapserver-doc,
- php5-mapscript, python-mapscript, libmapscript-perl, libmapscript-ruby
+ libmapscript-perl, php5-mapscript, python-mapscript, ruby-mapscript
 Description: Shared library development files for MapServer
  This package contains the development files for the shared library.
  .
@@ -100,7 +101,7 @@ Section: web
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
 Suggests: mapserver-bin, mapserver-doc,
- php5-mapscript, python-mapscript, libmapscript-perl, libmapscript-ruby
+ libmapscript-perl, php5-mapscript, python-mapscript, ruby-mapscript
 Description: CGI executable for MapServer
  This package contains the mapserv CGI program. It provides the
  MapServer template language, and can be used to implement Web Map
@@ -128,7 +129,7 @@ Section: misc
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
 Suggests: cgi-mapserver, mapserver-doc, shapelib,
- php5-mapscript, python-mapscript, libmapscript-perl, libmapscript-ruby
+ libmapscript-perl, php5-mapscript, python-mapscript, ruby-mapscript
 Description: MapServer utilities
  This package provides command-line utilities for MapServer.
  .
@@ -142,7 +143,7 @@ Section: doc
 Architecture: all
 Depends: ${misc:Depends}
 Suggests: cgi-mapserver,
- php5-mapscript, python-mapscript, libmapscript-perl, libmapscript-ruby
+ libmapscript-perl, php5-mapscript, python-mapscript, ruby-mapscript
 Description: documentation for MapServer
  This package provides some brief documentation for MapServer.
  .
@@ -152,40 +153,44 @@ Description: documentation for MapServer
  library packages.
 
 Package: libmapscript-ruby
-Section: ruby
+Depends: ruby-mapscript, ${misc:Depends}
 Architecture: all
-Depends: libmapscript-ruby1.9.1, ${misc:Depends}
-Description: MapServer library for Ruby
- Ruby MapScript provides MapServer functions for Ruby scripts.
- .
- This package contains examples and depends on package for Debian
- default version of Ruby.
- .
- MapServer is a CGI-based framework for Internet map services which
- supports Open Geospatial Consortium (OGC) standards.
+Section: oldlibs
+Description: Transitional dummy package for ruby-mapscript
+ This is a transitional dummy package to ease upgrades to the
+ ruby-mapscript package. It can safely be removed.
 
 Package: libmapscript-ruby1.8
-Section: ruby
+Depends: ruby-mapscript, ${misc:Depends}
 Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: mapserver-bin, mapserver-doc
-Description: MapServer library for Ruby 1.8
- Ruby MapScript provides MapServer functions for Ruby scripts.
- .
- This package contains the MapServer functions for Ruby 1.8.
- .
- MapServer is a CGI-based framework for Internet map services which
- supports Open Geospatial Consortium (OGC) standards.
+Section: oldlibs
+Description: Transitional package from libmapscript-ruby1.8 to ruby-mapscript
+ This is a transitional dummy package to ease upgrades from the
+ libmapscript-ruby1.8 package to the ruby-mapscript package.
+ It can safely be removed.
 
 Package: libmapscript-ruby1.9.1
+Depends: ruby-mapscript, ${misc:Depends}
+Architecture: any
+Section: oldlibs
+Description: Transitional package from libmapscript-ruby1.9.1 to ruby-mapscript
+ This is a transitional dummy package to ease upgrades from the
+ libmapscript-ruby1.9.1 package to the ruby-mapscript package.
+ It can safely be removed.
+
+Package: ruby-mapscript
+Provides: libmapscript-ruby, libmapscript-ruby1.8, libmapscript-ruby1.9.1
+Replaces: libmapscript-ruby, libmapscript-ruby1.8, libmapscript-ruby1.9.1
+Breaks: libmapscript-ruby, libmapscript-ruby1.8, libmapscript-ruby1.9.1
 Section: ruby
 Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ruby1.9.1, ${shlibs:Depends}, ${misc:Depends}
 Suggests: mapserver-bin, mapserver-doc
-Description: MapServer library for Ruby 1.9.1
+XB-Ruby-Versions: ruby1.9.1
+Description: MapServer library for Ruby
  Ruby MapScript provides MapServer functions for Ruby scripts.
  .
- This package contains the MapServer functions for Ruby 1.9.1.
+ This package contains examples and the MapServer functions for Ruby.
  .
  MapServer is a CGI-based framework for Internet map services which
  supports Open Geospatial Consortium (OGC) standards.
diff --git a/debian/patches/ruby-shebang.patch 
b/debian/patches/ruby-shebang.patch
new file mode 100644
index 0000000..f471951
--- /dev/null
+++ b/debian/patches/ruby-shebang.patch
@@ -0,0 +1,11 @@
+Description: Explicitly use ruby1.9.1 in shebang.
+Author: Bas Couwenberg <sebas...@xs4all.nl>
+Last-Update: 2013-09-10
+--- a/mapscript/ruby/examples/shp2img.rb
++++ b/mapscript/ruby/examples/shp2img.rb
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env ruby 
++#!/usr/bin/ruby1.9.1
+ 
+ require "mapscript"
+ include Mapscript
diff --git a/debian/patches/series b/debian/patches/series
index ee79e12..981b3de 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,3 +3,4 @@ php_segfault.patch
 mapows-contenttype.patch
 hardening.patch
 shp2img-typo.patch
+ruby-shebang.patch
diff --git a/debian/libmapscript-ruby.docs b/debian/ruby-mapscript.docs
similarity index 100%
rename from debian/libmapscript-ruby.docs
rename to debian/ruby-mapscript.docs
diff --git a/debian/libmapscript-ruby.examples b/debian/ruby-mapscript.examples
similarity index 100%
rename from debian/libmapscript-ruby.examples
rename to debian/ruby-mapscript.examples
diff --git a/debian/rules b/debian/rules
index 4969f94..68fa351 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,7 +27,7 @@ RUBY_CPPFLAGS=$(subst -Werror=format-security,,$(CFLAGS))
 RUBY_CPPFLAGS+=$(LDFLAGS)
  
 PYVERS=$(shell pyversions -r debian/control)
-RUBYVERS=1.8 1.9.1
+RUBYVERS=1.9.1
 PHP5API=$(shell php-config5 --phpapi)
 MANPAGES:=$(wildcard debian/man/*.*.xml)
 
@@ -151,7 +151,7 @@ override_dh_auto_install:
        cd $(CURDIR)/mapscript/ruby && set -e ; \
          for v in $(RUBYVERS) ; do \
            ruby$$v extconf.rb --with-cppflags="$(RUBY_CPPFLAGS) " ; \
-             $(MAKE) install 
sitedir=$(CURDIR)/debian/libmapscript-ruby$$v/usr/lib/ruby ; \
+             $(MAKE) install 
sitedir=$(CURDIR)/debian/ruby-mapscript/usr/lib/ruby/vendor_ruby ; \
              $(MAKE) distclean ; \
          done
 
@@ -160,7 +160,7 @@ override_dh_auto_install:
 
        # removing embedded rpath in libraries
        -find $(CURDIR)/debian/python-mapscript/usr/ -name _mapscript.so -type 
f -exec chrpath --delete {} \;
-       -find $(CURDIR)/debian/libmapscript-ruby*/usr/lib/ruby/ -type f -exec 
chrpath --delete {} \;
+       -find $(CURDIR)/debian/ruby-mapscript/usr/lib/ruby/vendor_ruby/ -type f 
-exec chrpath --delete {} \;
 
        # remove la file in php ext dir
        -$(RM) -rf $(CURDIR)/debian/tmp/usr/lib/php5/$(PHP5API)/*.la

-- 
Packaging for MapServer

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to