Package: libmapserver-6.2.1,libmapserver-6.2.1-dev
Version: 6.4.0-1
Severity: serious
Usertags: piuparts


during a test with piuparts I noticed your package is no longer
installable in sid:

Package: libmapserver-6.2.1
Version: 6.4.0-1
Depends: libmapserver1

Package: libmapserver1
Version: 6.4.0-1
Replaces: libmapserver (<< 6.2.1-3~), libmapserver-6.2.1
Breaks: libmapserver (<< 6.2.1-3~), libmapserver-6.2.1

Package: libmapserver-6.2.1-dev
Source: mapserver
Version: 6.4.0-1
Depends: libmapserver1-dev

Package: libmapserver1-dev
Source: mapserver
Version: 6.4.0-1
Replaces: libmapserver-6.2.1-dev, libmapserver-dev (<< 6.2.1-3~)
Depends: libmapserver1 (= 6.4.0-1)
Breaks: libmapserver-6.2.1-dev, libmapserver-dev (<< 6.2.1-3~)

If the transtional packages are not installable, the package won't
migrate to testing.

The Breaks/Replaces against -6.2.1 need to be versioned as well.

But do you really need transitional packages for a shared library?
Does this even work correctly?
Wouldn't a transition with binNMUs on all rdeps be better?

If the library gained a stable API/ABI, you can probably close #327853.

Same problem for the transitional ruby packages:

Package: ruby-mapscript
Source: mapserver
Version: 6.4.0-1
Replaces: libmapscript-ruby, libmapscript-ruby1.8, libmapscript-ruby1.9.1
Provides: libmapscript-ruby, libmapscript-ruby1.8, libmapscript-ruby1.9.1
Breaks: libmapscript-ruby, libmapscript-ruby1.8, libmapscript-ruby1.9.1



Pkg-grass-devel mailing list

Reply via email to