The following commit has been merged in the jessie branch:
commit 8bd16bebefa60b3d24836142cb9dc80199cb5a1a
Author: Bas Couwenberg <sebas...@xs4all.nl>
Date:   Sat Sep 21 22:15:53 2013 +0200

    Add versioned Breaks/Replaces for transitional packages.

diff --git a/debian/changelog b/debian/changelog
index 0b46528..3335b68 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ mapserver (6.4.0-2) UNRELEASED; urgency=low
   * Use php5enmod and php5dismod instead of installing the ini directly.
     (closes: #667771)
   * Add patch to export mapserver.cmake for external projects.
+  * Add versioned Breaks/Replaces for transitional packages. (closes: #723979)
 
  -- Bas Couwenberg <sebas...@xs4all.nl>  Thu, 19 Sep 2013 19:52:12 +0200
 
diff --git a/debian/control b/debian/control
index 6ac0cdd..783ba3b 100644
--- a/debian/control
+++ b/debian/control
@@ -86,9 +86,9 @@ Suggests: cgi-mapserver,
           ruby-mapscript
 Pre-Depends: ${misc:Pre-Depends}
 Breaks: libmapserver (<< 6.2.1-3~),
-        libmapserver-6.2.1
+        libmapserver-6.2.1 (<< 6.4.0-1~)
 Replaces: libmapserver (<< 6.2.1-3~),
-          libmapserver-6.2.1
+          libmapserver-6.2.1 (<< 6.4.0-1~)
 Description: Shared library for MapServer
  This package contains the shared library.
  .
@@ -130,9 +130,9 @@ Suggests: cgi-mapserver,
           python-mapscript,
           ruby-mapscript
 Breaks: libmapserver-dev (<< 6.2.1-3~),
-        libmapserver-6.2.1-dev
+        libmapserver-6.2.1-dev (<< 6.4.0-1~)
 Replaces: libmapserver-dev (<< 6.2.1-3~),
-          libmapserver-6.2.1-dev
+          libmapserver-6.2.1-dev (<< 6.4.0-1~)
 Description: Shared library development files for MapServer
  This package contains the development files for the shared library.
  .
@@ -281,14 +281,15 @@ Depends: ruby1.9.1,
          ${misc:Depends}
 Suggests: mapserver-bin,
           mapserver-doc
-Breaks: libmapscript-ruby,
-        libmapscript-ruby1.8
+Breaks: libmapscript-ruby (<< 6.4.0-1~),
+        libmapscript-ruby1.8 (<< 6.4.0-1~),
+        libmapscript-ruby1.9.1 (<< 6.4.0-1~)
 Provides: libmapscript-ruby,
           libmapscript-ruby1.8,
           libmapscript-ruby1.9.1
-Replaces: libmapscript-ruby,
-          libmapscript-ruby1.8,
-          libmapscript-ruby1.9.1
+Replaces: libmapscript-ruby (<< 6.4.0-1~),
+          libmapscript-ruby1.8 (<< 6.4.0-1~),
+          libmapscript-ruby1.9.1 (<< 6.4.0-1~)
 XB-Ruby-Versions: ruby1.9.1
 Description: MapServer library for Ruby
  Ruby MapScript provides MapServer functions for Ruby scripts.

-- 
Packaging for MapServer

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to