The following commit has been merged in the jessie branch:
commit 614f924b70b9f0b4b9f95b1fc95cbc8ef17051e5
Author: Bas Couwenberg <sebas...@xs4all.nl>
Date:   Sun Sep 22 03:24:30 2013 +0200

    Drop transitional packages and Breaks/Replaces for libmapserver.

diff --git a/debian/changelog b/debian/changelog
index a515522..e51f5c1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,7 +5,9 @@ mapserver (6.4.0-2) unstable; urgency=low
   * Use php5enmod and php5dismod instead of installing the ini directly.
     (closes: #667771)
   * Add patch to export mapserver.cmake for external projects.
-  * Add versioned Breaks/Replaces for transitional packages. (closes: #723979)
+  * Add versioned Breaks/Replaces for dev package.
+  * Drop transitional packages and Breaks/Replaces for libmapserver.
+    (closes: #723979)
 
  -- Bas Couwenberg <sebas...@xs4all.nl>  Thu, 19 Sep 2013 19:52:12 +0200
 
diff --git a/debian/control b/debian/control
index 783ba3b..793b3de 100644
--- a/debian/control
+++ b/debian/control
@@ -52,26 +52,6 @@ Vcs-Browser: 
http://anonscm.debian.org/gitweb/?p=pkg-grass/mapserver.git
 Vcs-Git: git://anonscm.debian.org/pkg-grass/mapserver.git
 Homepage: http://www.mapserver.org
 
-Package: libmapserver
-Architecture: all
-Section: oldlibs
-Depends: libmapserver1,
-         ${misc:Depends}
-Description: Dummy package for libmapserver to libmapserver1 transition
- This is a transitional dummy package to ease upgrades from the
- libmapserver package to the libmapserver1 package.
- It can safely be removed.
-
-Package: libmapserver-6.2.1
-Architecture: all
-Section: oldlibs
-Depends: libmapserver1,
-         ${misc:Depends}
-Description: Dummy package for libmapserver-6.2.1 to libmapserver1 transition
- This is a transitional dummy package to ease upgrades from the
- libmapserver-6.2.1 package to the libmapserver1 package.
- It can safely be removed.
-
 Package: libmapserver1
 Architecture: any
 Section: libs
@@ -85,10 +65,6 @@ Suggests: cgi-mapserver,
           python-mapscript,
           ruby-mapscript
 Pre-Depends: ${misc:Pre-Depends}
-Breaks: libmapserver (<< 6.2.1-3~),
-        libmapserver-6.2.1 (<< 6.4.0-1~)
-Replaces: libmapserver (<< 6.2.1-3~),
-          libmapserver-6.2.1 (<< 6.4.0-1~)
 Description: Shared library for MapServer
  This package contains the shared library.
  .
@@ -97,26 +73,6 @@ Description: Shared library for MapServer
  functionality in MapScript is provided by the suggested mapscript
  library packages.
 
-Package: libmapserver-dev
-Architecture: all
-Section: oldlibs
-Depends: libmapserver1-dev,
-         ${misc:Depends}
-Description: Transitional dummy package for libmapserver1-dev
- This is a transitional dummy package to ease upgrades from the
- libmapserver-dev package to the libmapserver1-dev package.
- It can safely be removed.
-
-Package: libmapserver-6.2.1-dev
-Architecture: all
-Section: oldlibs
-Depends: libmapserver1-dev,
-         ${misc:Depends}
-Description: Dummy package for libmapserver1-dev transition
- This is a transitional dummy package to ease upgrades from the
- libmapserver-6.2.1-dev package to the libmapserver1-dev package.
- It can safely be removed.
-
 Package: libmapserver1-dev
 Architecture: any
 Section: libdevel

-- 
Packaging for MapServer

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to