Source: mapserver
Version: 6.4.0-1
Severity: serious
Justification: fails to build from source

The automated builds of mapserver on i386 and kfreebsd-i386 failed:

  -- Found Perl: /usr/bin/perl (found version "5.18.1") 
  CMake Error at 
/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
    Could NOT find PerlLibs (missing: PERL_LIBRARY)
  Call Stack (most recent call first):
    cmake/FindPerlLibs.cmake:278 (find_package_handle_standard_args)
    mapscript/perl/CMakeLists.txt:4 (FIND_PACKAGE)

I'd suggest declaring a build dependency on libperl-dev.  (I'm not
sure offhand why this wasn't an issue elsewhere; i386 is unusual in
shipping only a static libperl, but I didn't think kfreebsd-i386
worked the same way, and regardless I'd expect Perl's headers to be

At any rate, could you please take a look?


Pkg-grass-devel mailing list

Reply via email to