The following commit has been merged in the master branch:
commit ba5465a9638e7f535f0ac0087ed617abd694f420
Author: Markus Wanner <mar...@bluegap.ch>
Date:   Mon Sep 30 11:37:46 2013 +0200

    Rename pg-X.Y-postgis-2.1-scripts package to exclude PostGIS version
    number.

diff --git a/debian/changelog b/debian/changelog
index ff238c8..1a9017a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
 postgis (2.1.0-4) UNRELEASED; urgency=low
 
+  * Rename pg-X.Y-postgis-2.1-scripts package to exclude PostGIS version
+    number.
   * Add transitional postgis-2.0-scripts packages for all Pg versions ever
     supported. These effectively remove scripts and the postgis.control
     file prior to installing a newer *-postgis-2.1-scrips package, which
diff --git a/debian/control b/debian/control
index 3ebcf17..9f55759 100644
--- a/debian/control
+++ b/debian/control
@@ -139,7 +139,7 @@ Description: PostGIS for PostgreSQL 9.2 -- scripts -- dummy 
package
 
 Package: postgresql-9.3-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-9.3,
- postgresql-9.3-postgis-2.1-scripts, liblwgeom-2.1.0,
+ postgresql-9.3-postgis-scripts, liblwgeom-2.1.0,
  ${misc:Depends}
 Recommends: postgis
 Breaks: postgis (<< 1.2.1)
@@ -154,7 +154,7 @@ Description: Geographic objects support for PostgreSQL 9.3
  .
  This package supports PostgreSQL 9.3.
 
-Package: postgresql-9.3-postgis-2.1-scripts
+Package: postgresql-9.3-postgis-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-9.3-postgis-2.1
diff --git a/debian/control.in b/debian/control.in
index 7c4b857..7de542a 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -103,7 +103,7 @@ Description: PostGIS "Lightweight Geometry" library - 
Development files
 
 Package: postgresql-PGVERSION-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-PGVERSION,
- postgresql-PGVERSION-postgis-2.1-scripts, liblwgeom-2.1.0,
+ postgresql-PGVERSION-postgis-scripts, liblwgeom-2.1.0,
  ${misc:Depends}
 Recommends: postgis
 Breaks: postgis (<< 1.2.1)
@@ -118,12 +118,14 @@ Description: Geographic objects support for PostgreSQL 
PGVERSION
  .
  This package supports PostgreSQL PGVERSION.
 
-Package: postgresql-PGVERSION-postgis-2.1-scripts
+Package: postgresql-PGVERSION-postgis-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-PGVERSION-postgis-2.1
-Replaces: postgresql-PGVERSION-postgis-2.0-scripts (<< 2.1.0~)
-Breaks: postgresql-PGVERSION-postgis-2.0-scripts (<< 2.1.0~)
+Replaces: postgresql-PGVERSION-postgis-2.0-scripts (<< 2.1.0~),
+ postgresql-PGVERSION-postgis-2.1-scripts (<< 2.1.0-4~)
+Breaks: postgresql-PGVERSION-postgis-2.0-scripts (<< 2.1.0~),
+ postgresql-PGVERSION-postgis-2.1-scripts (<< 2.1.0-4~)
 Description: Geographic objects support for PostgreSQL PGVERSION -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS "spatially enables"
@@ -135,6 +137,16 @@ Description: Geographic objects support for PostgreSQL 
PGVERSION -- scripts
  This package contains SQL scripts to upgrade from earlier PostGIS
  versions for PostgreSQL PGVERSION as well as Perl utility scripts.
 
+Package: postgresql-PGVERSION-postgis-2.1-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL PGVERSION -- scripts -- dummy package
+ This package contained SQL scripts to upgrade from earlier PostGIS
+ versions for PostgreSQL PGVERSION as well as Perl utility scripts.
+ It got renamed to postgresql-PGVERSION-postgis-scripts.
+ .
+ This is a transitional dummy package. It can safely be removed.
+
 Package: postgresql-8.4-postgis-2.0-scripts
 Architecture: all
 Depends: ${misc:Depends}
diff --git a/debian/postgresql-generic-postgis-2.1-scripts.install.in 
b/debian/postgresql-generic-postgis-scripts.install.in
similarity index 100%
rename from debian/postgresql-generic-postgis-2.1-scripts.install.in
rename to debian/postgresql-generic-postgis-scripts.install.in
diff --git a/debian/rules b/debian/rules
index 65ca336..f7e4c8b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -186,7 +186,7 @@ clean: debian/control
                raster/rt_pg/rtpostgis_drop.sql \
                raster/rt_pg/rtpostgis_upgrade_cleanup.sql
        rm -f $(CURDIR)/debian/postgresql-*-postgis-2.1.install
-       rm -f $(CURDIR)/debian/postgresql-*-postgis-2.1-scripts.install
+       rm -f $(CURDIR)/debian/postgresql-*-postgis-scripts.install
        rm -f loader/cunit/cu_tester
        rm -rf liblwgeom/cunit/.libs
 
@@ -255,9 +255,9 @@ install-arch: build-arch
                cat $(CURDIR)/debian/postgresql-generic-postgis-2.1.install.in \
                        | sed -e "s/@PGVERSION@/$$PGVER/" \
                        > 
$(CURDIR)/debian/postgresql-$$PGVER-postgis-2.1.install; \
-               cat 
$(CURDIR)/debian/postgresql-generic-postgis-2.1-scripts.install.in \
+               cat 
$(CURDIR)/debian/postgresql-generic-postgis-scripts.install.in \
                        | sed -e "s/@PGVERSION@/$$PGVER/" \
-                       > 
$(CURDIR)/debian/postgresql-$$PGVER-postgis-2.1-scripts.install; \
+                       > 
$(CURDIR)/debian/postgresql-$$PGVER-postgis-scripts.install; \
        done)
 
 #      Copy binaries from the NEWEST_POSTGRES_VERSION build to the

-- 
PostGIS for PostgreSQL

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to