Your message dated Wed, 09 Oct 2013 11:48:18 +0200
with message-id <1381312098.4580.175.camel@celpetit>
and subject line Re: 3D support not working for sun-java6
has caused the Debian Bug report #651315,
regarding gpsprune: 3D support not working, causes thread exception - no 
j3dcore-ogl in java.library.path
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
651315: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=651315
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: gpsprune
Version: 13.1-1
Severity: important

I've just started to use gpsprune (for which many thanks), and I find that
the 3D support fails, with the following exception.

I do I have the library installed:

diz $ dlocate j3dcore-ogl
libjava3d-jni: /usr/lib/jni/libj3dcore-ogl.so


thanks much indeed.

cheers
calum.

Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: no 
j3dcore-ogl in java.library.path
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1738)
        at java.lang.Runtime.loadLibrary0(Runtime.java:823)
        at java.lang.System.loadLibrary(System.java:1028)
        at javax.media.j3d.NativePipeline$1.run(NativePipeline.java:231)
        at java.security.AccessController.doPrivileged(Native Method)
        at javax.media.j3d.NativePipeline.loadLibrary(NativePipeline.java:200)
        at javax.media.j3d.NativePipeline.loadLibraries(NativePipeline.java:157)
        at javax.media.j3d.MasterControl.loadLibraries(MasterControl.java:987)
        at javax.media.j3d.VirtualUniverse.<clinit>(VirtualUniverse.java:299)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:169)
        at 
tim.prune.threedee.WindowFactory.isJava3dEnabled(WindowFactory.java:41)
        at tim.prune.threedee.WindowFactory.getWindow(WindowFactory.java:19)
        at 
tim.prune.function.ShowThreeDFunction.begin(ShowThreeDFunction.java:38)
        at 
tim.prune.gui.FunctionLauncher.actionPerformed(FunctionLauncher.java:30)
        at 
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
        at 
javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
        at 
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
        at 
javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
        at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
        at 
javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:809)
        at 
javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:850)
        at java.awt.Component.processMouseEvent(Component.java:6288)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
        at java.awt.Component.processEvent(Component.java:6053)
        at java.awt.Container.processEvent(Container.java:2041)
        at java.awt.Component.dispatchEventImpl(Component.java:4651)
        at java.awt.Container.dispatchEventImpl(Container.java:2099)
        at java.awt.Component.dispatchEvent(Component.java:4481)
        at 
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4577)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
        at java.awt.Container.dispatchEventImpl(Container.java:2085)
        at java.awt.Window.dispatchEventImpl(Window.java:2478)
        at java.awt.Component.dispatchEvent(Component.java:4481)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:643)
        at java.awt.EventQueue.access$000(EventQueue.java:84)
        at java.awt.EventQueue$1.run(EventQueue.java:602)
        at java.awt.EventQueue$1.run(EventQueue.java:600)
        at java.security.AccessController.doPrivileged(Native Method)
        at 
java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
        at 
java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
        at java.awt.EventQueue$2.run(EventQueue.java:616)
        at java.awt.EventQueue$2.run(EventQueue.java:614)
        at java.security.AccessController.doPrivileged(Native Method)
        at 
java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:613)
        at 
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
        at 
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at 
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 3.1.4 (PREEMPT)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gpsprune depends on:
ii  libmetadata-extractor-java     2.3.1+dfsg-2
ii  sun-java6-jre [java6-runtime]  6.26-3

Versions of packages gpsprune recommends:
ii  gnuplot                 4.4.0-1.1
ii  gpsbabel                1.4.2-3
ii  libimage-exiftool-perl  8.60-2
ii  libjava3d-java          1.5.2+dfsg-7
ii  libjava3d-jni           1.5.2+dfsg-7
ii  libvecmath-java         1.5.2-3

gpsprune suggests no packages.

-- debconf-show failed



--- End Message ---
--- Begin Message ---
On Wed, 2013-10-02 at 13:58 +0200, Mònica Ramírez Arceda wrote: 
> Hi!
> 
> On Tue, 2013-03-26 at 20:29 +0100, deb...@activityworkshop.net wrote: 
> > Thanks, Michael, for doing the investigative work!
> > 
> > At the moment it looks like there's nothing we can do for squeeze (as 
> > it's frozen), and there's nothing we need to do for wheezy (because 
> > sun-java6 isn't in wheezy).
> > 
> > For those who are still having this problem, there are various 
> > solutions:
> > - Symlink the java3d components into the sun-java6 installation (ugly 
> > solution perhaps but then it works everywhere)
> > - Patch the launch script yourself (or make a new one) to add the 
> > library path to the java command:
> >    java -Djava.library.path=/usr/lib/jni ...
> > - add Michael's line export LD_LIBRARY_PATH=/usr/lib/jni either to the 
> > launch script or to a user-specific .bashrc
> > - apparently switching to openjdk6 also fixes the problem (according to 
> > the linked thread)
> > 
> > So I'm not sure if this bug should be closed or not, but it doesn't 
> > look like it can be fixed.
> 
> You're right, I can't reproduce this bug in unstable. 
> 
> So, I propose to wait for a week to see if anyone can reproduce this bug
> in Debian sid. If anybody can't reproduce it, I'll close the bug.

Closing this bug.
Feel free to reopen it, if it can be reproduced again.

Cheers

Attachment: signature.asc
Description: This is a digitally signed message part


--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to