Package: src:nco
Version: 4.0.9-1
Severity: normal
Usertags: arm64

The package fails to build on arm64 (aarch64-linux-gnu), because the
config.{guess,sub} files are out of date, and are not updated during
the build.  If possible, please do not update these files directly,
but build-depend on autotools-dev instead, and use the tools provided
by autotools-dev to update these files.

  - For dh, call dh --with autotools_dev (yes, underscore).

  - For other rules files, call dh_autotools-dev_updateconfig before
    calling configure (in the build or configure target), and call
    dh_autotools-dev_restoreconfig before calling dh_clean in the clean

After the build on any architecture, and before a clean, a grep for
aarch64 in the config.sub file(s) should print some lines.

The full build log can be found at:
The last lines of the build log are at the end of this report.

Please note that these build were done in an Ubuntu development,
environment there may be a few false positives in these bug reports.

Adding debian:Visa_eCommerce_Root.pem
Adding debian:WellsSecure_Public_Root_Certificate_Authority.pem
Adding debian:Wells_Fargo_Root_CA.pem
Adding debian:XRamp_Global_CA_Root.pem
Adding debian:certSIGN_ROOT_CA.pem
Adding debian:ePKI_Root_Certification_Authority.pem
Adding debian:thawte_Primary_Root_CA.pem
Adding debian:thawte_Primary_Root_CA_-_G2.pem
Adding debian:thawte_Primary_Root_CA_-_G3.pem
Adding debian:spi-cacert-2008.pem
Checking correctness of source dependencies...
Toolchain package versions: libc6-dev_2.17-93ubuntu4 make_3.81-8.2ubuntu3 
dpkg-dev_1.16.12ubuntu1 gcc-4.8_4.8.1-10ubuntu8 g++-4.8_4.8.1-10ubuntu8 
binutils_2.23.52.20130913-0ubuntu1 libstdc++-4.8-dev_4.8.1-10ubuntu8 
dpkg-source: warning: -sn is not a valid option for 
gpgv: Signature made Sat Jun  2 13:45:01 2012 UTC using RSA key ID B913E271
gpgv: Can't check signature: public key not found
dpkg-source: warning: failed to verify signature on ./nco_4.0.9-1build1.dsc
dpkg-source: info: extracting nco in nco-4.0.9
dpkg-source: info: unpacking nco_4.0.9.orig.tar.gz
dpkg-source: info: unpacking nco_4.0.9-1build1.debian.tar.gz
dpkg-buildpackage: source package nco
dpkg-buildpackage: source version 4.0.9-1build1
 dpkg-source --before-build nco-4.0.9
dpkg-buildpackage: host architecture arm64
 /usr/bin/fakeroot debian/rules clean
rm -f build-arch-stamp build-indep-stamp config-stamp
[ ! -f Makefile ] || /usr/bin/make distclean
rm -f data/
 debian/rules build-arch
LD_LIBRARY_PATH='' LDFLAGS='' NETCDF_INC='/usr/include' NETCDF_LIB='/usr/lib' 
NETCDF_ROOT='/usr' NETCDF4_ROOT='/usr' \
        ./configure --build=aarch64-linux-gnu --enable-dap-netcdf 
--enable-netcdf4 --enable-udunits2 \
                --prefix=/usr \
                --infodir=/usr/share/info \
                --libdir=/usr/lib/nco \
                --mandir=/usr/share/man \
                --enable-gsl \
                --enable-ncap2 \
                --disable-nco_cplusplus \
                --disable-udunits \
checking build system type... Invalid configuration `aarch64-linux-gnu': 
machine `aarch64' not recognized
configure: error: /bin/bash autobld/config.sub aarch64-linux-gnu failed
make: *** [config.status] Error 1
dpkg-buildpackage: error: debian/rules build-arch gave error exit status 2

Pkg-grass-devel mailing list

Reply via email to