Your message dated Tue, 24 Dec 2013 00:58:29 +0100
with message-id <52b8ce25.3080...@debian.org>
and subject line Re: Switch from serial to openmpi variant fails.
has caused the Debian Bug report #684995,
regarding Switch from serial to openmpi variant fails.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
684995: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=684995
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: hdf5
Version: 1.8.8-9
Severity: normal

Dear maintainer,

on Debian Wheezy I have libhdf5-7 installed. Now I tried to install
the openmpi variant, that also provides the same virtual name
libhdf5-1.8, but it failed.

# dpkg -i libhdf5-openmpi-7_1.8.8-9_amd64.deb
dpkg: regarding libhdf5-openmpi-7_1.8.8-9_amd64.deb containing
libhdf5-openmpi-7:
 libhdf5-openmpi-7 conflicts with libhdf5-1.8
  libhdf5-7 provides libhdf5-1.8 and is present and installed.
dpkg: error processing libhdf5-openmpi-7_1.8.8-9_amd64.deb (--install):
 conflicting packages - not installing libhdf5-openmpi-7
Errors were encountered while processing:
 libhdf5-openmpi-7_1.8.8-9_amd64.deb
#

For now libhdf5-openmpi-7 conflicts with and provides libhd5-7. Should
it rather replace the libhd5-7, but not conflict?

Thanks,
Andrey

--- End Message ---
--- Begin Message ---
Hi,

Andrey Gursky a écrit , Le 15/08/2012 17:30:
Package: hdf5
Version: 1.8.8-9
Severity: normal

Dear maintainer,

on Debian Wheezy I have libhdf5-7 installed. Now I tried to install
the openmpi variant, that also provides the same virtual name
libhdf5-1.8, but it failed.

# dpkg -i libhdf5-openmpi-7_1.8.8-9_amd64.deb
dpkg: regarding libhdf5-openmpi-7_1.8.8-9_amd64.deb containing
libhdf5-openmpi-7:
  libhdf5-openmpi-7 conflicts with libhdf5-1.8
   libhdf5-7 provides libhdf5-1.8 and is present and installed.
dpkg: error processing libhdf5-openmpi-7_1.8.8-9_amd64.deb (--install):
  conflicting packages - not installing libhdf5-openmpi-7
Errors were encountered while processing:
  libhdf5-openmpi-7_1.8.8-9_amd64.deb
#

For now libhdf5-openmpi-7 conflicts with and provides libhd5-7. Should
it rather replace the libhd5-7, but not conflict?

dpkg can't solve conflicts. apt-get can:
(cowbuilder-wheezy)root@pini:~# dpkg -l | grep libhdf5
(cowbuilder-wheezy)root@pini:~# apt-get install libhdf5-7
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libgfortran3
The following NEW packages will be installed:
  libgfortran3 libhdf5-7
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 1666 kB of archives.
After this operation, 4920 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://ftp.fr.debian.org/debian/ wheezy/main libgfortran3 i386 4.7.2-5 [335 kB] Get:2 http://ftp.fr.debian.org/debian/ wheezy/main libhdf5-7 i386 1.8.8-9 [1331 kB]
Fetched 1666 kB in 1s (1641 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package libgfortran3:i386.
(Reading database ... 12081 files and directories currently installed.)
Unpacking libgfortran3:i386 (from .../libgfortran3_4.7.2-5_i386.deb) ...
Selecting previously unselected package libhdf5-7.
Unpacking libhdf5-7 (from .../libhdf5-7_1.8.8-9_i386.deb) ...
Setting up libgfortran3:i386 (4.7.2-5) ...
Setting up libhdf5-7 (1.8.8-9) ...
(cowbuilder-wheezy)root@pini:~# apt-get install libhdf5-openmpi-7
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  adduser libibverbs1 libnuma1 libopenmpi1.3 libtorque2
The following packages will be REMOVED:
  libhdf5-7
The following NEW packages will be installed:
  adduser libhdf5-openmpi-7 libibverbs1 libnuma1 libopenmpi1.3 libtorque2
0 upgraded, 6 newly installed, 1 to remove and 0 not upgraded.
Need to get 3190 kB of archives.
After this operation, 5374 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://ftp.fr.debian.org/debian/ wheezy/main adduser all 3.113+nmu3 [264 kB] Get:2 http://ftp.fr.debian.org/debian/ wheezy/main libnuma1 i386 2.0.8~rc4-1 [34.7 kB] Get:3 http://ftp.fr.debian.org/debian/ wheezy/main libtorque2 i386 2.4.16+dfsg-1+deb7u2 [116 kB] Get:4 http://ftp.fr.debian.org/debian/ wheezy/main libibverbs1 i386 1.1.6-1 [35.9 kB] Get:5 http://ftp.fr.debian.org/debian/ wheezy/main libopenmpi1.3 i386 1.4.5-1 [1384 kB] Get:6 http://ftp.fr.debian.org/debian/ wheezy/main libhdf5-openmpi-7 i386 1.8.8-9 [1356 kB]
Fetched 3190 kB in 2s (1327 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
(Reading database ... 12099 files and directories currently installed.)
Removing libhdf5-7 ...
Selecting previously unselected package adduser.
(Reading database ... 12084 files and directories currently installed.)
Unpacking adduser (from .../adduser_3.113+nmu3_all.deb) ...
Selecting previously unselected package libnuma1.
Unpacking libnuma1 (from .../libnuma1_2.0.8~rc4-1_i386.deb) ...
Selecting previously unselected package libtorque2.
Unpacking libtorque2 (from .../libtorque2_2.4.16+dfsg-1+deb7u2_i386.deb) ...
Selecting previously unselected package libibverbs1.
Unpacking libibverbs1 (from .../libibverbs1_1.1.6-1_i386.deb) ...
Selecting previously unselected package libopenmpi1.3.
Unpacking libopenmpi1.3 (from .../libopenmpi1.3_1.4.5-1_i386.deb) ...
Selecting previously unselected package libhdf5-openmpi-7.
Unpacking libhdf5-openmpi-7 (from .../libhdf5-openmpi-7_1.8.8-9_i386.deb) ...
Setting up adduser (3.113+nmu3) ...
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog based frontend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 76.)
debconf: falling back to frontend: Readline
Setting up libnuma1 (2.0.8~rc4-1) ...
Setting up libtorque2 (2.4.16+dfsg-1+deb7u2) ...
Setting up libibverbs1 (1.1.6-1) ...
Setting up libopenmpi1.3 (1.4.5-1) ...
Setting up libhdf5-openmpi-7 (1.8.8-9) ...
(cowbuilder-wheezy)root@pini:~#


Closing this bug which actually isn't one.

Thanks,

_g.

--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to