Package: geographiclib
Version: 1.21-1
Severity: normal
Tags: patch
User: ubuntu-de...@lists.ubuntu.com
Usertags: origin-ubuntu trusty ubuntu-patch

Dear Maintainer,

For the ppc64el architecture in Ubuntu, since this package uses libtool, a full
autoreconf is necessary instead of just config.{sub,guess} updates with
autotools-dev. This is because we need new libtool macros for ppc64el.

In Ubuntu, the attached patch was applied to achieve the following:

  * Use dh-autoreconf instead of autotools-dev to fix FTBFS on ppc64el.

Thanks for considering the patch.

Logan Rosen



-- System Information:
Debian Release: jessie/sid
  APT prefers trusty-updates
  APT policy: (500, 'trusty-updates'), (500, 'trusty-security'), (500, 
'trusty'), (100, 'trusty-backports')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.13.0-1-generic (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
diff -Nru geographiclib-1.21/debian/control geographiclib-1.21/debian/control
--- geographiclib-1.21/debian/control	2012-05-24 11:05:48.000000000 -0400
+++ geographiclib-1.21/debian/control	2014-01-11 13:47:32.000000000 -0500
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Francesco Paolo Lovergine <fran...@debian.org>
-Build-Depends: cdbs, debhelper (>= 8), autotools-dev, doxygen, python-all
+Build-Depends: cdbs, debhelper (>= 8), dh-autoreconf, doxygen, python-all
 Standards-Version: 3.9.3
 Homepage: http://geographiclib.sf.net/
 Vcs-Browser: http://git.debian.org/?p=pkg-grass/geographiclib.git
diff -Nru geographiclib-1.21/debian/rules geographiclib-1.21/debian/rules
--- geographiclib-1.21/debian/rules	2012-05-24 11:05:48.000000000 -0400
+++ geographiclib-1.21/debian/rules	2014-01-09 00:25:08.000000000 -0500
@@ -2,6 +2,7 @@
 
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/autoreconf.mk
 
 DEB_PYTHON_DISTUTILS_SRCDIR = python
 DEB_PYTHON2_MODULE_PACKAGES = python-geographiclib
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to