Dear maintainer,

Your package still uses ruby1.8, which is unmaintainable at this point. We
can't keep ruby1.8 around for Jessie. We plan to request its removal in 4

Recommendations for some common cases:

If your package contains Ruby programs that are hardcoded to use
ruby1.8, you need to port those to a more recent version. Please use
/usr/bin/ruby instead. Please do not change to /usr/bin/ruby1.9.1

If your package calls `ruby1.8` during build, please make it call
`ruby` instead. If your scripts don't work with a newer Ruby, you need
to port them.  Please do not change `ruby1.8` to `ruby1.9.1` as it
will require more work later when we want to get rid of ruby1.9.1 (and
we will).

If your packages builds binary extensions for ruby1.8, you need to
remove those. Please consider building binary extensions for all
supported Ruby versions. You can get a list of supported Ruby versions
at runtime by build-depending on gem2deb and running

  $ dh_ruby --print-supported

I'm flagging this bug as release critical, since it's impossible to
have ruby1.8 in the next release.

If you need advice on the best way to handle your package, please feel
free to get in touch with

Antonio Terceiro <>

Attachment: signature.asc
Description: Digital signature

Pkg-grass-devel mailing list

Reply via email to