Your message dated Sun, 19 Jan 2014 23:19:06 +0000
with message-id <e1w51dy-0002du...@franck.debian.org>
and subject line Bug#649352: fixed in postgis 2.1.1-4
has caused the Debian Bug report #649352,
regarding postgis: HTML documentation resources not installed
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
649352: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=649352
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Subject: postgis: HTML documentation resources not installed
Package: postgis
Version: 1.5.3-1
Severity: minor
Tags: upstream patch

Dear Maintainer,

The HTML postgis help is install to
/usr/share/doc/postgis/postgis/postgis.html but the accompanying
style.css and images are not installed.

The attached patch against the current HEAD of
git.debian.org/pkg-grass/postgis.git fixes the issue.

It would seem that this is an upstream problem, but I've solved it
with a patch at Debian build time.
From bab23ae7696d1a2f23620263420f0a61dde0e753 Mon Sep 17 00:00:00 2001
From: Andrew Harvey <andrew.harv...@gmail.com>
Date: Sun, 20 Nov 2011 20:12:48 +1100
Subject: [PATCH] Install HTML documentation resources

---
 debian/patches/html_doc_resources |   19 +++++++++++++++++++
 debian/patches/series             |    1 +
 2 files changed, 20 insertions(+), 0 deletions(-)
 create mode 100644 debian/patches/html_doc_resources

diff --git a/debian/patches/html_doc_resources b/debian/patches/html_doc_resources
new file mode 100644
index 0000000..72ad6b5
--- /dev/null
+++ b/debian/patches/html_doc_resources
@@ -0,0 +1,19 @@
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -134,12 +134,16 @@
+ 	@mkdir -p $(PGSQL_DOCDIR)/postgis
+ 	@mkdir -p $(PGSQL_MANDIR)/man1
+ 	cp html/postgis.html $(PGSQL_DOCDIR)/postgis/postgis.html
++	cp html/style.css $(PGSQL_DOCDIR)/postgis/style.css
++	cp -r html/images $(PGSQL_DOCDIR)/postgis/
+ 	cp ../README.postgis $(PGSQL_DOCDIR)/postgis/README.postgis
+ 	cp man/pgsql2shp.1 $(PGSQL_MANDIR)/man1/pgsql2shp.1
+ 	cp man/shp2pgsql.1 $(PGSQL_MANDIR)/man1/shp2pgsql.1
+ 
+ uninstall:
+ 	rm -f $(PGSQL_DOCDIR)/postgis/postgis.html
++	rm -f $(PGSQL_DOCDIR)/postgis/style.css
++	rm -rf $(PGSQL_DOCDIR)/postgis/images
+ 	rm -f $(PGSQL_DOCDIR)/postgis/README.postgis
+ 	rm -f $(PGSQL_MANDIR)/man1/shp2pgsql.1
+ 	rm -f $(PGSQL_MANDIR)/man1/pgsql2shp.1
diff --git a/debian/patches/series b/debian/patches/series
index 9d74090..5deccea 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
 install
 generator
+html_doc_resources
-- 
1.7.7.3


--- End Message ---
--- Begin Message ---
Source: postgis
Source-Version: 2.1.1-4

We believe that the bug you reported is fixed in the latest version of
postgis, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 649...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Markus Wanner <mar...@bluegap.ch> (supplier of updated postgis package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sun, 19 Jan 2014 15:48:48 +0100
Source: postgis
Binary: postgis postgis-doc libpostgis-java liblwgeom-2.1.1 liblwgeom-dev 
postgresql-9.3-postgis-2.1 postgresql-9.3-postgis-scripts 
postgresql-9.3-postgis-2.1-scripts
Architecture: source i386 all
Version: 2.1.1-4
Distribution: unstable
Urgency: low
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: Markus Wanner <mar...@bluegap.ch>
Description: 
 liblwgeom-2.1.1 - PostGIS "Lightweight Geometry" library
 liblwgeom-dev - PostGIS "Lightweight Geometry" library - Development files
 libpostgis-java - Geographic objects support for PostgreSQL -- JDBC support
 postgis    - Geographic objects support for PostgreSQL
 postgis-doc - Geographic objects support for PostgreSQL -- documentation
 postgresql-9.3-postgis-2.1 - Geographic objects support for PostgreSQL 9.3
 postgresql-9.3-postgis-2.1-scripts - PostGIS for PostgreSQL 9.3 -- scripts -- 
dummy package
 postgresql-9.3-postgis-scripts - Geographic objects support for PostgreSQL 9.3 
-- scripts
Closes: 649352
Changes: 
 postgis (2.1.1-4) unstable; urgency=low
 .
   * Drop an unneeded fixmakedoc patch.
   * Add style.css and images to postgis-doc. Closes: #649352.
Checksums-Sha1: 
 fe965e447e6fede2ef0297b81e0abf3ee10edf44 3751 postgis_2.1.1-4.dsc
 1c60d71094f622fb685ae8634d3bdc6ae855eb81 26276 postgis_2.1.1-4.debian.tar.xz
 b8ca31666e0ba480c4bef198807385dabc7f49aa 485868 postgis_2.1.1-4_i386.deb
 ea4e1a1e10f0e668d93e60e8d7ee45bdb99bcf41 482128 
liblwgeom-2.1.1_2.1.1-4_i386.deb
 b2a41e54b7e5929dc8c5b09b8dd4f896d1e90ba4 505554 liblwgeom-dev_2.1.1-4_i386.deb
 fe8640c70a95dd5d9b186867b137008139b6f4b0 565148 
postgresql-9.3-postgis-2.1_2.1.1-4_i386.deb
 118dbcbc81ebd1279a517a26cfad240a0d0e7112 2968338 postgis-doc_2.1.1-4_all.deb
 31dc99be94988a67f73ec3047f48ca4e87195af8 408140 libpostgis-java_2.1.1-4_all.deb
 bd930c3fef0206bcd637e608c1590f18eacb2206 690736 
postgresql-9.3-postgis-scripts_2.1.1-4_all.deb
 0aca1046eafa2e5f6adf480ce1d0cb4aea378ea8 337280 
postgresql-9.3-postgis-2.1-scripts_2.1.1-4_all.deb
Checksums-Sha256: 
 8159eee6cc555c07be181eceb13c455248ebed4d19b469f3f5a0625b1c1bd82c 3751 
postgis_2.1.1-4.dsc
 9a80d49e71abfae5147ae706fd11049695cf3929aec022ac2477d6c550eb5cb5 26276 
postgis_2.1.1-4.debian.tar.xz
 4236b98c41bd2a556330ec3992a61746c3db11cd311666953fda2d5d911c7c12 485868 
postgis_2.1.1-4_i386.deb
 098f4a8dc6f2b0766509891f3f8929eb1bac9fb1604a740ea2adc9f48c2ad64f 482128 
liblwgeom-2.1.1_2.1.1-4_i386.deb
 5cd03073118e0fb2007a788ced5650f9d8fa9f00fe8fa0f7829b0d2dc2544563 505554 
liblwgeom-dev_2.1.1-4_i386.deb
 47248139526731af1423a5e214b7822ab4c8629c2fc0ac76ef1efac60c19eb14 565148 
postgresql-9.3-postgis-2.1_2.1.1-4_i386.deb
 b74f757533799245a001f82cc95b3dc4c46260d9807edf4d4e61cdb89345c37e 2968338 
postgis-doc_2.1.1-4_all.deb
 a77569d36dfc5009554c2234277ee145002a297077f9a0a036bd8d49ce5dc3b7 408140 
libpostgis-java_2.1.1-4_all.deb
 3b0bcd090ae880b49e83f0b7c54acd5ada2f40356db4e37dca384c08ac79c82f 690736 
postgresql-9.3-postgis-scripts_2.1.1-4_all.deb
 18ac2c242f5efed550065aeaba19981735988298356731be783d85705bf9fe6e 337280 
postgresql-9.3-postgis-2.1-scripts_2.1.1-4_all.deb
Files: 
 cb88fae0281841be49a150ea935d898c 3751 misc optional postgis_2.1.1-4.dsc
 fe16ece5437468e62ece1ea2f22cacc9 26276 misc optional 
postgis_2.1.1-4.debian.tar.xz
 dce39adc6649c420a219e43ea27b84d7 485868 misc optional postgis_2.1.1-4_i386.deb
 02a133956e870964a143336d15d1f6cb 482128 libs optional 
liblwgeom-2.1.1_2.1.1-4_i386.deb
 31284765b8349b55cb703177dab0be13 505554 libdevel optional 
liblwgeom-dev_2.1.1-4_i386.deb
 2a1dbfaa926de78b34f8b670fe86e0fe 565148 misc optional 
postgresql-9.3-postgis-2.1_2.1.1-4_i386.deb
 438396884d830773236be5f71b9aedae 2968338 doc optional 
postgis-doc_2.1.1-4_all.deb
 cf0dd738ea8b04395f457a17233d8f8a 408140 java optional 
libpostgis-java_2.1.1-4_all.deb
 e9b8d6eef89ab1098f56375ea49e433a 690736 misc optional 
postgresql-9.3-postgis-scripts_2.1.1-4_all.deb
 85ddbc96d68e69ebfa5b991c8c230061 337280 misc optional 
postgresql-9.3-postgis-2.1-scripts_2.1.1-4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.15 (GNU/Linux)

iQQcBAEBCgAGBQJS3FkYAAoJEOhoLRs/MemzR84f/0cpTD2Jgqn33PWA2avh4GVV
SUTf5f8NhclaKE83TyLqQdag1CdGu6c9tcEq5dq9fbGjiuaRAT+G2Vrjd7ZlW/z/
8duJ+TTkByj/JEqHtKIU/Oqp4ISoSsEcq/oDGfYzaJKoasbc0JitCYccH9HoQ5rA
iWevgWjczg8WOOKINczP/mkxjO699CDkNkjCoGghKrmGCh4n0enmOU1Gxa/xSkHL
xni1dCSPHgdGZApsmN6MIo7RZO3vlN/0wzlZjlLkQFdrV81Yk+E8jUgr2VQQg1Hb
ASzg/BdgC0B/LW9cPSUee7PPWJiD/xVCuTAEqZ4fZKewYk3pFT6Ch+7xbttdX2pb
C/2H7h5L4Qyd4njPvvrpNc4DJVVCTNDH0fyp/MmRiwqt7wudz2CUUfu8Wo+LvUSO
WrIvHRPY3KWBzYjmrWmkiSSJ9fqK6gBEk/aR8WBD4iepTF+9U6ZcnsqD7Yp0QlR1
T37Ye9RSdSgIS7ZEVBI0EsdoPOerBO/KWf6cr/2EUbfOf+UCuEBDy1zzW3PAWiyO
Oh012ZSsLuNUlaHWFYiNFEq6X11WiCRztJDvdsCnlh2+3DmvyFRMVDEheQ1rU1/W
GmPtVdQ6ATIvZVrAojBHRngWwkvFy/T9OS7VNECkdNWMPEVqCri32tz+8N8YZ1yw
F1DiC+wzs4k4l0vtqeNEyYh6Ul/M2JRkBtMIuV5U0dyfuOw7hnjS1O9G8Y4LgyP4
8cDVzcb0Et/tNmEbv4HTfoc4LF3OP1+4Dov43zPDyadcSr3Ve92JaFulzLfduRhf
gEUqz8lRp5GoFdZ8FnAwBroVvh2LooCvMfxd2N/8lj5cvo3N0wBJ0reKwW+3nLJr
GLSk/JEMXx+mAKc0Z1WpU8py3GybWCpTB3nGrbjZ2AZXsA0SgVhTAGTATa6dpEVZ
kb5fhYcxFNtC6otNBrSxNYRdoypmD0TnSFhLr9xomNREUXADy6HzZrJ4LGeSSP1B
pB0xHJe90iDdwiE36EGJ7+YAVritqRRN7qhIWja2HUTdOagyQh6dy9QZiwfHEDwN
h4X85Ftw6lJPGDbf62TA/sDGQvg8lbkhqk2NDv2H4gB/VML1jahkgcakRc+F8Lzy
1+cHsoRIKpKfosoURc52uJqUScBMCvjX852cNE2JrRUnX12ng0VWAN3Sw7PQGFPa
Yl7QXz1+nXQETG9CutwimIANxa/sG63PPjq9NmPa3qD9C1m2Tw3N14UGvtbQ6CgT
c2BNqrs8eqXe9Ci4loUPXnvgJV2ZFMxyIv+ESaRTSIFyHdS6a1P+Zt7eOOHa7wQk
oF3Pj85zxUtLmBoWO8BytJiTXtMiMHpaJCxG+TyQnpQJ2MK1m9ljcUN66JgGu84=
=cITu
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to