Source: mapserver
Version: 6.4.1-1
Severity: normal

Dear Maintainer,

A new ruby-defaults, switching the default Ruby version to 2.0, will be
uploaded soon. (It is available in experimental for testing.)

During a test rebuild of rdepends with the new package, your package
failed to build.

If possible, please change your package in advance to support building
for Ruby 2.0, so when ruby-defaults is uploaded, only a binNMU is
needed.

Hopefully relevant log parts:
----------------------------------------------------------------------
CMake Error at 
/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
  Could NOT find Ruby (missing: RUBY_INCLUDE_DIR RUBY_LIBRARY
  RUBY_CONFIG_INCLUDE_DIR) (found version "2.0.0")
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 
(_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-2.8/Modules/FindRuby.cmake:239 
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  mapscript/ruby/CMakeLists.txt:3 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
----------------------------------------------------------------------

The full build log is available at:
http://aws-logs.debian.net/ftbfs-logs/ruby-defaults/failed-logs/mapserver_6.4.1-1_unstable.log.gz

Important changes from 1.9 to 2.0:
- location of ruby/config.h has changed; it's location is now available
  from:
  ruby -r rbconfig -e "print RbConfig::CONFIG['rubyarchhdrdir']"
- path for binary extensions has changed; it's location is now available
  from:
  ruby -r rbconfig -e "print RbConfig::CONFIG['vendorarchdir']"


Thank you,
Christian

-- 
 ,''`.  Christian Hofstaedtler <z...@debian.org>
: :' :  Debian Developer
`. `'   7D1A CFFA D9E0 806C 9C4C  D392 5C13 D6DB 9305 2E03
  `-

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to