Hi Christian,

Thanks for reporting this issue.

On 02/22/2014 01:54 PM, Christian Hofstaedtler wrote:
> A new ruby-defaults, switching the default Ruby version to 2.0, will be
> uploaded soon. (It is available in experimental for testing.)
> During a test rebuild of rdepends with the new package, your package
> failed to build.
> If possible, please change your package in advance to support building
> for Ruby 2.0, so when ruby-defaults is uploaded, only a binNMU is
> needed.

Supporting Ruby 2.0 is not straight forward. The FindRuby.cmake shipped
with CMake 2.8 doesn't search for Ruby 2.0 yet, so we'll need to at
least include a custom FindRuby.cmake in MapServer similar to the one
included in mod_ruby for instance:


The mapscript binding for Ruby doesn't have an upstream maintainer
anymore, so to keep supporting it in Debian may become too burdensome.

I'll try to fix the build with Ruby 2.0 using the packages from

Kind Regards,


Pkg-grass-devel mailing list

Reply via email to