This is an automated email from the git hooks/post-receive script.

sebastic-guest pushed a commit to branch master
in repository geos.

commit d07b919fae0e30574464d0a23909378ab8f727c2
Author: Bas Couwenberg <sebas...@xs4all.nl>
Date:   Sun Feb 16 20:52:40 2014 +0100

    Rename libgeos-ruby1.8 to ruby-geos, according to Ruby packaging policy.
---
 debian/changelog                                      |  1 +
 debian/control                                        | 13 +++++++++++++
 debian/control.in                                     | 13 +++++++++++++
 debian/{libgeos-ruby1.8.install => ruby-geos.install} |  0
 4 files changed, 27 insertions(+)

diff --git a/debian/changelog b/debian/changelog
index 9a3ff52..6624e2f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ geos (3.4.2-2) UNRELEASED; urgency=low
 
   * Add myself to Uploaders.
   * Restructure control file with cme, changes: Vcs-* fields.
+  * Rename libgeos-ruby1.8 to ruby-geos, according to Ruby packaging policy.
 
  -- Bas Couwenberg <sebas...@xs4all.nl>  Sun, 16 Feb 2014 20:11:38 +0100
 
diff --git a/debian/control b/debian/control
index 1d7c5ad..a6b1262 100644
--- a/debian/control
+++ b/debian/control
@@ -107,9 +107,22 @@ Homepage: http://download.osgeo.org/geos/doxygen/
 
 Package: libgeos-ruby1.8
 Architecture: any
+Section: oldlibs
+Depends: ruby-geos,
+         ${misc:Depends}
+Description: Transitional package from libgeos-ruby1.8 to ruby-geos
+ This is a transitional dummy package to ease upgrades from the
+ libgeos-ruby1.8 package to the ruby-geos package.
+ It can safely be removed.
+
+Package: ruby-geos
+Architecture: any
 Section: ruby
 Depends: ${shlibs:Depends},
          ${misc:Depends}
+Breaks: libgeos-ruby1.8 (<< 3.4.2-2~)
+Provides: libgeos-ruby1.8
+Replaces: libgeos-ruby1.8 (<< 3.4.2-2~)
 Description: GEOS bindings for Ruby
  GEOS provides a spatial object model and fundamental geometric
  functions. It implements the geometry model defined in the
diff --git a/debian/control.in b/debian/control.in
index 782bbe4..b939ac1 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -107,9 +107,22 @@ Homepage: http://download.osgeo.org/geos/doxygen/
 
 Package: libgeos-ruby1.8
 Architecture: any
+Section: oldlibs
+Depends: ruby-geos,
+         ${misc:Depends}
+Description: Transitional package from libgeos-ruby1.8 to ruby-geos
+ This is a transitional dummy package to ease upgrades from the
+ libgeos-ruby1.8 package to the ruby-geos package.
+ It can safely be removed.
+
+Package: ruby-geos
+Architecture: any
 Section: ruby
 Depends: ${shlibs:Depends},
          ${misc:Depends}
+Breaks: libgeos-ruby1.8 (<< 3.4.2-2~)
+Provides: libgeos-ruby1.8
+Replaces: libgeos-ruby1.8 (<< 3.4.2-2~)
 Description: GEOS bindings for Ruby
  GEOS provides a spatial object model and fundamental geometric
  functions. It implements the geometry model defined in the
diff --git a/debian/libgeos-ruby1.8.install b/debian/ruby-geos.install
similarity index 100%
rename from debian/libgeos-ruby1.8.install
rename to debian/ruby-geos.install

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/geos.git

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to