package postgis
tags 737497 + patch
thanks

On 03-Feb-2014, Ben Finney wrote:
> Administrating PostGIS requires understanding how it works and what it
> does. Please set a “Suggests: postgis-doc” dependency, so that
> administrators choosing to install ‘postgis’ will receive the suggestion.

The attached patch addresses this by adding “Suggests: postgis-doc”
relationships to two packages.

-- 
 \        “I knew it was a shocking thing to say, but … no-one has the |
  `\        right to spend their life without being offended.” —Philip |
_o__)                                              Pullman, 2010-03-28 |
Ben Finney <b...@benfinney.id.au>
diff --git a/debian/changelog b/debian/changelog
index 209d7f9..2fc8f3f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+postgis (2.1.1-7) UNRELEASED; urgency=low
+
+  [ Ben Finney ]
+  
+  * Some binary packages require an understanding of the PostGIS system;
+    add a “Suggests: postgis-doc” dependency.
+    (Closes: bug#737497)
+
+ --
+
 postgis (2.1.1-6) unstable; urgency=low
 
   * Recommend postgresql-contrib-M.N for the fuzzystrmatch
diff --git a/debian/control b/debian/control
index c8a973b..071033c 100644
--- a/debian/control
+++ b/debian/control
@@ -23,7 +23,9 @@ Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 Package: postgis
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: postgresql-9.3-postgis-2.1
+Suggests:
+    postgresql-9.3-postgis-2.1,
+    postgis-doc
 Description: Geographic objects support for PostgreSQL
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS "spatially enables"
@@ -106,6 +108,7 @@ Depends: ${shlibs:Depends}, postgresql-9.3,
  postgresql-9.3-postgis-scripts, liblwgeom-2.1.1,
  ${misc:Depends}
 Recommends: postgis, postgresql-contrib-9.3
+Suggests: postgis-doc
 Breaks: postgis (<< 1.2.1)
 Architecture: any
 Description: Geographic objects support for PostgreSQL 9.3

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to