Your message dated Mon, 31 Mar 2014 09:24:09 +0200
with message-id <53391819.1010...@bluegap.ch>
and subject line Bug#653111: postgresql-9.1-postgis: postgis dependencies are 
very strong
has caused the Debian Bug report #653111,
regarding postgresql-9.1-postgis: postgis dependencies are very strong
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
653111: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=653111
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Subject: postgresql-9.1-postgis: postgis dependencies are very strong
Package: postgresql-9.1-postgis
Version: 1.5.3-2
Severity: minor

Dear Maintainer,

Currently postgresql-9.1-postgis depends on postgis, and postgis
includes the gui application shp2pgsql-gui. This means that to install
the postgresql-9.1-postgis package I need to pull in gtk and other
dependencies for running a graphical application. For this reason I
think it would make sense to separate out shp2pgsql-gui from the
postgis package.

Another option, possibly in addition to the suggestion above, would be
to make postgres-9.1-postgis recommend the postgis package rather than
depend. However then you still can't use just the non-gui shp2pgsql
and pgsql2shp programs without installing all the dependencies the
-gui program requires.


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages postgresql-9.1-postgis depends on:
ii  libc6           2.13-23
ii  libgeos-c1      3.2.2-3
ii  libproj0        4.7.0-1
ii  libxml2         2.7.8.dfsg-5
ii  postgis         1.5.3-2
ii  postgresql-9.1  9.1.2-2

postgresql-9.1-postgis recommends no packages.

postgresql-9.1-postgis suggests no packages.



--- End Message ---
--- Begin Message ---
Given that it's now well possible to install postgresql-9.3-postgis on a
server without pulling all of the GUI packages, and the fact that I
didn't get any feedback to my last message [0], I consider this bug
closed, now.

Regards

Markus Wanner

[0]: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=653111#15

Attachment: signature.asc
Description: OpenPGP digital signature


--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to