-----BEGIN PGP SIGNED MESSAGE-----
On 04/08/2014 09:14 PM, Markus Wanner wrote:
> On 04/08/2014 08:04 PM, Sebastiaan Couwenberg wrote:
>> Why did you chose to downgrade the priority?
> Because of the following extra dependencies, for which the postgis
> package currently seems to violate Policy 2.5:
> - libproj0 - libgdal1 - libpango1.0-0 - libpg-java - libjson-c2 -
> (That's according to debcheck here:
Because of the Policy requirements it's not a good idea to use
Priority extra for library packages. It forces all packages that
depend on the library to also use priority extra. We need to change
that, and we can fix GDAL and Proj.4 at least as they're team maintained.
>> Priority optional is usually the right choice, and recommended
>> for all Debian GIS packages.
> Back to the topic: Reading Policy 2.5, optional software is "all
> the software that you might reasonably want to install if you
> didn't know what it was and don't have specialized requirements"
> I felt like that didn't apply to postgis (nor do I think that
> applies to any GIS software). Thus, given the debcheck report and
> that wording, I adjusted the priority.
> Is there a general consensus that GIS stuff should rather have
> priority optional? How should I deal with the above extra
> dependencies, in that case?
I also thought that GIS packages are a specialized requirement, but
Andreas made me reconsider. The topic of Priority optional for GIS
packages was briefly discussed in November last year, see:
>> Both TinyOWS and pgRouting depend on postgresql-9.3-postgis-2.1
> Somewhat off-topic: Can't TinyOWS run on a different server than
> the database? Oh, it's just a recommends, fair enough.
It can, and that's my the dependency is only a Recommends indeed.
> However, that still reminds me: Both of these likely only depend
> on 'CREATE EXTENSION postgis;' to work (and result in some
> minimally required PostGIS version). Other packages like
> postgresql-9.3-postgis-2.0 or postgresql-9.2-postgis-2.1 should be
> able to satisfy that dependency as well. (Granted, that's more of a
> pgapt issue.)
The minimum required PostGIS version for TinyOWS is 1.5, so the above
is correct. TinyOWS should work with any of the postgres and postgis
I'm not sure what the requirements of pgRouting are, but I assume
they're not that strict either.
> I'm not sure how to best express that dependency. Would a virtual
> postgresql-X.Y-postgis-extension package make sense? So you could
> have a dependency like postgresql-X.Y-postgis-extension >= 1.5, for
> example? What do you think?
I like the idea of providing a virtual postgis package for others to
depend on. I don't think the postgresql version needs to be part of
the virtual package name though, just postgis-extension >= 1.5 would
suffice for TinyOWS for instance.
GPG Key ID: 4096R/E88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146 50D1 6750 F10A E88D 4AF1
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
Comment: Using GnuPG with Icedove - http://www.enigmail.net/
-----END PGP SIGNATURE-----
Pkg-grass-devel mailing list