Howdy,

I am currently using your `postgresql-9.3-postgis-2.1` debian package. My
team and I upgrading our RoR app to Rails 4, and we keep throwing the same
error when attempting to create a database.

PG::RaiseException: ERROR:  PostGIS is already installed in schema
'public', uninstall it first : CREATE EXTENSION postgis SCHEMA public


For more information including my installation steps, please refer to my
question on stackoverflow:

http://stackoverflow.com/questions/22947838/postgis-error-when-upgrading-to-rails-4

I think this installation line might be conflicting with Rails:

sudo -u postgres psql -d template_postgis -f
/usr/share/postgresql/9.3/extension/postgis--2.1.2.sql


Any suggestions on how to resolve?

Cheers,
Jake
------------------------------

Jake O'Brien Fagan

Development Operations Engineer
househappy.org <http://www.househappy.org/>
Facebook <https://www.facebook.com/househappy.org> |
Twitter<https://twitter.com/househappy>
 | Instagram <http://instagram.com/househappy>
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to