Source: hdf5
Version: 1.8.12+docs-1
Severity: serious
Tags: patch

Hi,

mpi-defaults now uses openmpi on mips and mipsel (as of 1.0.2+nmu1).  A
rebuilt libhdf5-mpi-dev thus depends on libhdf5-openmpi-dev, which is
not built on those archs, making it uninstallable.

diff --git a/debian/control b/debian/control
index 0b3c252..24929a9 100644
--- a/debian/control
+++ b/debian/control
@@ -101,7 +101,7 @@ Description: Hierarchical Data Format 5 (HDF5) - 
development files - serial vers
 Package: libhdf5-openmpi-7
 Section: libs
 Priority: extra
-Architecture: alpha arm64 armel armhf amd64 i386 ia64 powerpc powerpcspe ppc64 
sparc kfreebsd-i386 kfreebsd-amd64 hurd-i386
+Architecture: alpha arm64 armel armhf amd64 i386 ia64 mips mipsel powerpc 
powerpcspe ppc64 sparc kfreebsd-i386 kfreebsd-amd64 hurd-i386
 Depends: ${shlibs:Depends}, ${misc:Depends}
 Pre-Depends: ${misc:Pre-Depends}
 Conflicts: libhdf5-7
@@ -118,7 +118,7 @@ Description: Hierarchical Data Format 5 (HDF5) - runtime 
files - OpenMPI version
 Package: libhdf5-openmpi-dev
 Section: libdevel
 Priority: extra
-Architecture: alpha arm64 armel armhf amd64 i386 ia64 powerpc powerpcspe ppc64 
sparc kfreebsd-i386 kfreebsd-amd64 hurd-i386
+Architecture: alpha arm64 armel armhf amd64 i386 ia64 mips mipsel powerpc 
powerpcspe ppc64 sparc kfreebsd-i386 kfreebsd-amd64 hurd-i386
 Depends: libhdf5-openmpi-7 (= ${binary:Version}), zlib1g-dev,
  libjpeg-dev, libopenmpi-dev, ${misc:Depends}, hdf5-helpers
 Conflicts: libhdf5-dev
@@ -135,7 +135,7 @@ Description: Hierarchical Data Format 5 (HDF5) - 
development files - OpenMPI ver
 Package: libhdf5-openmpi-7-dbg
 Section: debug
 Priority: extra
-Architecture: alpha arm64 armel armhf amd64 i386 ia64 powerpc powerpcspe ppc64 
sparc kfreebsd-i386 kfreebsd-amd64 hurd-i386
+Architecture: alpha arm64 armel armhf amd64 i386 ia64 mips mipsel powerpc 
powerpcspe ppc64 sparc kfreebsd-i386 kfreebsd-amd64 hurd-i386
 Depends: ${shlibs:Depends}, ${misc:Depends},
  libhdf5-openmpi-7 (= ${binary:Version}),
 Conflicts: libhdf5-7-dbg, libhdf5-mpich-7-dbg
diff --git a/debian/rules b/debian/rules
index 1f2eb06..1e54389 100755
--- a/debian/rules
+++ b/debian/rules
@@ -37,7 +37,7 @@ DEFAULT_MPI=$(ARCH_DEFAULT_MPI_IMPL)
 #ARCH_FLAG=-a
 #ARCHS=any
 ARCH_FLAG=-s
-ARCHS=alpha arm64 armel armhf amd64 i386 ia64 powerpc powerpcspe ppc64 sparc 
kfreebsd-i386 kfreebsd-amd64 hurd-i386
+ARCHS=alpha arm64 armel armhf amd64 i386 ia64 mips mipsel powerpc powerpcspe 
ppc64 sparc kfreebsd-i386 kfreebsd-amd64 hurd-i386
 
 ifeq (,$(filter $(DEB_HOST_ARCH),$(ARCHS)))
 build_openmpi = no

Cheers,
Julien

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to