Package: postgresql-9.3-postgis-2.1
Version: 2.1.3+dfsg-2
Severity: important

Dear Maintainer,

apt-get dist-upgrade fails because libwlgeom-2.1.2 is not removed and conflicts
with  libwlgeom-2.1.3. Looks like this package upgrade relies on autoremove,
which can only be applied after the new package is installed. Perhaps you need
a Conflicts:?

The failure:

Unpacking liblwgeom-2.1.3 (2.1.3+dfsg-2) ...
dpkg: error processing archive /var/cache/apt/archives/liblwgeom-2.1.3_2.1.3
+dfsg-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/liblwgeom-2.1.3.so', which is also in package
liblwgeom-2.1.2 2.1.3+dfsg-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Then:

# apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  liblwgeom-2.1.2
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  liblwgeom-2.1.3
The following NEW packages will be installed:
  liblwgeom-2.1.3
0 upgraded, 1 newly installed, 0 to remove and 9 not upgraded.
23 not fully installed or removed.
Need to get 0 B/537 kB of archives.
After this operation, 863 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
(Reading database ... 263437 files and directories currently installed.)
Preparing to unpack .../liblwgeom-2.1.3_2.1.3+dfsg-2_amd64.deb ...
Unpacking liblwgeom-2.1.3 (2.1.3+dfsg-2) ...
dpkg: error processing archive /var/cache/apt/archives/liblwgeom-2.1.3_2.1.3
+dfsg-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/liblwgeom-2.1.3.so', which is also in package
liblwgeom-2.1.2 2.1.3+dfsg-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/liblwgeom-2.1.3_2.1.3+dfsg-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Workaround is:

apt-get remove postgresql-9.3-postgis-2.1 liblwgeom-2.1.3 liblwgeom-2.1.2
postgis

Followed by:

apt-get install postgresql-9.3-postgis-2.1

Kind regards,
Ben.



-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.14-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages postgresql-9.3-postgis-2.1 depends on:
ii  libc6                           2.18-7
ii  libgdal1h                       1.10.1+dfsg-5+b1
ii  libgeos-c1                      3.4.2-5
ii  liblwgeom-2.1.3                 2.1.3+dfsg-2
ii  libproj0                        4.8.0-5
ii  libxml2                         2.9.1+dfsg1-3
ii  postgresql-9.3                  9.3.4-1
ii  postgresql-9.3-postgis-scripts  2.1.3+dfsg-2

Versions of packages postgresql-9.3-postgis-2.1 recommends:
ii  postgis                 2.1.3+dfsg-2
ii  postgresql-contrib-9.3  9.3.4-1

postgresql-9.3-postgis-2.1 suggests no packages.

-- no debconf information

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to