> Since the libminizip from libkml is used specifically for its KMZ
> support, the bet course of action may be to rename the libkml library to
> libkmlminizip and patch gdal and osgearth accordingly.
> If the libraries are compatible (they both seem the be extracted from
> zlib), it may be wisest to drop the libminizip from libkml.

They're not compatible.  ibkml adds various libkml_ methods directly
in their embedded minizip source.  That's sort of the wrong way to do
it, and it would be nice to get that fixed, but it's unlikely to
happen any time soon.

The best solution for now is to add appropriate conflicts between the packages.

Best wishes,

Pkg-grass-devel mailing list

Reply via email to