Hi Christoph,

On 08/12/2014 10:53 PM, Christoph Berg wrote:
> osm2pgsql recommends postgresql-9.3-postgis-2.1,
> please upgrade this dependency. (postgis will likely be updated later
> this week.)

Will do after postgis is updated.

> As postgis is also in the Recommends, the extra Recommends:
> postgresql-9.4-postgis-2.1 should be redundant and could as well be
> removed so osm2pgsql doesn't need to track the PostgreSQL
> version. This would be the nicer solution imho.

The postgresql specific dependency has a long history (since #559604 at
least). While not ideal, having the Recommends for both postgis (for the
executables) and postgresql-9.4-postgis-2.1 (for the shared library) is
useful I think as postgis only Suggests postgresql-9.4-postgis-2.1.

Providing a virtual postgis-extension package was discussed briefly back
in April. That was in the context of TinyOWS which also doesn't need an
explicit PostgreSQL version specific dependency. But nothing concrete
has come out of this yet.

http://lists.alioth.debian.org/pipermail/pkg-grass-devel/2014-April/019374.html

I think the postgis-extension virtual package without a postgres
specific version is the way to go for cases like osm2pgsql and tinyows.

For now I think we should stick to bumping the postgresql version when
the default changes, while acknowledging that this is very suboptimal.

Kind Regards,

Bas

-- 
 GPG Key ID: 4096R/E88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to