This is an automated email from the git hooks/post-receive script.

sebastic-guest pushed a commit to branch master
in repository thuban.

commit b4c4ba87a4f5dafdf999355774cfaef913bef875
Author: Bas Couwenberg <sebas...@xs4all.nl>
Date:   Tue Aug 19 23:38:37 2014 +0200

    Apply patch by Olly Betts to use wxWidgets 3.0 - drop wxpython.patch, add 
wxpython3.0.patch. (closes: #757299)
---
 debian/changelog                 |   8 +++
 debian/control                   |   7 ++-
 debian/patches/series            |   2 +-
 debian/patches/wxpython.patch    |  16 ------
 debian/patches/wxpython3.0.patch | 121 +++++++++++++++++++++++++++++++++++++++
 5 files changed, 134 insertions(+), 20 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index 012dae5..008fea8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+thuban (1.2.2-6) UNRELEASED; urgency=medium
+
+  * Apply patch by Olly Betts to use wxWidgets 3.0 -
+    drop wxpython.patch, add wxpython3.0.patch.
+    (closes: #757299)
+
+ -- Bas Couwenberg <sebas...@xs4all.nl>  Tue, 19 Aug 2014 23:29:18 +0200
+
 thuban (1.2.2-5) unstable; urgency=low
 
   * Bump Standards-Version to 3.9.5, no changes required.
diff --git a/debian/control b/debian/control
index 5908b3d..cf89475 100644
--- a/debian/control
+++ b/debian/control
@@ -6,10 +6,11 @@ Section: graphics
 Priority: optional
 Build-Depends: debhelper (>= 9),
                python-all-dev (>= 2.6.6-3~),
-               python-wxgtk2.8,
+               python-wxgtk3.0,
+               python-wxgtk3.0-dev,
                libproj-dev,
                libgdal-dev,
-               libwxgtk2.8-dev,
+               libwxgtk3.0-dev,
                docbook-utils,
                docbook-xsl,
                docbook-xml,
@@ -25,7 +26,7 @@ Architecture: any
 Depends: ${shlibs:Depends},
          ${python:Depends},
          gdal-bin,
-         python-wxgtk2.8,
+         python-wxgtk3.0,
          python-sqlite,
          ${misc:Depends}
 Recommends: python-psycopg2,
diff --git a/debian/patches/series b/debian/patches/series
index ae6b71c..7a363c5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,5 +1,5 @@
 locale.patch
 setup.patch
 bitmappath.patch
-wxpython.patch
 gdal.patch
+wxpython3.0.patch
diff --git a/debian/patches/wxpython.patch b/debian/patches/wxpython.patch
deleted file mode 100644
index 94176ac..0000000
--- a/debian/patches/wxpython.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Description: Select wx version 2.8.
-Author: Francesco Paolo Lovergine <fran...@debian.org>
-Last-Update: 2011-11-03
-
---- a/thuban.py
-+++ b/thuban.py
-@@ -8,6 +8,9 @@
- # Read the file COPYING coming with Thuban for details.
- 
- import sys, os
-+import wxversion
-+wxversion.select("2.8")
-+
- import Thuban
- 
- import wxversion
diff --git a/debian/patches/wxpython3.0.patch b/debian/patches/wxpython3.0.patch
new file mode 100644
index 0000000..762eecf
--- /dev/null
+++ b/debian/patches/wxpython3.0.patch
@@ -0,0 +1,121 @@
+Description: wxPython 3.0 support
+ Note: wxPython and wxWidgets are now separate source packages, so we only
+ want to check that the major and minor versions match.
+Author: Olly Betts <o...@survex.com>
+Last-Update: 2014-08-06
+
+--- a/thuban.py
++++ b/thuban.py
+@@ -11,7 +11,7 @@
+ import Thuban
+ 
+ import wxversion
+-wxversion.select("2.8")
++wxversion.select("3.0")
+ 
+ # Put the Lib dir into the path. The Lib dir contains some extra non
+ # really Thuban specific Python modules
+--- a/setup.py
++++ b/setup.py
+@@ -71,7 +71,7 @@
+ 
+     # On POSIX-systems we run wxgtk-config to determine the C++-compiler
+     # flags
+-    wx_config_script = "wx-config --version=2.8"
++    wx_config_script = "wx-config --version=3.0"
+     # These lists will be filled automatically below
+     wx_cs_params = [[] for i in range(CS_NUM_PARAMS)]
+ 
+--- a/Thuban/version.py
++++ b/Thuban/version.py
+@@ -201,7 +201,7 @@
+ 
+     # Check whether the wxWindows version of wxPython and thuban's
+     # wxproj module match.  If they don't match, segfaults are likely.
+-    if versions["wxproj-wx-tuple"] != versions["wxPython-tuple"][:3]:
++    if versions["wxproj-wx-tuple"][:2] != versions["wxPython-tuple"][:2]:
+         errors.append(_("Thuban was compiled with wx %(wxproj-wx)s"
+                         " but wxPython is %(wxPython)s")
+                       % versions)
+--- a/Extensions/ogr/ogrdialog.py
++++ b/Extensions/ogr/ogrdialog.py
+@@ -36,7 +36,7 @@
+         """Initialize the dialog.
+         """
+         wx.Dialog.__init__(self, parent, -1, _("Choose file format"),
+-                          style = wx.DIALOG_MODAL|wx.CAPTION)
++                          style = wx.CAPTION)
+         self.session = session
+         self.tables = []
+ 
+@@ -116,7 +116,7 @@
+         """Initialize the dialog.
+         """
+         wx.Dialog.__init__(self, parent, -1, _("Choose layer"),
+-                          style = wx.DIALOG_MODAL|wx.CAPTION)
++                          style = wx.CAPTION)
+         self.tables = []
+ 
+         #
+@@ -200,7 +200,7 @@
+         """Initialize the dialog.
+         """
+         wx.Dialog.__init__(self, parent, -1, _("Choose layer from database"),
+-                          style = wx.DIALOG_MODAL|wx.CAPTION)
++                          style = wx.CAPTION)
+         self.session = session
+         self.dbconns = self.session.DBConnections()
+         self.tables = []
+@@ -348,7 +348,7 @@
+         """Initialize the dialog.
+         """
+         wx.Dialog.__init__(self, parent, -1, "Enter string for OGRConnection",
+-                          style = wx.DIALOG_MODAL|wx.CAPTION)
++                          style = wx.CAPTION)
+         self.session = session
+ 
+         # Sizer for the entire dialog
+--- a/Thuban/UI/dbdialog.py
++++ b/Thuban/UI/dbdialog.py
+@@ -40,7 +40,7 @@
+ 
+     def __init__(self, parent, session):
+         wx.Dialog.__init__(self, parent, -1, _("Choose layer from database"),
+-                          style = wx.DIALOG_MODAL|wx.CAPTION)
++                          style = wx.CAPTION)
+         self.session = session
+         self.dbconns = self.session.DBConnections()
+         self.tables = []
+--- a/Thuban/UI/exceptiondialog.py
++++ b/Thuban/UI/exceptiondialog.py
+@@ -23,7 +23,7 @@
+     def __init__(self, parent, message, title = _('Thuban: Internal Error')):
+         wx.Dialog.__init__(self, parent, -1, title,
+                           wx.DefaultPosition,
+-                          style = wx.RESIZE_BORDER|wx.CAPTION|wx.DIALOG_MODAL)
++                          style = wx.RESIZE_BORDER|wx.CAPTION)
+ 
+         self.parent = parent
+         self.dialog_layout(message)
+--- a/Thuban/UI/labeldialog.py
++++ b/Thuban/UI/labeldialog.py
+@@ -25,7 +25,7 @@
+     def __init__(self, parent, table, shape_index):
+         wx.Dialog.__init__(self, parent, -1, _("Label Values"),
+                           wx.DefaultPosition,
+-                          style = wx.RESIZE_BORDER|wx.CAPTION|wx.DIALOG_MODAL)
++                          style = wx.RESIZE_BORDER|wx.CAPTION)
+ 
+         self.parent = parent
+         self.dialog_layout(table, shape_index)
+--- a/Extensions/mouseposition/mouseposition.py
++++ b/Extensions/mouseposition/mouseposition.py
+@@ -101,7 +101,7 @@
+ # locator executed as an tool/extension to Thuban
+ iconfile = os.path.join(os.path.abspath(Thuban.__path__[0]),
+                         "..", "Resources", "Bitmaps", "identify")
+-iconfile = os.path.join(os.path.abspath(os.path.dirname(__file__)), 
++iconfile = os.path.join('/usr/share/thuban/Extensions/mouseposition',
+                         'position')
+ registry.Add(ToolCommand("mouse_position_tool", "Mouse Position Tool",
+                  mouse_position_tool, icon = iconfile,

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/thuban.git

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to