Package: libgeographic-dev
Version: 1.37-2
Severity: serious
User: debian...@lists.debian.org
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'wheezy'.
It installed fine in 'wheezy', then the upgrade to 'jessie' fails
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at
http://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

>From the attached log (scroll to the bottom...):

  Selecting previously unselected package libgeographic13.
  Unpacking libgeographic13 (from .../libgeographic13_1.37-2_amd64.deb) ...
  Selecting previously unselected package libgeographic-dev.
  Unpacking libgeographic-dev (from .../libgeographic-dev_1.37-2_amd64.deb) ...
  dpkg: error processing 
/var/cache/apt/archives/libgeographic-dev_1.37-2_amd64.deb (--unpack):
   trying to overwrite 
'/usr/include/GeographicLib/TransverseMercatorExact.hpp', which is also in 
package libgeographiclib-dev 1.21-1
  dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
  Errors were encountered while processing:
   /var/cache/apt/archives/libgeographic-dev_1.37-2_amd64.deb


cheers,

Andreas

Attachment: libgeographiclib-dev=1.21-1_libgeographic-dev=1.37-2.log.gz
Description: application/gzip

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to