Your message dated Fri, 05 Dec 2014 15:02:52 +0100
with message-id <5481bb0c.6040...@xs4all.nl>
and subject line Re: Bug#771705: osm2pgsql: Import fails in 
PolygonBuilder.cpp:261
has caused the Debian Bug report #771705,
regarding osm2pgsql: Import fails in PolygonBuilder.cpp:261
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
771705: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=771705
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: osm2pgsql
Version: 0.86.0-1
Severity: important

Hello,

I try to import the last planet-dump into the database. The import fails
with

--snip----

Reading in file: /data/dump/planet-latest.osm.pbf
Processing: Node(2614096k 177.8k/s) Way(261025k 27.43k/s) Relation(46730
40.49/s)osm2pgsql: PolygonBuilder.cpp:261: geos::geomgraph::EdgeRing*
geos::operation::overlay::PolygonBuilder::findShell(std::vector<geos::operation::overlay::MinimalEdgeRing*,
std::allocator<geos::operation::overlay::MinimalEdgeRing*> >*): Assertion
`shellCount <= 1' failed.

--snap---

after a few hours. If you need more data, please tell.

Thank you in advantage.

Sincerely,
DaB.


-- System Information:
Debian Release: 6.0.10
  APT prefers oldstable-updates
  APT policy: (500, 'oldstable-updates'), (500, 'oldstable'), (400, 'stable'), 
(200, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/16 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8) (ignored: LC_ALL 
set to de_DE.UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages osm2pgsql depends on:
ii  libbz2-1.0         1.0.5-6+squeeze1      high-quality block-sorting file co
ii  libc6              2.19-13               GNU C Library: Shared libraries
ii  libgcc1            1:4.7.2-5             GCC support library
ii  libgeos-3.4.2      3.4.2-6               Geometry engine for Geographic Inf
ii  liblua5.2-0        5.2.3-1.1             Shared library for the Lua interpr
ii  libpq5             9.4~beta3-3           PostgreSQL C client library
ii  libproj0           4.8.0-5               Cartographic projection library
ii  libprotobuf-c1     1.0.2-1               Protocol Buffers C shared library 
ii  libstdc++6         4.9.1-19              GNU Standard C++ Library v3
ii  libxml2            2.7.8.dfsg-2+squeeze8 GNOME XML library
ii  zlib1g             1:1.2.7.dfsg-13       compression library - runtime

Versions of packages osm2pgsql recommends:
ii  postgis                       1.5.1-5    geographic objects support for Pos

osm2pgsql suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
reassign 771705 geos
notfound 771705 osm2pgsql/0.86.0-1
found 771705 geos/3.2.2-1
fixed 771705 geos/3.3.1-1
thanks

Hi Daniel,

I've reviewed the previous upstream release of GEOS, and the assert that
is triggered on your system was removed in GEOS 3.3.1 and possibly earlier.

I'm reassigning this issue to the geos source package and marking it as
fixed by geos/3.3.1-1.

I suggest you upgrade your system to jessie properly, removing all
obsolete squeeze and wheezy packages, and only use the versions in jessie.

Kind Regards,

Bas

-- 
 GPG Key ID: 4096R/E88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1

--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to