This is an automated email from the git hooks/post-receive script.

sebastic-guest pushed a commit to branch master
in repository pktools.

commit 605385a91f7ed42bff53083fc0f1300ff97505f6
Author: Bas Couwenberg <sebas...@xs4all.nl>
Date:   Mon Feb 2 18:10:19 2015 +0100

    Add patch to not install deprecated utilities.
---
 debian/changelog                       |  1 +
 debian/patches/deprecated-noinst.patch | 22 ++++++++++++++++++++++
 debian/patches/series                  |  1 +
 3 files changed, 24 insertions(+)

diff --git a/debian/changelog b/debian/changelog
index 45615d7..9d533d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ pktools (2.6.2-1) UNRELEASED; urgency=medium
   * New upstream release.
   * Update man pages with changes in upstream docs.
   * Update Vcs-Browser URL to use cgit instead of gitweb.
+  * Add patch to not install deprecated utilities.
 
  -- Bas Couwenberg <sebas...@xs4all.nl>  Wed, 28 Jan 2015 09:24:30 +0100
 
diff --git a/debian/patches/deprecated-noinst.patch 
b/debian/patches/deprecated-noinst.patch
new file mode 100644
index 0000000..f73370a
--- /dev/null
+++ b/debian/patches/deprecated-noinst.patch
@@ -0,0 +1,22 @@
+Description: Don't install deprecated utilities and those not ready to publish.
+ Documentation for these utilties is explicitly removed, see:
+ 
http://git.savannah.gnu.org/cgit/pktools.git/tree/doc/createappsdox.sh?id=3f62efb556e29f35d6a0b88fa77cb9ffca8f925b#n60
+ .
+ Upstream agreed that not installing these utilities is a good idea.
+Author: Bas Couwenberg <sebas...@xs4all.nl>
+
+--- a/src/apps/Makefile.am
++++ b/src/apps/Makefile.am
+@@ -8,10 +8,10 @@ LDADD = $(GSL_LIBS) $(GDAL_LDFLAGS) $(to
+ 
###############################################################################
+ 
+ # the program to build and install (the names of the final binaries)
+-bin_PROGRAMS = pkinfo pkcrop pkreclass pkdiff pkgetmask pksetmask pkcreatect 
pkdumpimg pkdumpogr pksieve pkstatascii pkstatogr pkegcs pkextract pkfillnodata 
pkfilter pkkalman pkfilterdem pkenhance pkfilterascii pkdsm2shadow pkcomposite 
pkndvi pkpolygonize pkascii2img pksvm pkfssvm pkascii2ogr pkeditogr
++bin_PROGRAMS = pkinfo pkcrop pkdiff pkgetmask pksetmask pkcreatect pkdumpimg 
pkdumpogr pksieve pkstatascii pkstatogr pkegcs pkextract pkfillnodata pkfilter 
pkfilterdem pkfilterascii pkdsm2shadow pkcomposite pkpolygonize pkascii2img 
pksvm pkfssvm pkascii2ogr
+ 
+ # the program to build but not install (the names of the final binaries)
+-#noinst_PROGRAMS =  pkxcorimg pkgeom
++noinst_PROGRAMS = pkeditogr pkenhance pkkalman pkndvi pkreclass
+ 
+ if USE_FANN
+ bin_PROGRAMS += pkann pkfsann pkregann
diff --git a/debian/patches/series b/debian/patches/series
index e9e0975..cc11a10 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
 automake-subdir-objects.patch
+deprecated-noinst.patch

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/pktools.git

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to