Package: release.debian.org
Severity: normal
User: release.debian....@packages.debian.org
Usertags: unblock

Please unblock package debian-gis

According to previous discussion about Blends metapackages[1] I'd like
you to unblock debian-gis 0.0.4.  I simply rerendered the status of
the current debian-gis package (0.0.3) in testing by blends-dev which
excluded several packages from Recommends (and moved them to suggests as
blends-dev does with packages it can not found in the target release).

See the attached debdiff of mostly auto-generated files.

Thanks for working on the Debian release

    Andreas.

[1] https://lists.debian.org/debian-release/2014/11/msg01092.html

(include/attach the debdiff against the package in testing)

unblock debian-gis/0.0.4

-- System Information:
Debian Release: 7.8
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
diff -Nru debian-gis-0.0.3/debian/changelog debian-gis-0.0.4/debian/changelog
--- debian-gis-0.0.3/debian/changelog	2014-10-27 07:24:04.000000000 +0100
+++ debian-gis-0.0.4/debian/changelog	2015-04-01 13:26:36.000000000 +0200
@@ -1,3 +1,9 @@
+debian-gis (0.0.4) unstable; urgency=medium
+
+  * Rerender Debian GIS metapackages to reflect Jessie package pool.
+
+ -- Andreas Tille <ti...@debian.org>  Wed, 01 Apr 2015 11:59:03 +0200
+
 debian-gis (0.0.3) unstable; urgency=low
 
   [ Andreas Tille ]
diff -Nru debian-gis-0.0.3/debian/control debian-gis-0.0.4/debian/control
--- debian-gis-0.0.3/debian/control	2014-10-27 07:24:04.000000000 +0100
+++ debian-gis-0.0.4/debian/control	2015-04-01 13:26:36.000000000 +0200
@@ -123,7 +123,6 @@
  gpsbabel,
  gpsd,
  gpsd-clients,
- gpsdrive,
  gpsman,
  gpstrans,
  gpx2shp,
@@ -137,6 +136,7 @@
  qmapshack
 Suggests: gpscorrelate,
  gpscorrelate-gui,
+ gpsdrive,
  navit-graphics-gtk-drawing-area | navit-graphics-qt-qpainter,
  qlandkartegt-garmin
 Description: GPS related programs
@@ -151,7 +151,6 @@
  gir1.2-osmgpsmap-1.0,
  gosmore,
  gpsprune,
- gpxviewer,
  imposm,
  jmapviewer,
  josm,
@@ -168,7 +167,6 @@
  osmctools,
  osmjs,
  osmosis,
- osmosis-plugin-borderextract,
  osmpbf-bin,
  python-imposm-parser,
  qlandkartegt,
@@ -183,6 +181,7 @@
  gebabbel,
  gpscorrelate,
  gpscorrelate-gui,
+ gpxviewer,
  josm-plugins,
  libmemphis-0.2-dev,
  libmemphis-doc,
@@ -192,6 +191,7 @@
  openstreetmap-carto,
  openstreetmap-map-icons-classic | openstreetmap-map-icons-scalable | openstreetmap-map-icons-square,
  osmembrane,
+ osmosis-plugin-borderextract,
  osrm,
  osrm-tools,
  qmapcontrol,
@@ -207,7 +207,6 @@
 Architecture: all
 Depends: gis-tasks (= ${binary:Version})
 Recommends: dans-gdal-scripts,
- doris,
  gdal-bin,
  libepr-api2-dev,
  libgdal-dev,
@@ -221,11 +220,11 @@
  python-pycoast,
  python-pykdtree,
  python-pyorbital,
- python-pyresample,
- snaphu
+ python-pyresample
 Suggests: adore-doris,
  best,
  bestgui,
+ doris,
  eolisa,
  getorb,
  giant,
@@ -247,6 +246,7 @@
  pyaps,
  python-bufr,
  roipac,
+ snaphu,
  varres
 Description: Remote sensing and earth observation
  Debian packages which are dealing with Remote Sensing (for instance
@@ -290,14 +290,14 @@
  tilecache,
  tilelite,
  tilestache,
- tinyows,
  twms
 Suggests: mapcache-cgi,
  musmap,
  pycsw-cgi,
  python-pycsw,
  pywps,
- tilemill
+ tilemill,
+ tinyows
 Description: Present geographic information via web map server
  Debian packages which are dealing with geographical information
  to be presented for the web on so called map tile servers.  These
@@ -328,7 +328,6 @@
  libgeo-point-perl,
  libgeographic-dev,
  libgeos-c1,
- libgeotiff-epsg,
  libjts-java,
  liblas-bin,
  libshp-dev,
@@ -364,6 +363,7 @@
  libgdal1-1.10.1-grass,
  libgdal1-1.11.1-grass,
  libgeo-proj4-perl,
+ libgeotiff-epsg,
  libkml-java,
  libspatialite3,
  mapnik-viewer,
diff -Nru debian-gis-0.0.3/debian-gis-tasks.desc debian-gis-0.0.4/debian-gis-tasks.desc
--- debian-gis-0.0.3/debian-gis-tasks.desc	2014-10-27 07:24:04.000000000 +0100
+++ debian-gis-0.0.4/debian-gis-tasks.desc	2015-04-01 13:26:36.000000000 +0200
@@ -104,7 +104,6 @@
  gpsbabel
  gpx2shp
  gpsd
- gpsdrive
  gpsman
  gpstrans
  gpsd-clients
@@ -137,12 +136,10 @@
  mkgmapgui
  osm2pgsql
  osmosis
- osmosis-plugin-borderextract
  imposm
  osmpbf-bin
  python-imposm-parser
  gpsprune
- gpxviewer
  libgeo-osm-tiles-perl
  routino
  qlandkartegt
@@ -180,8 +177,6 @@
  libossim1
  libossim-dev
  dans-gdal-scripts
- doris
- snaphu
  python-pyresample
  python-pykdtree
  python-pyorbital
@@ -226,7 +221,6 @@
  mapserver-bin
  cgi-mapserver
  python-mapscript
- tinyows
  routino-www
  mapcache-tools
  libapache2-mod-mapcache
@@ -275,7 +269,6 @@
  libjts-java
  libgeo-point-perl
  geotiff-bin
- libgeotiff-epsg
  liblas-bin
  rasterlite-bin
  osgearth
diff -Nru debian-gis-0.0.3/dependency_data/debian-gis_0.0.4.json debian-gis-0.0.4/dependency_data/debian-gis_0.0.4.json
--- debian-gis-0.0.3/dependency_data/debian-gis_0.0.4.json	1970-01-01 01:00:00.000000000 +0100
+++ debian-gis-0.0.4/dependency_data/debian-gis_0.0.4.json	2015-04-01 13:26:36.000000000 +0200
@@ -0,0 +1 @@
+{"web": {"ignore": [], "suggests": ["mapcache-cgi"], "depends": ["tilecache", "tilelite", "tilestache", "twms", "qgis-mapserver", "php5-mapscript", "mapserver-bin", "cgi-mapserver", "python-mapscript", "musmap", "tilemill", "tinyows", "routino-www", "pywps", "mapcache-tools", "libapache2-mod-mapcache", "python-owslib", "python-pycsw", "pycsw-cgi"], "recommends": [], "avoid": []}, "workstation": {"ignore": [], "suggests": ["grass-doc", "libgdal1-1.10.1-grass", "libgdal1-1.11.1-grass", "googleearth-package", "s3dosm", "openjump", "libgeo-proj4-perl", "libkml-java", "python-kml", "nco", "ncview", "netcdf-bin", "python-epr", "python-pyshp"], "depends": ["grass", "qgis", "qgis-plugin-grass", "earth3d", "openscenegraph", "thuban", "proj-bin", "postgis", "savi", "avce00", "gdal-bin", "libgdal-dev", "python-gdal", "pktools", "libgeos-c1", "epsilon-bin", "ossim-core", "saga", "python-mapnik", "python-osmgpsmap", "libgeographic-dev", "libshp-dev", "geographiclib-tools", "geoip-bin", "gmt", "g
 race", "mapnik-utils", "mapnik-viewer", "e00compr", "gpsmanshp", "ogdi-bin", "h5utils", "hdf5-tools", "hdf4-tools", "libjts-java", "libgeo-point-perl", "geotiff-bin", "libgeotiff-epsg", "liblas-bin", "rasterlite-bin", "osgearth", "python-pyproj", "libspatialite3", "libspatialite5", "spatialite-bin", "spatialite-gui", "python-pyspatialite", "libfreexl1", "libgaiagraphics1", "libgaiagraphics2", "totalopenstation", "postgresql-comparator", "vtp", "opencpn", "capaware", "roadmap", "roadmap-qt", "roadmap-gtk2", "python-geolinks"], "recommends": [], "avoid": []}, "statistics": {"ignore": [], "suggests": [], "depends": ["r-cran-mapdata", "r-cran-mapproj", "r-cran-maps", "r-cran-sp", "r-cran-deldir", "r-cran-spatstat", "r-cran-gpclib", "r-cran-gstat", "r-cran-pbsmapping", "r-cran-spdep", "r-cran-tripack", "hyantesite"], "recommends": [], "avoid": []}, "devel": {"ignore": [], "suggests": ["libkmlframework-java"], "depends": ["libepr-api2-dev", "libgdal-dev", "libgeographic-dev", "libgeos-dev
 ", "libgmt-dev", "grass-dev", "libhdf5-dev", "libhdf5-mpi-dev", "libhdf5-mpich2-dev", "libhdf5-openmpi-dev", "libhdf5-serial-dev", "libepsilon-dev", "libfreexl-dev", "libfyba-dev", "libgeotiff-dev", "libhdf4-alt-dev", "libhdf4-dev", "libhdf4g-dev", "libkml-dev", "liblas-dev", "liblaszip-dev", "librasterlite-dev", "libterralib-dev", "libmapnik-dev", "libmapcache1-dev", "libmapserver1-dev", "libnetcdf-dev", "libogdi3.2-dev", "libosmgpsmap-1.0-dev", "libossim-dev", "liblwgeom-dev", "libproj-dev", "libqgis-dev", "libreadosm-dev", "libsaga-dev", "libshp-dev", "libspatialindex-dev", "libspatialite-dev", "libgeo-proj4-perl", "pktools-dev", "ruby-hdfeos5", "ruby-netcdf", "python-liblas", "python-modestmaps", "libgrits-dev", "python-geohash", "libgeo-google-mapobject-perl", "libgeo-googleearth-pluggable-perl"], "recommends": ["libcgal-dev", "libemos-dev", "libgrib2c-dev", "libgeoip-dev", "libgps-dev", "libgts-dev", "libhe5-hdfeos-dev", "libcitygml0-dev", "libdap-dev", "libgctp-dev", "libmarb
 le-dev", "libcv-dev", "libcvaux-dev", "libhighgui-dev", "libopencv-calib3d-dev", "libopencv-contrib-dev", "libopencv-core-dev", "libopencv-dev", "libopencv-features2d-dev", "libopencv-flann-dev", "libopencv-gpu-dev", "libopencv-highgui-dev", "libopenscenegraph-dev", "libopenthreads-dev", "paraview-dev", "libudunits2-dev", "libgeo-gpx-perl", "libosmium-dev"], "avoid": []}, "remotesensing": {"ignore": [], "suggests": ["googleearth-package", "nco", "ncview", "netcdf-bin"], "depends": ["libepr-api2-dev", "python-epr", "gdal-bin", "libgdal-dev", "python-gdal", "ossim-core", "libossim1", "libossim-dev", "dans-gdal-scripts", "otb-bin", "otb-bin-qt", "polsarpro", "doris", "snaphu", "gsdview", "mapready", "getorb", "adore-doris", "bestgui", "best", "roipac", "eolisa", "nest", "opticks", "openev", "gmtsar", "giant", "varres", "pyaps", "imcorr", "points2grid", "python-pyresample", "python-pykdtree", "python-pyorbital", "python-pycoast", "python-mipp", "python-mpop", "python-bufr"], "recommends
 ": [], "avoid": []}, "osm": {"ignore": [], "suggests": ["josm-plugins", "openstreetmap-map-icons-classic | openstreetmap-map-icons-scalable | openstreetmap-map-icons-square", "gpscorrelate", "gpscorrelate-gui", "routino-www", "libmemphis-doc", "libosm-gary68-perl", "libmemphis-0.2-dev", "libreadosm-dev"], "depends": ["viking", "josm", "osrm", "osrm-tools", "merkaartor", "emerillon", "gosmore", "maptool", "mkgmap", "mkgmapgui", "mkgmap-splitter", "osm2pgsql", "osmosis", "osmosis-plugin-borderextract", "imposm", "osmpbf-bin", "python-imposm-parser", "gpsprune", "gpxviewer", "libgeo-osm-tiles-perl", "routino", "qlandkartegt", "jmapviewer", "osmembrane", "sjjb-map-icons", "tkosm", "gebabbel", "cascadenik", "libosmpbf-java", "monav", "gir1.2-osmgpsmap-1.0", "qmapcontrol", "tilecache", "tilelite", "tilestache", "libjs-openlayers", "osmjs", "libjs-leaflet", "osmctools", "rel2gpx", "openstreetmap-carto", "sosi2osm"], "recommends": [], "avoid": []}, "data": {"ignore": [], "suggests": ["gmt-g
 shhs-full", "gmt-gshhs-high"], "depends": ["gmt-coast-low", "gmt-gshhs-low"], "recommends": [], "avoid": []}, "gps": {"ignore": [], "suggests": ["gpscorrelate", "gpscorrelate-gui", "qlandkartegt-garmin", "navit-graphics-gtk-drawing-area | navit-graphics-qt-qpainter"], "depends": ["gpsbabel", "gpx2shp", "gpsd", "gpsdrive", "gpsman", "gpstrans", "gpsd-clients", "qlandkartegt", "marble", "qmapshack", "foxtrotgps", "obdgpslogger", "navit-gui-gtk", "navit", "mtkbabel", "openbmap-logger"], "recommends": [], "avoid": []}}
\ Kein Zeilenumbruch am Dateiende.
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to