This is an automated email from the git hooks/post-receive script.

sebastic pushed a commit to tag v1.0.0
in repository osmium-tool.

commit bd43cc1f3401780de48ec664b471f0570c4ccf3c
Author: Jochen Topf <joc...@topf.org>
Date:   Tue Dec 16 15:32:42 2014 +0100

    Change cmake config to allow specifying C++ version to use.
---
 CMakeLists.txt            | 13 +++++++++++++
 cmake/OsmiumOptions.cmake |  1 -
 2 files changed, 13 insertions(+), 1 deletion(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index ed118ab..7b1635b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,6 +163,19 @@ include_directories(${PROJECT_BINARY_DIR}/src)
 
 
 #----------------------------------------------------------------------
+#
+#  Decide which C++ version to use (Minimum/default: C++11).
+#
+#----------------------------------------------------------------------
+
+if(NOT USE_CPP_VERSION)
+    set(USE_CPP_VERSION c++11)
+endif()
+message(STATUS "Use C++ version: ${USE_CPP_VERSION}")
+add_compile_options(-std=${USE_CPP_VERSION})
+
+
+#----------------------------------------------------------------------
 
 add_subdirectory(src)
 
diff --git a/cmake/OsmiumOptions.cmake b/cmake/OsmiumOptions.cmake
index 01d8c0e..ac4811c 100644
--- a/cmake/OsmiumOptions.cmake
+++ b/cmake/OsmiumOptions.cmake
@@ -5,7 +5,6 @@ add_definitions(-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64)
 if(MSVC)
     add_definitions(-wd4996 -DNOMINMAX -DWIN32_LEAN_AND_MEAN 
-D_CRT_SECURE_NO_WARNINGS)
 else()
-    add_compile_options(-std=c++11)
     add_compile_options(
         -Wall
         -Wextra

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/osmium-tool.git

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to