Source: etsf-io
Version: 1.0.3-4
Severity: normal
Tags: patch
User: debian-...@lists.debian.org
Usertags: netcdf-split-c-f-cxx

Dear Maintainer,

For the upcoming netcdf transition your package needs a build dependency
on libnetcdff-dev to build successfully.

Since NetCDF 4.3.3.1 the upstream developers have split the project into
language specific releases, the netcdf Debian package has likewise split
into language specific source packages:

┌─────────────────────┬───────────────────┬──────────────────────────┐
│ NetCDF project      │ Source package    │ -dev package             │
├─────────────────────┼───────────────────┼──────────────────────────┤
│ NetCDF-C            │ netcdf            │ libnetcdf-dev            │
│ NetCDF C++ (cxx4)   │ netcdf-cxx        │ libnetcdf-c++4-dev       │
│ NetCDF C++ (legacy) │ netcdf-cxx-legacy │ libnetcdf-cxx-legacy-dev │
│ NetCDF-Fortran      │ netcdf-fortran    │ libnetcdff-dev           │
└─────────────────────┴───────────────────┴──────────────────────────┘

The attached patches add the build dependency for etsf-io (1.0.3-4) and
etsf-io (1.0.4-1~exp1).

Kind Regards,

Bas
--- debian/control.orig	2015-07-27 22:02:28.339460767 +0200
+++ debian/control	2015-07-27 22:02:45.643370123 +0200
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian Science Team <debian-science-maintain...@lists.alioth.debian.org>
 Uploaders:  Damien Caliste <damien.cali...@cea.fr>
-Build-Depends: debhelper (>= 5), cdbs, autotools-dev, gfortran, libnetcdf-dev
+Build-Depends: debhelper (>= 5), cdbs, autotools-dev, gfortran, libnetcdf-dev, libnetcdff-dev
 Standards-Version: 3.9.6
 Homepage: http://www.etsf.eu/resources/software/libraries_and_tools
 Vcs-Svn: svn://svn.debian.org/svn/debian-science/packages/etsf-io/
--- debian/control.orig	2015-07-27 21:59:45.556313564 +0200
+++ debian/control	2015-07-27 22:00:41.300021514 +0200
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian Science Team <debian-science-maintain...@lists.alioth.debian.org>
 Uploaders:  Damien Caliste <damien.cali...@cea.fr>
-Build-Depends: debhelper (>= 5), cdbs, autotools-dev, gfortran, libnetcdf-dev
+Build-Depends: debhelper (>= 5), cdbs, autotools-dev, gfortran, libnetcdf-dev, libnetcdff-dev
 Standards-Version: 3.9.2
 Homepage: http://www.etsf.eu/resources/software/libraries_and_tools
 Vcs-Svn: svn://svn.debian.org/svn/debian-science/packages/etsf-io/
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to