On 26-08-15 18:02, Johan Van de Wauw wrote:
> While investigating the failing tests of rasterio in sid on
> armhf/armel [1,2] I tried doing the same command using ogr2ogr:
> ogr2ogr new.geojson test.geojson   -t_srs epsg:4326 -f GeoJSON -wrapdateline
> ERROR 1: vector::_M_fill_insert
> ERROR 1: vector::_M_fill_insert
> ERROR 1: vector::_M_fill_insert
> ERROR 1: vector::_M_fill_insert
> The same error is encountered. This error comes from C++ so I assume
> it is related to the libstdc++ transition. Moreover, if I build
> rasterio on stretch the error does not occur (and the ogr2ogr command
> works fine).

Builds on stretch have different versions in the dependency chain, as
part of the ongoing GCC 5 transitions several packages in the rasterio
dependency chain have been updated to newer upstream versions, most
importantly gdal.

The most interesting aspect of this issue is that it's limited to
arm{hf,el} which makes me suspect architecture differences are the root

I'm not sure what to do with this bugreport, if it's a problem with gdal
on arm{el,hf} we should forward it upstream, but since it can also very
likely be caused by the ongoing transitions we should probably keep it
around for now and check it again when the GCC 5 transitions have completed.

For now I'll do some porter uploads with nocheck to allow the build to
succeed and not block the gdal transition.

Kind Regards,


 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1

Pkg-grass-devel mailing list

Reply via email to