This is an automated email from the git hooks/post-receive script.

sebastic pushed a commit to branch jessie-backports
in repository qgis.

commit b0da4b9003133dc626b2562f1af5a90b5b3ff65d
Author: Bas Couwenberg <sebas...@xs4all.nl>
Date:   Mon Sep 7 22:08:45 2015 +0200

    Rebuild for jessie-backports.
    
    Re-enable GRASS plugin, still works with GRASS 6.
---
 debian/changelog           |  7 ++++
 debian/control             | 82 ++++++++++++++++++++++------------------------
 debian/libqgis-dev.install |  2 +-
 debian/rules               |  2 +-
 4 files changed, 49 insertions(+), 44 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index bc6399a..5b5c46a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+qgis (2.8.3+dfsg-3~bpo8+1) jessie-backports; urgency=medium
+
+  * Rebuild for jessie-backports.
+  * Re-enable GRASS plugin, still works with GRASS 6.
+
+ -- Bas Couwenberg <sebas...@debian.org>  Mon, 07 Sep 2015 22:04:39 +0200
+
 qgis (2.8.3+dfsg-3) unstable; urgency=medium
 
   * Update watch file to use lowercase RC in uversionmangle.
diff --git a/debian/control b/debian/control
index 18e32b9..c039900 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Build-Depends: bison,
                cmake (>= 2.8),
                debhelper (>= 9),
                flex,
-#               grass-dev (<< 7),
+               grass-dev (<< 7),
                libexpat1-dev,
                libfcgi-dev,
                libgdal-dev (>= 1.10.1-0~),
@@ -66,8 +66,7 @@ Depends: ${shlibs:Depends},
          python-qgis (= ${binary:Version}),
          qgis-providers (= ${binary:Version}),
          qgis-common (= ${source:Version})
-Recommends:
-# qgis-plugin-grass,
+Recommends: qgis-plugin-grass,
             qgis-plugin-globe
 Suggests: gpsbabel
 Conflicts: uim-qt3
@@ -136,16 +135,16 @@ Description: QGIS - shared network analysis library
  .
  This package contains the shared network analysis library.
 
-#Package: libqgisgrass2.8.3
-#Architecture: any
-#Section: libs
-#Depends: ${shlibs:Depends},
-#         ${misc:Depends}
-#Description: QGIS - shared grass library
-# QGIS is a Geographic Information System (GIS) which manages, analyzes and
-# display databases of geographic information.
-# .
-# This package contains the shared grass library.
+Package: libqgisgrass2.8.3
+Architecture: any
+Section: libs
+Depends: ${shlibs:Depends},
+         ${misc:Depends}
+Description: QGIS - shared grass library
+ QGIS is a Geographic Information System (GIS) which manages, analyzes and
+ display databases of geographic information.
+ .
+ This package contains the shared grass library.
 
 Package: libqgispython2.8.3
 Architecture: any
@@ -191,8 +190,7 @@ Description: QGIS - shared server library
 Package: libqgis-dev
 Architecture: any
 Section: libdevel
-Depends:
-# grass-dev (<< 7),
+Depends: grass-dev (<< 7),
          libexpat1-dev,
          libgdal-dev (>= 1.10.1-0~),
          libgeos-dev (>= 3.0.0),
@@ -204,7 +202,7 @@ Depends:
          libqgis-analysis2.8.3 (= ${binary:Version}),
          libqgis-networkanalysis2.8.3 (= ${binary:Version}),
          libqgis-server2.8.3 (= ${binary:Version}),
-#         libqgisgrass2.8.3 (= ${binary:Version}),
+         libqgisgrass2.8.3 (= ${binary:Version}),
          libqgispython2.8.3 (= ${binary:Version}),
          libqt4-dev (>= 4.7.0),
          libsqlite3-dev,
@@ -231,7 +229,7 @@ Depends: libqgis-core2.8.3 (= ${binary:Version}),
          libqgis-analysis2.8.3 (= ${binary:Version}),
          libqgis-networkanalysis2.8.3 (= ${binary:Version}),
          libqgis-server2.8.3 (= ${binary:Version}),
-#         libqgisgrass2.8.3 (= ${binary:Version}),
+         libqgisgrass2.8.3 (= ${binary:Version}),
          libqgispython2.8.3 (= ${binary:Version}),
          ${misc:Depends}
 Suggests: gdb
@@ -241,31 +239,31 @@ Description: QGIS - debugging symbols
  .
  This package contains debugging symbols.
 
-#Package: qgis-plugin-grass
-#Architecture: any
-#Depends: qgis (= ${binary:Version}),
-#         qgis-plugin-grass-common (= ${source:Version}),
-#         ${shlibs:Depends},
-#         ${misc:Depends},
-#         grass-core (<< 7)
-#Description: GRASS plugin for QGIS
-# QGIS is a Geographic Information System (GIS) which manages, analyzes and
-# display databases of geographic information.
-# .
-# This plugin enables GRASS data access in the QGIS geographic data viewer.
-#
-#Package: qgis-plugin-grass-common
-#Architecture: all
-#Depends: python2.7,
-#         ${misc:Depends}
-#Breaks: qgis-common (<< 1.5)
-#Replaces: qgis-common (<< 1.5)
-#Description: GRASS plugin for QGIS - architecture-independent data
-# QGIS is a Geographic Information System (GIS) which manages, analyzes and
-# display databases of geographic information.
-# .
-# This package contains architecture-independent supporting data files for use
-# with the QGIS GRASS plugin.
+Package: qgis-plugin-grass
+Architecture: any
+Depends: qgis (= ${binary:Version}),
+         qgis-plugin-grass-common (= ${source:Version}),
+         ${shlibs:Depends},
+         ${misc:Depends},
+         grass-core (<< 7)
+Description: GRASS plugin for QGIS
+ QGIS is a Geographic Information System (GIS) which manages, analyzes and
+ display databases of geographic information.
+ .
+ This plugin enables GRASS data access in the QGIS geographic data viewer.
+
+Package: qgis-plugin-grass-common
+Architecture: all
+Depends: python2.7,
+         ${misc:Depends}
+Breaks: qgis-common (<< 1.5)
+Replaces: qgis-common (<< 1.5)
+Description: GRASS plugin for QGIS - architecture-independent data
+ QGIS is a Geographic Information System (GIS) which manages, analyzes and
+ display databases of geographic information.
+ .
+ This package contains architecture-independent supporting data files for use
+ with the QGIS GRASS plugin.
 
 Package: qgis-plugin-globe
 Architecture: any
diff --git a/debian/libqgis-dev.install b/debian/libqgis-dev.install
index 6b4d980..a6fdc2f 100644
--- a/debian/libqgis-dev.install
+++ b/debian/libqgis-dev.install
@@ -4,6 +4,6 @@ usr/lib/libqgis_gui.so
 usr/lib/libqgis_analysis.so
 usr/lib/libqgis_networkanalysis.so
 usr/lib/libqgis_server.so
-#usr/lib/libqgisgrass.so
+usr/lib/libqgisgrass.so
 usr/lib/libqgispython.so
 usr/share/qgis/FindQGIS.cmake
diff --git a/debian/rules b/debian/rules
index d62a73b..5f0e049 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,7 +23,7 @@ ifeq (,$(DISTRIBUTION))
        DISTRIBUTION := $(shell dpkg-parsechangelog --format rfc822 | sed -ne 
"s/^Distribution: //p")
 endif
 
-ifneq ($(DISTRIBUTION),$(findstring $(DISTRIBUTION),"wheezy jessie precise 
trusty utopic vivid sid-oracle"))
+ifneq ($(DISTRIBUTION),$(findstring $(DISTRIBUTION),"wheezy jessie 
jessie-backports precise trusty utopic vivid sid-oracle"))
        DISTRIBUTION := sid
 endif
 

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/qgis.git

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to