On 17-07-15 00:56, Sebastiaan Couwenberg wrote:
> mapnik-vector-tile (0.8.0+dfsg-1) fails to build with mapnik
> (3.0.0+ds-2) as well. It's missing clipper.hpp:
> [...]
> This appear to be provided by an external dependency, that was added to
> the Makefile in v0.8.1. That release also adds a dependency on a MapBox
> specific pbf.hpp, so there are two missing build dependencies for
> mapnik-vector-tile:
>  1. https://github.com/mapnik/clipper
>  2. https://github.com/mapbox/pbf.hpp
> These build dependencies will need to be packaged before
> mapnik-vector-tile can be fixed.

The mapbox/pbf.hpp dependency is no longer required, mapnik-vector-tile
has switched to the protozero [0] library also required for recent
libosmium releases.

mapnik/clipper is still required, this is a mapnik specific fork of
polyclipping [1] (packaged in Debian as libpolyclipping [2]).

I've updated the mapnik-vector-tile package to the recent 0.10.0
upstream release and patched it to use the protozero Debian package
instead of a clone of the protozero git repository. I'll do the same for
mapnik-clipper once that's packaged (I'm working on that too).

[0] https://tracker.debian.org/pkg/protozero
[1] http://sourceforge.net/projects/polyclipping/
[2] https://tracker.debian.org/pkg/libpolyclipping

Kind Regards,


 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1

Pkg-grass-devel mailing list

Reply via email to