Package: gdal-bin
Version: 1.11.2+dfsg-3+b2
Severity: grave
Justification: causes non-serious data loss

NetCDF-4 format is not properly recognized in recent gdal (libgdal1i ?).

How to reproduce the bug: 
--------------------------

the attached file JEJK_topoC9k_ZABA10mHbpv.nc  is of NetCDF-4 / HDF5 format, 
see ncdump or h5dump output

$ ncdump -h JEJK_topoC9k_ZABA10mHbpv.nc
netcdf JEJK_topoC9k_ZABA10mHbpv {
dimensions:
        x = 501 ;
        y = 601 ;
variables:
        double x(x) ;
                x:long_name = "x" ;
                x:actual_range = -546000., -541000. ;
        double y(y) ;
                y:long_name = "y" ;
                y:actual_range = -1073000., -1067000. ;
        float z(y, x) ;
                z:long_name = "z" ;
                z:_FillValue = NaNf ;
                z:actual_range = 2.38614749908447, 11.5756139755249 ;

// global attributes:
                :Conventions = "COARDS, CF-1.5" ;
                :title = "Produced by grdreformat" ;
                :history = "grdreformat CRJK_topoC9c_ZABAGED10m.grd 
Jesenik_topoC9_ZABAGED10mBpv.nc -R-546000/-541000/-1073000/-1067000" ;
                :GMT_version = "5.1.2 (r14256) [64-bit]" ;
}


$ ncdump -k JEJK_topoC9k_ZABA10mHbpv.nc 
netCDF-4


$ h5dump -n JEJK_topoC9k_ZABA10mHbpv.nc 
HDF5 "JEJK_topoC9k_ZABA10mHbpv.nc" {
FILE_CONTENTS {
 group      /
 dataset    /x
 dataset    /y
 dataset    /z
 }
}


----------------------------

Now see what about gdal:

$ gdalinfo JEJK_topoC9k_ZABA10mHbpv.nc 
ERROR 4: `HDF5:"JEJK_topoC9k_ZABA10mHbpv.nc":z' does not exist in the file 
system,
and is not recognised as a supported dataset name.

gdalinfo failed - unable to open 'JEJK_topoC9k_ZABA10mHbpv.nc'.


The support for NetCDF-4 / HDF-5 output is broken too:

$ gmt grdreformat JEJK_topoC9k_ZABA10mHbpv.grd JEJK_topoC9k_ZABA10mHbpv.xnc=nf
grdreformat (GMTAPI_Export_Grid): NetCDF: HDF error 
[JEJK_topoC9k_ZABA10mHbpv.xnc=nf]
[Session gmt (0)]: Error returned from GMT API: GMT_GRID_WRITE_ERROR (19)


Previous gdal version (1.11.1 perhaps? - in stretch) worked well in this 
respect.

Regards,
Otakar


-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.2.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=cs_CZ.UTF-8, LC_CTYPE=cs_CZ.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gdal-bin depends on:
ii  libc6                            2.19-22
ii  libgcc1                          1:5.2.1-22
ii  libgdal1i [libgdal.so.1-1.11.2]  1.11.2+dfsg-3+b2
ii  libstdc++6                       5.2.1-22

gdal-bin recommends no packages.

Versions of packages gdal-bin suggests:
ii  python-gdal  1.11.2+dfsg-3+b2

-- no debconf information

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to