Package: src:mapserver
Version: 7.0.0-5
Tags: sid stretch patch
Blocks: 803158
User: gif...@packages.debian.org
Usertags: giflib5

Planning an update of giflib to the current version 5.1.1. Giflib slightly changes it's API, requiring soureful changes. There are some options for getting giflib5.1 support:

- Look for a newer upstream version, if upstream supports
both giflib4 and giflib5.1. Upload the new package,
and close the bug report.

- Patch the code to both use the NEW API. This can be done using
#if GIFLIB_MAJOR >= 5
<giflib5 code>
#else
<giflib4 code>
#endif
Please upload the package, and close the report.

- Unconditionally patch the code, not supporting giflib4 anymore.
Please upload a package to experimental once giflib5 hits
experimental.

For the latter two options, please see a patch at
http://launchpadlibrarian.net/222944103/mapserver_7.0.0-5build1_7.0.0-5ubuntu1.diff.gz

To test your changes before giflib5 is found in experimental, please use

deb https://people.debian.org/~doko/tmp/giflib5 ./

Thanks, Matthias

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to