This is an automated email from the git hooks/post-receive script.

sebastic pushed a commit to branch master
in repository mapserver.

commit 68342be43c2f204a0284be06f374d8637b6588b2
Author: Bas Couwenberg <sebas...@xs4all.nl>
Date:   Mon Nov 16 23:24:10 2015 +0100

    Add patch to fix build with newer SWIG versions.
---
 debian/changelog                                   |  6 +++++
 ...apscript-to-be-compatible-with-newer-swig.patch | 29 ++++++++++++++++++++++
 debian/patches/series                              |  1 +
 3 files changed, 36 insertions(+)

diff --git a/debian/changelog b/debian/changelog
index f7d6755..c654aac 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+mapserver (7.0.0-7) UNRELEASED; urgency=medium
+
+  * Add patch to fix build with newer SWIG versions.
+
+ -- Bas Couwenberg <sebas...@debian.org>  Mon, 16 Nov 2015 23:06:04 +0100
+
 mapserver (7.0.0-6) unstable; urgency=medium
 
   * Add upstream patch for giflib 5.1 support.
diff --git 
a/debian/patches/0001-Fix-java-mapscript-to-be-compatible-with-newer-swig.patch 
b/debian/patches/0001-Fix-java-mapscript-to-be-compatible-with-newer-swig.patch
new file mode 100644
index 0000000..a5ac144
--- /dev/null
+++ 
b/debian/patches/0001-Fix-java-mapscript-to-be-compatible-with-newer-swig.patch
@@ -0,0 +1,29 @@
+From 8399145191c4bf2065ba436a62ca76b776c5bb19 Mon Sep 17 00:00:00 2001
+From: Bruno Friedmann <br...@ioda-net.ch>
+Date: Sun, 4 Oct 2015 11:32:22 +0200
+Subject: [PATCH] Fix java mapscript to be compatible with newer swig (#5174)
+Origin: 
https://github.com/mapserver/mapserver/commit/8399145191c4bf2065ba436a62ca76b776c5bb19
+
+closes #5174
+closes #5178
+---
+ mapscript/java/javamodule.i | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+--- a/mapscript/java/javamodule.i
++++ b/mapscript/java/javamodule.i
+@@ -1,9 +1,11 @@
+ 
+ %include arrays_java.i
+ 
+-# Uncomment this if you wish to hace enums wrapped in an interface compatible
+-# with that generated by swig 1.3.21 (tests wont compile, though)
+-#%include enumsimple.swg
++/*
++  Uncomment this if you wish to hace enums wrapped in an interface compatible
++  with that generated by swig 1.3.21 (tests wont compile, though)
++  %include enumsimple.swg
++*/
+ 
+ /* Mapscript library loader */
+ 
diff --git a/debian/patches/series b/debian/patches/series
index 6939d7f..a726aa6 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -7,3 +7,4 @@ windows-archive-install-target.patch
 dont-install-headers-in-usr-lib.patch
 dont-export-mapserver-target-for-static-libmapserver.patch
 0001-Fix-compilation-with-gif_lib-5.1.patch
+0001-Fix-java-mapscript-to-be-compatible-with-newer-swig.patch

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/mapserver.git

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to