This is an automated email from the git hooks/post-receive script.

sebastic pushed a commit to branch experimental
in repository postgis.

commit 5891536be769053451a9d1b38ca5a815be125f77
Author: Bas Couwenberg <sebas...@xs4all.nl>
Date:   Mon Sep 19 10:12:10 2016 +0200

    Drop run_test-INC.patch, applied upstream. Refresh remaining patches.
---
 debian/changelog                  |  1 +
 debian/patches/link-liblwgeom     |  2 +-
 debian/patches/run_test-INC.patch | 22 ----------------------
 debian/patches/series             |  1 -
 4 files changed, 2 insertions(+), 24 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index d602dae..c996fec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ postgis (2.3.0~rc1+dfsg-1) UNRELEASED; urgency=medium
   * New upstream release candidate.
   * Add Conficts on postgresql-9.5-postgis-2.2-scripts to 2.3-scripts package.
     (closes: #837294)
+  * Drop run_test-INC.patch, applied upstream. Refresh remaining patches.
 
  -- Bas Couwenberg <sebas...@debian.org>  Mon, 19 Sep 2016 09:59:32 +0200
 
diff --git a/debian/patches/link-liblwgeom b/debian/patches/link-liblwgeom
index de3013e..2580d29 100644
--- a/debian/patches/link-liblwgeom
+++ b/debian/patches/link-liblwgeom
@@ -33,7 +33,7 @@ Forwarded: https://trac.osgeo.org/postgis/ticket/3290
 -# Note: we specify liblwgeom.a directly in SHLIB_LINK rather than using
 -# -L... -l options to prevent issues with some platforms trying to link
 -# to an existing liblwgeom.so in the PostgreSQL $libdir supplied by an
--# older version of PostGIS, rather than with the static liblwgeom.a 
+-# older version of PostGIS, rather than with the static liblwgeom.a
 -# supplied with newer versions of PostGIS
 -#
 -LIBLWGEOM_LDFLAGS=../../liblwgeom/.libs/liblwgeom.a
diff --git a/debian/patches/run_test-INC.patch 
b/debian/patches/run_test-INC.patch
deleted file mode 100644
index 3179ee6..0000000
--- a/debian/patches/run_test-INC.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Description: Add . to @INC if removed for CVE-2016-1238.
- -{pre,post}.pl scripts not executed otherwise.
-Author: Bas Couwenberg <sebas...@debian.org>
-Forwarded: https://trac.osgeo.org/postgis/ticket/3624
-Applied-Upstream: https://trac.osgeo.org/postgis/changeset/15072
-
---- a/regress/run_test.pl
-+++ b/regress/run_test.pl
-@@ -22,6 +22,13 @@ use Cwd 'abs_path';
- use Getopt::Long;
- use strict;
- 
-+##################################################################
-+# Add . to @INC if removed for CVE-2016-1238
-+##################################################################
-+BEGIN {
-+      push @INC, "." if(!grep /^\.$/, @INC);
-+}
-+
- 
- ##################################################################
- # Usage ./run_test.pl <testname> [<testname>]
diff --git a/debian/patches/series b/debian/patches/series
index 1de694f..32f6ef4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,2 @@
 link-liblwgeom
 relax-test-timing-constraints.patch
-run_test-INC.patch

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/postgis.git

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to