Hi Anatoliy,

On 10/14/2016 04:28 PM, Anatoliy Golubev wrote:
> Im try to install postgis 2.3 from apt.postgresql.org repo on debian 8:
> [...]
> Are these dependencies correct? Why do we need video drivers,
> deprecated Qt4, x11 libs and other multimedia stuff for database
> server?

Yes, those dependencies are correct. postgis depends on sfcgal for 3D
support, which in turn depends on openscenegraph which depends on a
bunch of graphics related libraries.

Other than taking up a little space, these libraries don't hurt on a
database server.

You can reduce the number of dependencies by not installing recommended
packages, but since that has been made the default for good reasons.

Kind Regards,


 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1

Pkg-grass-devel mailing list

Reply via email to