See 
<https://jenkins.debian.net/job/haskell-package-plan/2235/display/redirect?page=changes>

Changes:

[clint] mark ansi-terminal, colour, test-framework as notest because of

------------------------------------------
[...truncated 134.68 KB...]
Setting up libgit-wrapper-perl (0.048-1) ...
Setting up libhtml-format-perl (2.12-1) ...
Setting up libemail-valid-perl (1.202-1) ...
Setting up libhttp-cookies-perl (6.04-1) ...
Setting up curl (7.58.0-2) ...
Setting up libmodule-runtime-perl (0.016-1) ...
Setting up libhttp-daemon-perl (6.01-1) ...
Setting up libxml-simple-perl (2.25-1) ...
Setting up lintian (2.5.82) ...
Setting up libhtml-form-perl (6.03-1) ...
Setting up libmime-tools-perl (5.509-1) ...
Setting up libimport-into-perl (1.002005-1) ...
Setting up libmodule-implementation-perl (0.09-1) ...
Setting up libparams-validate-perl (1.29-1) ...
Setting up libmoo-perl (2.003004-1) ...
Setting up libb-hooks-endofscope-perl (0.21-1) ...
Setting up libpackage-stash-perl (0.37-1) ...
Setting up libgetopt-long-descriptive-perl (0.102-1) ...
Setting up libnamespace-clean-perl (0.27-1) ...
Setting up licensecheck (3.0.31-2) ...
Setting up dh-autoreconf (17) ...
Setting up libwww-perl (6.33-1) ...
Setting up debhelper (11.2.1) ...
Setting up equivs (2.1.0) ...
Setting up liblwp-protocol-https-perl (6.07-2) ...
Setting up dh-strip-nondeterminism (0.041-1) ...
Setting up libxml-parser-perl (2.44-2+b3) ...
Setting up libxml-sax-expat-perl (0.51-1) ...
update-perl-sax-parsers: Registering Perl SAX parser XML::SAX::Expat with 
priority 50...
update-perl-sax-parsers: Updating overall Perl SAX parser modules info file...
Replacing config file /etc/perl/XML/SAX/ParserDetails.ini with new version
Setting up libsoap-lite-perl (1.26-1) ...
Setting up libxmlrpc-lite-perl (0.717-1) ...
Processing triggers for libc-bin (2.27-3) ...
Processing triggers for ca-certificates (20180409) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.
Reading package lists...
Building dependency tree...
Reading state information...
dctrl-tools is already the newest version (2.24-2+b1).
dctrl-tools set to manually installed.
libdpkg-perl is already the newest version (1.19.0.5).
libdpkg-perl set to manually installed.
libipc-run-perl is already the newest version (0.99-1).
libipc-run-perl set to manually installed.
liblist-moreutils-perl is already the newest version (0.416-1+b3).
liblist-moreutils-perl set to manually installed.
patchutils is already the newest version (0.3.4-2).
patchutils set to manually installed.
The following additional packages will be installed:
  libbsd-dev libffi-dev libgmp-dev libgmpxx4ldbl libncurses5-dev libtinfo-dev
Suggested packages:
  ghc-prof ghc-doc haskell-doc llvm-3.9 gmp-doc libgmp10-doc libmpfr-dev
  ncurses-doc
The following NEW packages will be installed:
  cabal-install ghc libbsd-dev libffi-dev libfile-slurp-perl libgmp-dev
  libgmpxx4ldbl libncurses5-dev libtext-patch-perl libtinfo-dev
0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
Need to get 60.7 MB of archives.
After this operation, 642 MB of additional disk space will be used.
Get:1 http://cdn-fastly.deb.debian.org/debian sid/main amd64 libgmpxx4ldbl 
amd64 2:6.1.2+dfsg-3 [22.7 kB]
Get:2 http://cdn-fastly.deb.debian.org/debian sid/main amd64 libgmp-dev amd64 
2:6.1.2+dfsg-3 [632 kB]
Get:3 http://cdn-fastly.deb.debian.org/debian sid/main amd64 libffi-dev amd64 
3.2.1-8 [156 kB]
Get:4 http://cdn-fastly.deb.debian.org/debian sid/main amd64 libbsd-dev amd64 
0.8.7-1 [202 kB]
Get:5 http://cdn-fastly.deb.debian.org/debian sid/main amd64 libtinfo-dev amd64 
6.1-1 [81.2 kB]
Get:6 http://cdn-fastly.deb.debian.org/debian sid/main amd64 libncurses5-dev 
amd64 6.1-1 [174 kB]
Get:7 http://cdn-fastly.deb.debian.org/debian sid/main amd64 ghc amd64 8.2.2-3 
[56.1 MB]
Get:8 http://cdn-fastly.deb.debian.org/debian sid/main amd64 cabal-install 
amd64 2.0.0.1-1 [3220 kB]
Get:9 http://cdn-fastly.deb.debian.org/debian sid/main amd64 libfile-slurp-perl 
all 9999.19-6 [43.2 kB]
Get:10 http://cdn-fastly.deb.debian.org/debian sid/main amd64 
libtext-patch-perl all 1.8-2 [8784 B]
Fetched 60.7 MB in 3s (24.2 MB/s)
E: Can not write log (Is /dev/pts mounted?) - posix_openpt (19: No such device)
Selecting previously unselected package libgmpxx4ldbl:amd64.
(Reading database ... 28848 files and directories currently installed.)
Preparing to unpack .../0-libgmpxx4ldbl_2%3a6.1.2+dfsg-3_amd64.deb ...
Unpacking libgmpxx4ldbl:amd64 (2:6.1.2+dfsg-3) ...
Selecting previously unselected package libgmp-dev:amd64.
Preparing to unpack .../1-libgmp-dev_2%3a6.1.2+dfsg-3_amd64.deb ...
Unpacking libgmp-dev:amd64 (2:6.1.2+dfsg-3) ...
Selecting previously unselected package libffi-dev:amd64.
Preparing to unpack .../2-libffi-dev_3.2.1-8_amd64.deb ...
Unpacking libffi-dev:amd64 (3.2.1-8) ...
Selecting previously unselected package libbsd-dev:amd64.
Preparing to unpack .../3-libbsd-dev_0.8.7-1_amd64.deb ...
Unpacking libbsd-dev:amd64 (0.8.7-1) ...
Selecting previously unselected package libtinfo-dev:amd64.
Preparing to unpack .../4-libtinfo-dev_6.1-1_amd64.deb ...
Unpacking libtinfo-dev:amd64 (6.1-1) ...
Selecting previously unselected package libncurses5-dev:amd64.
Preparing to unpack .../5-libncurses5-dev_6.1-1_amd64.deb ...
Unpacking libncurses5-dev:amd64 (6.1-1) ...
Selecting previously unselected package ghc.
Preparing to unpack .../6-ghc_8.2.2-3_amd64.deb ...
Unpacking ghc (8.2.2-3) ...
Selecting previously unselected package cabal-install.
Preparing to unpack .../7-cabal-install_2.0.0.1-1_amd64.deb ...
Unpacking cabal-install (2.0.0.1-1) ...
Selecting previously unselected package libfile-slurp-perl.
Preparing to unpack .../8-libfile-slurp-perl_9999.19-6_all.deb ...
Unpacking libfile-slurp-perl (9999.19-6) ...
Selecting previously unselected package libtext-patch-perl.
Preparing to unpack .../9-libtext-patch-perl_1.8-2_all.deb ...
Unpacking libtext-patch-perl (1.8-2) ...
Setting up libfile-slurp-perl (9999.19-6) ...
Setting up libbsd-dev:amd64 (0.8.7-1) ...
Setting up libtinfo-dev:amd64 (6.1-1) ...
Setting up libffi-dev:amd64 (3.2.1-8) ...
Setting up libncurses5-dev:amd64 (6.1-1) ...
Processing triggers for libc-bin (2.27-3) ...
Processing triggers for man-db (2.8.3-2) ...
Setting up libgmpxx4ldbl:amd64 (2:6.1.2+dfsg-3) ...
Setting up libtext-patch-perl (1.8-2) ...
Setting up libgmp-dev:amd64 (2:6.1.2+dfsg-3) ...
Setting up ghc (8.2.2-3) ...
update-alternatives: using /usr/bin/runghc to provide /usr/bin/runhaskell 
(runhaskell) in auto mode
update-alternatives: using /usr/bin/ghc to provide /usr/bin/haskell-compiler 
(haskell-compiler) in auto mode
Setting up cabal-install (2.0.0.1-1) ...
Processing triggers for libc-bin (2.27-3) ...
Config file path source is default config file.
Config file /root/.cabal/config not found.
Writing default configuration to /root/.cabal/config
Warning: 'nslookup' tool missing - can't locate mirrors
Downloading the latest package list from hackage.haskell.org
Reading packages.txt...
Reading lts.config...
Reading available versions...
Reading available binary versions...
Calculating availability...
Checking for outdated entries...
Updated:  Allure is 0.5.0.0 in the archive but 0.7.1.0 exists here.
Updated:  BlogLiterately is 0.8.4.3 in the archive but 0.8.6.1 exists here.
Updated:  LambdaHack is 0.5.0.0 in the archive but 0.7.1.0 exists here.
Added:    OneTuple is 0.2.1 here but does not exist in the archive.
Added:    Only is 0.1 here but does not exist in the archive.
Updated:  aeson-compat is 0.3.6 in the archive but 0.3.7.1 exists here.
Updated:  aeson-extra is 0.4.0.0 in the archive but 0.4.1.0 exists here.
Updated:  arbtt is 0.9.0.13 in the archive but 0.10.0.1 exists here.
Updated:  argon2 is 1.2.0 in the archive but 1.3.0.1 exists here.
Updated:  aws is 0.16 in the archive but 0.19 exists here.
Updated:  binary-orphans is 0.1.6.0 in the archive but 0.1.8.0 exists here.
Updated:  brick is 0.18 in the archive but 0.34.1 exists here.
Updated:  bytestring-progress is 1.0.7 in the archive but 1.0.9 exists here.
Updated:  cassava is 0.4.5.1 in the archive but 0.5.1.0 exists here.
Updated:  chell-quickcheck is 0.2.5 in the archive but 0.2.5.1 exists here.
Updated:  classy-prelude-yesod is 1.2.0 in the archive but 1.4.0 exists here.
Added:    cmark-gfm is 0.1.3 here but does not exist in the archive.
Updated:  conduit-combinators is 1.1.2 in the archive but 1.3.0 exists here.
Updated:  criterion is 1.1.4.0 in the archive but 1.3.0.0 exists here.
Updated:  ekg is 0.4.0.14 in the archive but 0.4.0.15 exists here.
Updated:  fb is 1.1.1 in the archive but 1.2.0 exists here.
Updated:  feed is 0.3.12.0 in the archive but 1.0.0.0 exists here.
Added:    genvalidity is 0.4.0.4 here but does not exist in the archive.
Updated:  github is 0.16.0 in the archive but 0.19 exists here.
Updated:  graphviz is 2999.18.1.2 in the archive but 2999.19.0.0 exists here.
Added:    hackage-mirror is 0.1.1.1 here but does not exist in the archive.
Updated:  haddock-library is 1.4.3 in the archive but 1.4.5 exists here.
Updated:  hakyll is 4.9.8.0 in the archive but 4.12.1.0 exists here.
Updated:  happstack-authenticate is 2.3.4.7 in the archive but 2.3.4.8 exists 
here.
Updated:  heist is 1.0.1.1 in the archive but 1.0.1.2 exists here.
Updated:  hledger-ui is 1.2 in the archive but 1.5 exists here.
Updated:  hledger-web is 1.2 in the archive but 1.5.1 exists here.
Updated:  hoauth2 is 1.3.0 in the archive but 1.7.1 exists here.
Updated:  hoogle is 5.0.14 in the archive but 5.0.17.2 exists here.
Updated:  hopenpgp-tools is 0.20 in the archive but 0.20.1 exists here.
Updated:  hs-bibutils is 5.5 in the archive but 6.2.0.1 exists here.
Updated:  hslua is 0.4.1 in the archive but 0.9.5.1 exists here.
Updated:  html-conduit is 1.2.1.2 in the archive but 1.3.0 exists here.
Updated:  http-api-data is 0.3.7.1 in the archive but 0.3.7.2 exists here.
Updated:  http-conduit is 2.2.4 in the archive but 2.3.0 exists here.
Added:    ini is 0.3.5 here but does not exist in the archive.
Updated:  intern is 0.9.1.4 in the archive but 0.9.2 exists here.
Added:    keysafe is 0.20180326 here but does not exist in the archive.
Updated:  lambdabot is 5.1 in the archive but 5.1.0.1 exists here.
Updated:  lambdabot-haskell-plugins is 5.1 in the archive but 5.1.0.1 exists 
here.
Updated:  libmpd is 0.9.0.7 in the archive but 0.9.0.8 exists here.
Updated:  mime-mail-ses is 0.3.2.3 in the archive but 0.4.0.0 exists here.
Added:    multimap is 1.2.1 here but does not exist in the archive.
Added:    network-uri-flag is 0.1 here but does not exist in the archive.
Added:    only is 0.0.6.0 here but does not exist in the archive.
Updated:  pandoc is 1.19.2.4 in the archive but 2.1.2 exists here.
Updated:  pandoc-citeproc is 0.10.5.1 in the archive but 0.14.3 exists here.
Added:    pandoc-citeproc-preamble is 1.2.3 here but does not exist in the 
archive.
Updated:  patat is 0.5.2.2 in the archive but 0.6.1.0 exists here.
Updated:  path is 0.5.13 in the archive but 0.6.1 exists here.
Updated:  path-io is 1.2.2 in the archive but 1.3.3 exists here.
Updated:  persistable-record is 0.5.1.1 in the archive but 0.6.0.3 exists here.
Updated:  persistent is 2.7.1 in the archive but 2.8.1 exists here.
Updated:  persistent-postgresql is 2.6.2.1 in the archive but 2.8.2.0 exists 
here.
Updated:  persistent-sqlite is 2.6.3 in the archive but 2.8.1.2 exists here.
Updated:  persistent-template is 2.5.3 in the archive but 2.5.4 exists here.
Added:    rate-limit is 1.4.0 here but does not exist in the archive.
Updated:  relational-query is 0.9.5.1 in the archive but 0.11.0.0 exists here.
Updated:  relational-query-HDBC is 0.6.4.2 in the archive but 0.6.6.1 exists 
here.
Added:    relational-record is 0.2.1.2 here but does not exist in the archive.
Updated:  relational-schemas is 0.1.4.2 in the archive but 0.1.6.1 exists here.
Added:    sdl2 is 2.4.0.1 here but does not exist in the archive.
Added:    sdl2-ttf is 2.0.2 here but does not exist in the archive.
Updated:  servant is 0.11 in the archive but 0.13 exists here.
Updated:  servant-client is 0.11 in the archive but 0.13 exists here.
Updated:  servant-server is 0.11.0.1 in the archive but 0.13 exists here.
Updated:  shake is 0.15.11 in the archive but 0.16.4 exists here.
Updated:  simple-sendfile is 0.2.26 in the archive but 0.2.27 exists here.
Updated:  snap is 1.0.0.2 in the archive but 1.1.0.0 exists here.
Updated:  snap-server is 1.0.3.3 in the archive but 1.1.0.0 exists here.
AHEAD:    snap-server is 1.1.0.0 here, but only 1.0.3.3 in the tracked LTS 
release.
Updated:  stack is 1.5.1 in the archive but 1.6.5 exists here.
Added:    stylish-haskell is 0.9.0.0 here but does not exist in the archive.
Updated:  swish is 0.9.1.10 in the archive but 0.9.2.1 exists here.
Added:    system-posix-redirect is 1.1.0.1 here but does not exist in the 
archive.
Updated:  taffybar is 0.4.6 in the archive but 1.0.1 exists here.
Updated:  text-show is 3.6 in the archive but 3.7.3 exists here.
AHEAD:    text-show is 3.7.3 here, but only 3.7.2 in the tracked LTS release.
Updated:  these is 0.7.3 in the archive but 0.7.4 exists here.
Updated:  threadscope is 0.2.9 in the archive but 0.2.10 exists here.
Updated:  trifecta is 1.6.2.1 in the archive but 1.7.1.1 exists here.
Added:    tuple is 0.3.0.2 here but does not exist in the archive.
Added:    validity is 0.4.0.4 here but does not exist in the archive.
Updated:  wai-app-static is 3.1.6.1 in the archive but 3.1.6.2 exists here.
Updated:  wai-websockets is 3.0.1.1 in the archive but 3.0.1.2 exists here.
Updated:  warp is 3.2.13 in the archive but 3.2.18.2 exists here.
Updated:  warp-tls is 3.2.4 in the archive but 3.2.4.2 exists here.
Updated:  werewolf is 1.5.1.1 in the archive but 1.5.2.0 exists here.
Updated:  wreq is 0.5.0.1 in the archive but 0.5.2.1 exists here.
Updated:  yesod is 1.4.5 in the archive but 1.6.0 exists here.
Updated:  yesod-auth is 1.4.21 in the archive but 1.6.2 exists here.
Updated:  yesod-auth-hashdb is 1.6.2 in the archive but 1.7 exists here.
Updated:  yesod-auth-oauth is 1.4.2 in the archive but 1.6.0 exists here.
Updated:  yesod-auth-oauth2 is 0.3.0 in the archive but 0.4.1.0 exists here.
Updated:  yesod-bin is 1.5.2.6 in the archive but 1.6.0 exists here.
Updated:  yesod-core is 1.4.37.2 in the archive but 1.6.2 exists here.
Updated:  yesod-form is 1.4.16 in the archive but 1.6.1 exists here.
Updated:  yesod-newsfeed is 1.6 in the archive but 1.6.1.0 exists here.
Updated:  yesod-persistent is 1.4.3 in the archive but 1.6.0 exists here.
Updated:  yesod-static is 1.5.3.1 in the archive but 1.6.0 exists here.
Updated:  yesod-test is 1.5.8 in the archive but 1.6.2 exists here.
Updated:  yi is 0.12.6 in the archive but 0.13.7 exists here.
Added:    yi-keymap-emacs is 0.17.1 here but does not exist in the archive.
Added:    yi-keymap-vim is 0.17.1 here but does not exist in the archive.
(Re-)Creating local hackage "repository"...
Could not open '/root/.cabal/packages/hackage.haskell.org/00-index.tar' for 
reading: No such file or directory at ./test-packages.pl line 275.
No data could be read from file at ./test-packages.pl line 275.
Can't call method "contains_file" on an undefined value at ./test-packages.pl 
line 288.
Reading 00-list.tar...
Adding additional packages...
Mon 16 Apr 19:47:59 UTC 2018 - /srv/jenkins/bin/chroot-run.sh stopped running 
as /tmp/jenkins-script-l9843ruO, which will now be removed.
Build step 'Execute shell' marked build as failure

_______________________________________________
Pkg-haskell-maintainers mailing list
Pkg-haskell-maintainers@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-haskell-maintainers

Reply via email to