This is an automated email from the git hooks/post-receive script.

apo pushed a commit to branch master
in repository libjcommon-java.

commit f61479f6f8c8b9c261e9390925f205eb5914bb02
Author: Damien Raude-Morvan <draz...@debian.org>
Date:   Mon Apr 25 13:35:15 2011 +0000

      Java FAQ 4.4.4).
    * Update to Standards-Version 3.9.2.
    * Remove Arnaud Vandyck from Uploaders.
    * Drop Depends on JRE since it's a library (as per Debian Java
      Policy).
    * Build-Depends on libservlet2.5-java instead of libservlet2.4-java.
    * Rename d/libcommon-java-doc.doc-base to d/libjcommon-java-doc.doc-base
      to correctly register documentation.
---
 debian/changelog                                   | 23 ++++++++++------
 debian/control                                     |  8 +++---
 ...a-doc.doc-base => libjcommon-java-doc.doc-base} |  0
 debian/rules                                       |  9 +++---
 debian/rules.orig                                  | 32 ----------------------
 5 files changed, 23 insertions(+), 49 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index 9622ccf..46c5d0c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,22 +1,29 @@
-libjcommon-java (1.0.16-3) unstable; urgency=low
+libjcommon-java (1.0.16-2) unstable; urgency=low
 
   * Team upload.
+
+  [ Ioan Eugen STAN ]
   * Fix "Package does not install maven artifacts" (Closes: #620046)
   * Enabled maven artifact deployment:
     - debian/control: Build-Depends added maven-repo-helper
     - debian/rules: install maven artifacts
     - debian/poms/jcommon.pom: localised pom for maven
   * debian/patches/javaDocLink: links the package to system doc (Debian
-    Java FAQ 4.4.4)
+    Java FAQ 4.4.4).
 
- -- Ioan Eugen STAN <stan.ieu...@gmail.com>  Mon, 11 Apr 2011 00:15:12 +0300
-
-libjcommon-java (1.0.16-2) unstable; urgency=low
-
-  UNRELEASED
+  [ Torsten Werner ]
   * Remove last patch because it is not needed.
 
- -- Torsten Werner <twer...@debian.org>  Tue, 23 Mar 2010 20:58:59 +0100
+  [ Damien Raude-Morvan ]
+  * Update to Standards-Version 3.9.2.
+  * Remove Arnaud Vandyck from Uploaders.
+  * Drop Depends on JRE since it's a library (as per Debian Java
+    Policy).
+  * Build-Depends on libservlet2.5-java instead of libservlet2.4-java.
+  * Rename d/libcommon-java-doc.doc-base to d/libjcommon-java-doc.doc-base
+    to correctly register documentation.
+
+ -- Damien Raude-Morvan <draz...@debian.org>  Mon, 25 Apr 2011 15:18:34 +0200
 
 libjcommon-java (1.0.16-1) unstable; urgency=low
 
diff --git a/debian/control b/debian/control
index d4aeec3..eb6aee5 100644
--- a/debian/control
+++ b/debian/control
@@ -2,17 +2,17 @@ Source: libjcommon-java
 Section: java
 Priority: optional
 Maintainer: Debian Java Maintainers 
<pkg-java-maintain...@lists.alioth.debian.org>
-Uploaders: Christian Bayle <ba...@debian.org>, Arnaud Vandyck 
<av...@debian.org>, Michael Koch <konque...@gmx.de>, Rene Engelhard 
<r...@debian.org>
+Uploaders: Christian Bayle <ba...@debian.org>, Michael Koch 
<konque...@gmx.de>, Rene Engelhard <r...@debian.org>
 Build-Depends: debhelper (>= 5), cdbs, maven-repo-helper
-Build-Depends-Indep: default-jdk, ant, libservlet2.4-java, junit
-Standards-Version: 3.8.4
+Build-Depends-Indep: default-jdk, ant, libservlet2.5-java, junit
+Standards-Version: 3.9.2
 Vcs-Svn: svn://svn.debian.org/svn/pkg-java/trunk/libjcommon-java
 Vcs-Browser: http://svn.debian.org/wsvn/pkg-java/trunk/libjcommon-java/
 Homepage: http://www.jfree.org/jcommon/
 
 Package: libjcommon-java
 Architecture: all
-Depends: default-jre | java1-runtime | java2-runtime, ${misc:Depends}
+Depends: ${misc:Depends}
 Suggests: java-virtual-machine, libjcommon-java-doc
 Description: General Purpose library for Java
  JCommon is a free general purpose Java class library that is used in
diff --git a/debian/libcommon-java-doc.doc-base 
b/debian/libjcommon-java-doc.doc-base
similarity index 100%
rename from debian/libcommon-java-doc.doc-base
rename to debian/libjcommon-java-doc.doc-base
diff --git a/debian/rules b/debian/rules
index 4eef2ce..fcb9f4b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,7 +10,7 @@ API_VERSION     := $(DEB_UPSTREAM_VERSION)
 
 DEB_JARS := \
        junit \
-       servlet-api-2.4
+       servlet-api-2.5
 
 DEB_ANT_BUILDFILE := ant/build.xml
 DEB_ANT_BUILD_TARGET := compile compile-xml javadoc
@@ -19,6 +19,7 @@ DEB_ANT_CHECK_TARGET := compile-junit-tests
 MAVEN_REPO := http://repository.jboss.org/maven2
 
 clean::
+       mh_clean
        rm -rf build
        rm -rf javadoc
        rm -f $(LIBRARY_PACKAGE)-$(API_VERSION).jar 
@@ -26,10 +27,8 @@ clean::
        rm -f lib/junit.jar lib/jcommon-$(API_VERSION)-junit.jar
 
 install/lib$(LIBRARY_PACKAGE)-java:: 
-       install -m 644 -D $(LIBRARY_PACKAGE)-$(API_VERSION).jar 
debian/lib$(LIBRARY_PACKAGE)-java/usr/share/java/$(LIBRARY_PACKAGE)-$(API_VERSION).jar
-       ln -s $(LIBRARY_PACKAGE)-$(API_VERSION).jar 
debian/lib$(LIBRARY_PACKAGE)-java/usr/share/java/$(LIBRARY_PACKAGE).jar
-       install -m 644 -D $(LIBRARY_PACKAGE)-xml-$(API_VERSION).jar 
debian/lib$(LIBRARY_PACKAGE)-java/usr/share/java/$(LIBRARY_PACKAGE)-xml-$(API_VERSION).jar
-       ln -s $(LIBRARY_PACKAGE)-xml-$(API_VERSION).jar 
debian/lib$(LIBRARY_PACKAGE)-java/usr/share/java/$(LIBRARY_PACKAGE)-xml.jar
+       dh_install -plib$(LIBRARY_PACKAGE)-java 
$(LIBRARY_PACKAGE)-xml-$(API_VERSION).jar /usr/share/java/
+       dh_link -plib$(LIBRARY_PACKAGE)-java 
/usr/share/java/$(LIBRARY_PACKAGE)-xml-$(API_VERSION).jar 
/usr/share/java/$(LIBRARY_PACKAGE)-xml.jar
        mh_installpoms -plib$(LIBRARY_PACKAGE)-java
        mh_installjar -plib$(LIBRARY_PACKAGE)-java -l 
debian/poms/$(LIBRARY_PACKAGE).pom $(LIBRARY_PACKAGE)-$(API_VERSION).jar 
 
diff --git a/debian/rules.orig b/debian/rules.orig
deleted file mode 100755
index 372c95c..0000000
--- a/debian/rules.orig
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/usr/bin/make -f
-
-# Add here any variable or target overrides you need
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/ant.mk
-
-JAVA_HOME       := /usr/lib/jvm/default-java
-LIBRARY_PACKAGE := jcommon
-API_VERSION     := $(DEB_UPSTREAM_VERSION)
-
-DEB_JARS := \
-       junit \
-       servlet-api-2.4
-
-DEB_ANT_BUILDFILE := ant/build.xml
-DEB_ANT_BUILD_TARGET := compile compile-xml javadoc
-# FIXME: how to run this?
-DEB_ANT_CHECK_TARGET := compile-junit-tests
-
-clean::
-       rm -rf build
-       rm -rf javadoc
-       rm -f $(LIBRARY_PACKAGE)-$(API_VERSION).jar 
-       rm -f $(LIBRARY_PACKAGE)-xml-$(API_VERSION).jar
-       rm -f lib/junit.jar lib/jcommon-$(API_VERSION)-junit.jar
-
-install/lib$(LIBRARY_PACKAGE)-java:: 
-       install -m 644 -D $(LIBRARY_PACKAGE)-$(API_VERSION).jar 
debian/lib$(LIBRARY_PACKAGE)-java/usr/share/java/$(LIBRARY_PACKAGE)-$(API_VERSION).jar
-       ln -s $(LIBRARY_PACKAGE)-$(API_VERSION).jar 
debian/lib$(LIBRARY_PACKAGE)-java/usr/share/java/$(LIBRARY_PACKAGE).jar
-       install -m 644 -D $(LIBRARY_PACKAGE)-xml-$(API_VERSION).jar 
debian/lib$(LIBRARY_PACKAGE)-java/usr/share/java/$(LIBRARY_PACKAGE)-xml-$(API_VERSION).jar
-       ln -s $(LIBRARY_PACKAGE)-xml-$(API_VERSION).jar 
debian/lib$(LIBRARY_PACKAGE)-java/usr/share/java/$(LIBRARY_PACKAGE)-xml.jar
-

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-java/libjcommon-java.git

_______________________________________________
pkg-java-commits mailing list
pkg-java-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-commits

Reply via email to