Source: jenkins-winstone
Version: 0.9.10-jenkins-31+dfsg-1

ii  apache2-mpm-prefork                  2.2.21-5                     Apache 
HTTP Server - traditional non-threaded model
ii  jenkins                              1.409.3+dfsg-2               
Continuous Integration and Job Scheduling Server
ii  jenkins-cli                          1.409.3+dfsg-2               Jenkins 
CI Command Line Interface
ii  jenkins-common                       1.409.3+dfsg-2               Jenkins 
common Java components and web application
ii  libapache2-mod-jk                    1:1.2.32-1                   Apache 2 
connector for the Tomcat Java servlet engine
ii  libjenkins-winstone-java             0.9.10-jenkins-31+dfsg-1     Jenkins 
branch of Winstone servlet container

We have Jenkins running on Port 8080 using the integrated Winstone,
which works but is insecure (think passwords). We also have Apache,
with SSL, call it on Port 8009 (AJP), which fails:

Bad Gateway
The proxy server received an invalid response from an upstream server.
 
Apache/2.2.21 (Debian) Server at ci-XXX.lan.tarent.de Port 443


[Winstone 2012/01/17 15:53:45] - Error within request handler thread
java.lang.NullPointerException
        at java.util.Hashtable.put(Hashtable.java:432)
        at 
winstone.ajp13.Ajp13IncomingPacket.parsePacket(Ajp13IncomingPacket.java:163)
        at 
winstone.ajp13.Ajp13Listener.allocateRequestResponse(Ajp13Listener.java:187)
        at winstone.RequestHandlerThread.run(RequestHandlerThread.java:79)
        at java.lang.Thread.run(Thread.java:722)

[Tue Jan 17 15:53:45.804 2012] [22196:139924975863616] [error] 
ajp_get_reply::jk_ajp_common.c (2118): (worker1) Tomcat is down or refused 
connection. No response has been sent to the client (yet)
[Tue Jan 17 15:53:45.804 2012] [22196:139924975863616] [info] 
ajp_service::jk_ajp_common.c (2607): (worker1) sending request to tomcat failed 
(recoverable),  (attempt=2)
[Tue Jan 17 15:53:45.804 2012] [22196:139924975863616] [error] 
ajp_service::jk_ajp_common.c (2626): (worker1) connecting to tomcat failed.
[Tue Jan 17 15:53:45.804 2012] [22196:139924975863616] [info] 
jk_handler::mod_jk.c (2678): Service error=0 for worker=worker1


This is probably https://issues.jenkins-ci.org/browse/JENKINS-10548
but before upgrading the machine from lenny to wheezy (running a
non-Debian version of Jenkins before, but we changed to the one
from sid today to be able to work on the problem more easily)
this worked.

Due to https://issues.jenkins-ci.org/browse/JENKINS-5753 we can’t
use mod_proxy_ajp either. Neither does using SSL with the HTTP
connector work.

bye,
//mirabilos
-- 
tarent solutions GmbH
Rochusstraße 2-4, D-53123 Bonn • http://www.tarent.de/
Tel: +49 228 54881-393 • Fax: +49 228 54881-314
HRB AG Bonn 5168 • USt-ID (VAT): DE122264941
Geschäftsführer: Boris Esser, Elmar Geese



__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to