Package: jruby
Version: 1.5.6-2
Severity: normal

"jruby -S gem" fails with the following stacktrace:

$ jruby -S gem
OrNode.java:96:in `interpret': java.lang.NullPointerException
        from NewlineNode.java:104:in `interpret'
        from BlockNode.java:71:in `interpret'
        from InterpretedMethod.java:180:in `call'
        from DefaultMethod.java:174:in `call'
        from CachingCallSite.java:309:in `cacheAndCall'
        from CachingCallSite.java:148:in `call'
        from FCallOneArgNode.java:36:in `interpret'
        from LocalAsgnNode.java:123:in `interpret'
        from NewlineNode.java:104:in `interpret'
        from BlockNode.java:71:in `interpret'
        from InterpretedMethod.java:201:in `call'
        from DefaultMethod.java:182:in `call'
        from CachingCallSite.java:319:in `cacheAndCall'
        from CachingCallSite.java:157:in `callBlock'
        from CachingCallSite.java:162:in `call'
        from RubyClass.java:808:in `call'
        from DynamicMethod.java:186:in `call'
        from CachingCallSite.java:309:in `cacheAndCall'
        from CachingCallSite.java:148:in `call'
        from CallOneArgNode.java:57:in `interpret'
        from AttrAssignOneArgNode.java:33:in `interpret'
        from NewlineNode.java:104:in `interpret'
        from BlockNode.java:71:in `interpret'
        from InterpretedMethod.java:180:in `call'
        from DefaultMethod.java:174:in `call'
        from CachingCallSite.java:309:in `cacheAndCall'
        from CachingCallSite.java:148:in `call'
        from FCallOneArgNode.java:36:in `interpret'
        from NewlineNode.java:104:in `interpret'
        from BlockNode.java:71:in `interpret'
        from InterpretedMethod.java:180:in `call'
        from DefaultMethod.java:174:in `call'
        from CachingCallSite.java:309:in `cacheAndCall'
        from CachingCallSite.java:148:in `call'
        from gem:24:in `rescue_1$RUBY$__rescue___0'
        from gem:23:in `__file__'
        from gem:-1:in `load'
        from Ruby.java:690:in `runScript'
        from Ruby.java:573:in `runNormally'
        from Ruby.java:416:in `runFromMain'
        from Main.java:286:in `run'
        from Main.java:128:in `run'
        from Main.java:97:in `main'

Both 1.5.6-2 and 1.5.6-3 are affected. Reverting to stable/1.5.1-1
fixes the problem.

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable'), (80, 'unstable'), (70, 
'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.1.0-1-686-pae (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages jruby depends on:
ii  default-jre [java6-runtime]    1:1.6-46
ii  libjffi-jni                    1.0.2-8
ii  openjdk-6-jre [java6-runtime]  6b24~pre2-1
ii  openjdk-7-jre [java6-runtime]  7~b147-2.0-1

Versions of packages jruby recommends:
ii  ri1.8  1.8.7.352-2

jruby suggests no packages.

-- no debconf information



__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to