Author: tmancill
Date: 2012-03-26 19:35:53 +0000 (Mon, 26 Mar 2012)
New Revision: 15879

Added:
   tags/surefire/2.10-4/
   tags/surefire/2.10-4/debian/changelog
   tags/surefire/2.10-4/debian/patches/fix-junit-provider-selection.patch
Removed:
   tags/surefire/2.10-4/debian/changelog
   tags/surefire/2.10-4/debian/patches/fix-junit-provider-selection.patch
Log:
[svn-buildpackage] Tagging surefire 2.10-4

Deleted: tags/surefire/2.10-4/debian/changelog
===================================================================
--- trunk/surefire/debian/changelog     2012-03-25 19:09:32 UTC (rev 15875)
+++ tags/surefire/2.10-4/debian/changelog       2012-03-26 19:35:53 UTC (rev 
15879)
@@ -1,82 +0,0 @@
-surefire (2.10-3~miguel1) unstable; urgency=low
-
-  * Team upload.
-  * Fix JUnit 4 detection during unit tests in build time.
-    Thanks to James Page for the patch. (Closes: #664641).
-  * Bump Standards-Version to 3.9.3. No changes were required.
-
- -- Miguel Landaeta <mig...@miguel.cc>  Thu, 22 Mar 2012 19:49:18 -0430
-
-surefire (2.10-2) unstable; urgency=low
-
-  [ Miguel Landaeta ]
-  * Team upload.
-  * Drop self Build-Depends on libsurefire-java. (Closes: #655011).
-    Thanks to Daniel Schepler for the patch.
-
-  [ Damien Raude-Morvan ]
-  * Use Recommends: junit | junit4 | testng | libjmock-java instead of Depends
-    as only one test framework is needed at a time. (Closes: #563710).
-
- -- Damien Raude-Morvan <draz...@debian.org>  Sun, 08 Jan 2012 12:48:06 +0100
-
-surefire (2.10-1) unstable; urgency=low
-
-  * Team upload.
-  * New upstream release.
-  * Refresh and remove unneccesary patches.
-  * Add Build-Depends on libsurefire-java and
-    libmaven-common-artifact-filters-java.
-  * Drop outdated Maven artifact surefire-junit.
-  * Provide new Maven artifacts: surefire-junit3, maven-surefire-common,
-    common-junit3, common-junit4, surefire-junit47 and surefire-testng-utils.
-  * Fix clean target to allow "two in a row" builds.
-  * Update Vcs-Browser field.
-
- -- Miguel Landaeta <mig...@miguel.cc>  Mon, 10 Oct 2011 20:42:16 -0430
-
-surefire (2.4.3-5) unstable; urgency=low
-
-  * Team upload.
-  * Switch to default-jdk. (Closes: #641380).
-  * Add mh_clean call in clean target to allow twice in row builds.
-  * Bump Standards-Version to 3.9.2. No changes were required.
-
- -- Miguel Landaeta <mig...@miguel.cc>  Tue, 13 Sep 2011 07:27:04 -0430
-
-surefire (2.4.3-4) unstable; urgency=low
-
-  * Switch to source format 3.0.
-  * Update debian/build.xml for newer maven-ant-helper. (Closes: #637824)
-  * Switch to debhelper level 7.
-  * Update Standards-Version: 3.9.1.
-
- -- Torsten Werner <twer...@debian.org>  Sun, 21 Aug 2011 21:54:11 +0200
-
-surefire (2.4.3-3) unstable; urgency=low
-
-  * Fix groupId for maven-plugin-testing-harness dependency
-    in the Maven POM.
-
- -- Ludovic Claude <ludovic.cla...@laposte.net>  Sun, 26 Jul 2009 16:11:15 
+0100
-
-surefire (2.4.3-2) experimental; urgency=low
-
-  * Change section to java, bump up Standards-Version to 3.8.1
-  * Bump up debhelper to 6
-  * Migrate the build from cdbs-maven to cdbs-ant as Maven uses
-    this plugin for its build.
-  * Add a Build-Depends-Indep dependency on maven-repo-helper
-  * Use mh_installpom and mh_installjar to install the POM and the jar to the
-    Maven repository
-  * Remove the patch for the POM as it's no longer needed, as well as
-    the dependency on Quilt
-  * Remove Depends on Java runtimes as it is a library
-
- -- Ludovic Claude <ludovic.cla...@laposte.net>  Tue, 26 May 2009 21:03:39 
+0100
-
-surefire (2.4.3-1) unstable; urgency=low
-
-  * Initial release. (Closes: #508829)
-
- -- Torsten Werner <twer...@debian.org>  Mon, 05 Jan 2009 23:46:52 +0100

Copied: tags/surefire/2.10-4/debian/changelog (from rev 15878, 
trunk/surefire/debian/changelog)
===================================================================
--- tags/surefire/2.10-4/debian/changelog                               (rev 0)
+++ tags/surefire/2.10-4/debian/changelog       2012-03-26 19:35:53 UTC (rev 
15879)
@@ -0,0 +1,90 @@
+surefire (2.10-4) unstable; urgency=low
+
+  * Team upload.
+  * Apply updated JUnit 4 detection patch.  (Closes: #665796)
+    - Thanks to James Page.
+
+ -- tony mancill <tmanc...@debian.org>  Mon, 26 Mar 2012 11:27:25 -0700
+
+surefire (2.10-3) unstable; urgency=low
+
+  * Team upload.
+  * Fix JUnit 4 detection during unit tests in build time.
+    Thanks to James Page for the patch. (Closes: #664641).
+  * Bump Standards-Version to 3.9.3. No changes were required.
+
+ -- Miguel Landaeta <mig...@miguel.cc>  Thu, 22 Mar 2012 19:49:18 -0430
+
+surefire (2.10-2) unstable; urgency=low
+
+  [ Miguel Landaeta ]
+  * Team upload.
+  * Drop self Build-Depends on libsurefire-java. (Closes: #655011).
+    Thanks to Daniel Schepler for the patch.
+
+  [ Damien Raude-Morvan ]
+  * Use Recommends: junit | junit4 | testng | libjmock-java instead of Depends
+    as only one test framework is needed at a time. (Closes: #563710).
+
+ -- Damien Raude-Morvan <draz...@debian.org>  Sun, 08 Jan 2012 12:48:06 +0100
+
+surefire (2.10-1) unstable; urgency=low
+
+  * Team upload.
+  * New upstream release.
+  * Refresh and remove unneccesary patches.
+  * Add Build-Depends on libsurefire-java and
+    libmaven-common-artifact-filters-java.
+  * Drop outdated Maven artifact surefire-junit.
+  * Provide new Maven artifacts: surefire-junit3, maven-surefire-common,
+    common-junit3, common-junit4, surefire-junit47 and surefire-testng-utils.
+  * Fix clean target to allow "two in a row" builds.
+  * Update Vcs-Browser field.
+
+ -- Miguel Landaeta <mig...@miguel.cc>  Mon, 10 Oct 2011 20:42:16 -0430
+
+surefire (2.4.3-5) unstable; urgency=low
+
+  * Team upload.
+  * Switch to default-jdk. (Closes: #641380).
+  * Add mh_clean call in clean target to allow twice in row builds.
+  * Bump Standards-Version to 3.9.2. No changes were required.
+
+ -- Miguel Landaeta <mig...@miguel.cc>  Tue, 13 Sep 2011 07:27:04 -0430
+
+surefire (2.4.3-4) unstable; urgency=low
+
+  * Switch to source format 3.0.
+  * Update debian/build.xml for newer maven-ant-helper. (Closes: #637824)
+  * Switch to debhelper level 7.
+  * Update Standards-Version: 3.9.1.
+
+ -- Torsten Werner <twer...@debian.org>  Sun, 21 Aug 2011 21:54:11 +0200
+
+surefire (2.4.3-3) unstable; urgency=low
+
+  * Fix groupId for maven-plugin-testing-harness dependency
+    in the Maven POM.
+
+ -- Ludovic Claude <ludovic.cla...@laposte.net>  Sun, 26 Jul 2009 16:11:15 
+0100
+
+surefire (2.4.3-2) experimental; urgency=low
+
+  * Change section to java, bump up Standards-Version to 3.8.1
+  * Bump up debhelper to 6
+  * Migrate the build from cdbs-maven to cdbs-ant as Maven uses
+    this plugin for its build.
+  * Add a Build-Depends-Indep dependency on maven-repo-helper
+  * Use mh_installpom and mh_installjar to install the POM and the jar to the
+    Maven repository
+  * Remove the patch for the POM as it's no longer needed, as well as
+    the dependency on Quilt
+  * Remove Depends on Java runtimes as it is a library
+
+ -- Ludovic Claude <ludovic.cla...@laposte.net>  Tue, 26 May 2009 21:03:39 
+0100
+
+surefire (2.4.3-1) unstable; urgency=low
+
+  * Initial release. (Closes: #508829)
+
+ -- Torsten Werner <twer...@debian.org>  Mon, 05 Jan 2009 23:46:52 +0100

Deleted: tags/surefire/2.10-4/debian/patches/fix-junit-provider-selection.patch
===================================================================
--- trunk/surefire/debian/patches/fix-junit-provider-selection.patch    
2012-03-25 19:09:32 UTC (rev 15875)
+++ tags/surefire/2.10-4/debian/patches/fix-junit-provider-selection.patch      
2012-03-26 19:35:53 UTC (rev 15879)
@@ -1,30 +0,0 @@
-Description: Surefire can't correctly detect the 4.x version of
- JUnit that is present in the Debian Maven Repository.
- .
- This patch corrects that - its safe to assume that its greater
- than 4.7 as sid contains 4.8.2. The JUnit4Provider should
- never get selected due to the way these two checks are combined.
-Author: James Page <james.p...@ubuntu.com>
-Forwarded: not-needed
-
-Index: 
surefire/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/AbstractSurefireMojo.java
-===================================================================
---- 
surefire.orig/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/AbstractSurefireMojo.java
       2012-03-19 15:06:03.310108598 +0000
-+++ 
surefire/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/AbstractSurefireMojo.java
    2012-03-19 15:12:27.376393271 +0000
-@@ -311,12 +311,14 @@
- 
-     private boolean isJunit47Compatible( Artifact artifact )
-     {
--        return dependencyResolver.isWithinVersionSpec( artifact, "[4.7,)" );
-+        return ( dependencyResolver.isWithinVersionSpec( artifact, "[4.7,)" ) 
||
-+                 "4.x".equals( artifact.getVersion() ) );
-     }
- 
-     private boolean isAnyJunit4( Artifact artifact )
-     {
--        return dependencyResolver.isWithinVersionSpec( artifact, "[4.0,)" );
-+        return ( dependencyResolver.isWithinVersionSpec( artifact, "[4.0,)" ) 
||
-+                 "4.x".equals( artifact.getVersion() ) );
-     }
- 
-     boolean isForkModeNever()

Copied: tags/surefire/2.10-4/debian/patches/fix-junit-provider-selection.patch 
(from rev 15878, 
trunk/surefire/debian/patches/fix-junit-provider-selection.patch)
===================================================================
--- tags/surefire/2.10-4/debian/patches/fix-junit-provider-selection.patch      
                        (rev 0)
+++ tags/surefire/2.10-4/debian/patches/fix-junit-provider-selection.patch      
2012-03-26 19:35:53 UTC (rev 15879)
@@ -0,0 +1,30 @@
+Description: Surefire can't correctly detect the 4.x version of
+ JUnit that is present in the Debian Maven Repository.
+ .
+ This patch corrects that - its safe to assume that its greater
+ than 4.7 as sid contains 4.8.2. The JUnit4Provider should
+ never get selected due to the way these two checks are combined.
+Author: James Page <james.p...@ubuntu.com>
+Forwarded: not-needed
+
+Index: 
surefire/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/AbstractSurefireMojo.java
+===================================================================
+--- 
surefire.orig/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/AbstractSurefireMojo.java
       2012-03-19 15:06:03.310108598 +0000
++++ 
surefire/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/AbstractSurefireMojo.java
    2012-03-26 09:34:20.549223250 +0100
+@@ -311,12 +311,14 @@
+ 
+     private boolean isJunit47Compatible( Artifact artifact )
+     {
+-        return dependencyResolver.isWithinVersionSpec( artifact, "[4.7,)" );
++        return ( dependencyResolver.isWithinVersionSpec( artifact, "[4.7,)" ) 
||
++                 ( artifact != null && "4.x".equals( artifact.getVersion() ) 
) );
+     }
+ 
+     private boolean isAnyJunit4( Artifact artifact )
+     {
+-        return dependencyResolver.isWithinVersionSpec( artifact, "[4.0,)" );
++        return ( dependencyResolver.isWithinVersionSpec( artifact, "[4.0,)" ) 
||
++                 ( artifact != null && "4.x".equals( artifact.getVersion() ) 
) );
+     }
+ 
+     boolean isForkModeNever()


_______________________________________________
pkg-java-commits mailing list
pkg-java-comm...@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-commits

Reply via email to