On Sunday, April 01, 2012 16:48:04, Adam D. Barratt wrote:
> On Sun, 2012-04-01 at 15:10 -0400, Chris Knadle wrote:
> > I'm confused as to how you ran into this error.
> 
> If you want to ask the submitter something, you need to mail them too,
> not just the bug... added.

Thanks -- wasn't aware of that.  Found the explanation:

   http://www.debian.org/Bugs/Developer#followup

> > /etc/java-6-openjdk/security.nss.cfg is part of openjdk-6-jre-headless:
> >    $ dpkg -S /etc/java-6-openjdk/security/nss.cfg
> >    openjdk-6-jre-headless:amd64: /etc/java-6-openjdk/security/nss.cfg
> > 
> > ca-certificates-java depends on openjdk-6-jre-headless:
> [...]
> 
> >    Depends: ca-certificates (>= 20090814), openjdk-6-jre-headless (>=
> >    
> >      6b16-1.6.1-2) | java6-runtime-headless, libnss3-1d (>= 3.12.10-2~)
> 
> Actually, it depends on openjdk-6-jre-headless _or_
> java6-runtime-headless.  Although I'm not sure it was the case here, the
> latter virtual package is also provided by openjdk-7-jre-headless, fwiw.

If you look at the original submission:

   ...
   ii  ca-certificates                                  20120212
   ii  default-jre-headless [java6-runtime-headless]    1:1.6-47
   ii  libnss3-1d                                       3.13.3-1
   ii  openjdk-6-jre-headless [java6-runtime-headless]  6b24-1.11.1-3

   ^^ looks like openjdk-6-jre-headless is installed.
   Also, default-jre-headless depends specifically on openjdk-6-jre-headless.

  -- Chris

--
Chris Knadle
chris.kna...@coredump.us



__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to