The following commit has been merged in the master branch:
commit d8b73c372422164102967f16a61bef853a23b9ca
Author: James Page <james.p...@ubuntu.com>
Date:   Thu Apr 26 11:18:47 2012 +0100

    New upstream release:
    
    * New upstream release:
      - d/patches/asm3-compat.patch: Dropped - included upstream.
      - d/maven.rules, d/patches/revert-kohsuke-asm3.patch: Use stock asm3
        rather than package renamed fork from upstream as asm version is
        consistent between stapler and jenkins in the archive.
      - Refreshed remaining patches.
    * Enabled test suite.

diff --git a/debian/changelog b/debian/changelog
index 3e37922..10ae0ab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+stapler (1.182-1) unstable; urgency=low
+
+  * New upstream release:
+    - d/patches/asm3-compat.patch: Dropped - included upstream.
+    - d/maven.rules, d/patches/revert-kohsuke-asm3.patch: Use stock asm3
+      rather than package renamed fork from upstream as asm version is
+      consistent between stapler and jenkins in the archive.
+    - Refreshed remaining patches.
+  * Enabled test suite.
+
+ -- James Page <james.p...@ubuntu.com>  Thu, 26 Apr 2012 11:15:09 +0100
+
 stapler (1.174-2) unstable; urgency=low
 
   * Fix FTBFS (Closes: #663548):
diff --git a/debian/control b/debian/control
index 530227b..0b8fd3e 100644
--- a/debian/control
+++ b/debian/control
@@ -25,14 +25,17 @@ Build-Depends-Indep:
  libguava-java-doc,
  libjellydoc-java,
  libjenkins-commons-jelly-java,
+ libjenkins-htmlunit-java,
  libjenkins-dom4j-java,
  libjenkins-json-java,
+ libjetty-java,
  liblocalizer-java,
  libmaven-enforcer-plugin-java,
  libmaven-install-plugin-java,
  libmaven-javadoc-plugin-java,
  libmetainf-services-java,
  libmetainf-services-java-doc,
+ libmockito-java,
  libservlet2.5-java,
  libtiger-types-java
 Standards-Version: 3.9.3
@@ -73,5 +76,6 @@ Description: Documentation for libstapler-java
   * Groovy
   * JRuby (not packaged)
   * Java Server Pages
+  * JRebel (not packaged)
  .
  This package provides the API documentation for libstapler-java.
diff --git a/debian/maven.ignoreRules b/debian/maven.ignoreRules
index 2a23fa0..ca31100 100644
--- a/debian/maven.ignoreRules
+++ b/debian/maven.ignoreRules
@@ -19,8 +19,3 @@ org.jvnet.maven-jellydoc-plugin maven-jellydoc-plugin * * * *
 org.jvnet.fix1600 fix1600 * * * *
 org.jvnet.wagon-svn wagon-svn * * * *
 org.apache.maven.wagon wagon-webdav * * * *
-# Testing currently disabled
-org.mortbay.jetty jetty * * * *
-org.jvnet.hudson htmlunit * * * *
-org.kohsuke.stapler stapler jar * tests *
-org.mockito mockito-all * * * *
diff --git a/debian/maven.properties b/debian/maven.properties
index be1360a..ad2ba29 100644
--- a/debian/maven.properties
+++ b/debian/maven.properties
@@ -1,3 +1,2 @@
 # Include here properties to pass to Maven during the build.
 # For example:
-maven.test.skip=true
diff --git a/debian/maven.rules b/debian/maven.rules
index 724113f..fb25dae 100644
--- a/debian/maven.rules
+++ b/debian/maven.rules
@@ -18,10 +18,12 @@
 
 junit junit jar s/4\..*/4.x/ * *
 commons-collections commons-collections * s/3\..*/3.x/ * *
-# Need to upgrade to 3.x as groovy pulls this in
-asm * * s/2\..*/3.x/ * *
+s/org.kohsuke/asm/ s/asm3/asm-all/ * s/.*/3.x/ * *
 s/groovy/org.codehaus.groovy/ groovy * s/.*/debian/ * *
 s/javax.servlet/javax.servlet.jsp/ jsp-api jar s/2\..*/2.1/ * *
 javax.servlet servlet-api jar s/2\..*/2.5/ * *
 org.jvnet.maven-jellydoc-plugin * * s/1\..*/1.x/ * *
 s/org.jvnet.hudson/org.jenkins-ci/ commons-jelly-tags-define * * * *
+s/org.jvnet.hudson/org.jenkins-ci/ htmlunit * s/.*/debian/ * *
+org.mockito s/mockito-all/mockito-core/ * s/.*/debian/ * *
+org.mortbay.jetty jetty * s/6\..*/6.x/ * *
diff --git a/debian/patches/asm3-compat.patch b/debian/patches/asm3-compat.patch
deleted file mode 100644
index d033ff8..0000000
--- a/debian/patches/asm3-compat.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Description: Patch to support migration from asm2 -> asm3; this is required
- because the package is built against groovy 1.7.x (asm3) in Debian/Ubuntu; 
- however upstream depends on groovy 1.6.x (which pulls asm2).
-Author: James Page <james.p...@ubuntu.com>
-Forwarded: not-needed
-
-Index: stapler-old/core/src/main/java/org/kohsuke/stapler/ClassDescriptor.java
-===================================================================
---- 
stapler-old.orig/core/src/main/java/org/kohsuke/stapler/ClassDescriptor.java    
   2011-06-24 15:21:43.866827048 +0100
-+++ stapler-old/core/src/main/java/org/kohsuke/stapler/ClassDescriptor.java    
2011-06-24 15:21:47.756827046 +0100
-@@ -185,7 +185,7 @@
-                     else
-                         return null; // ignore this method
-                 }
--            }, false);
-+            }, 0);
- 
-             // Indexes may not be sequential, but first set of local 
variables are method params
-             int i = 0;
-@@ -221,7 +221,7 @@
-                     else
-                         return null; // ignore this method
-                 }
--            }, false);
-+            }, 0);
- 
-             // Indexes may not be sequential, but first set of local 
variables are method params
-             int i = 0;
diff --git a/debian/patches/beanutils18-compat.patch 
b/debian/patches/beanutils18-compat.patch
index c93d52e..7605f10 100644
--- a/debian/patches/beanutils18-compat.patch
+++ b/debian/patches/beanutils18-compat.patch
@@ -3,11 +3,11 @@ Descrition: Patch to sort out compatibility with Commons 
Beanutils 1.8
 Author: James Page <james.p...@ubuntu.com>
 Forwarded: no
 
-Index: stapler-old/core/src/main/java/org/kohsuke/stapler/RequestImpl.java
+Index: stapler/core/src/main/java/org/kohsuke/stapler/RequestImpl.java
 ===================================================================
---- stapler-old.orig/core/src/main/java/org/kohsuke/stapler/RequestImpl.java   
2011-06-24 15:21:43.826827048 +0100
-+++ stapler-old/core/src/main/java/org/kohsuke/stapler/RequestImpl.java        
2011-06-24 15:21:54.956827044 +0100
-@@ -688,7 +688,7 @@
+--- stapler.orig/core/src/main/java/org/kohsuke/stapler/RequestImpl.java       
2012-04-26 10:12:32.712639118 +0100
++++ stapler/core/src/main/java/org/kohsuke/stapler/RequestImpl.java    
2012-04-26 10:12:48.703729126 +0100
+@@ -693,7 +693,7 @@
                  if (converter==null)
                      throw new IllegalArgumentException("Unable to convert to 
"+type);
  
diff --git a/debian/patches/disable-jrebel-bindings.patch 
b/debian/patches/disable-jrebel-bindings.patch
index 5b8cdd9..94a49fe 100644
--- a/debian/patches/disable-jrebel-bindings.patch
+++ b/debian/patches/disable-jrebel-bindings.patch
@@ -1,7 +1,11 @@
-Index: stapler-debian/pom.xml
+Description: Don't build jrebel bindings as jrebel is not packaged.
+Author: James Page <james.p...@ubuntu.com>
+Forwarded: not-needed
+
+Index: stapler/pom.xml
 ===================================================================
---- stapler-debian.orig/pom.xml        2011-09-29 10:21:12.404969320 +0100
-+++ stapler-debian/pom.xml     2011-09-29 10:21:40.464782528 +0100
+--- stapler.orig/pom.xml       2012-04-26 10:12:48.995712215 +0100
++++ stapler/pom.xml    2012-04-26 10:12:49.479684125 +0100
 @@ -14,7 +14,6 @@
      <module>jsp</module>
      <module>jelly</module>
diff --git a/debian/patches/disable-jruby-bindings.patch 
b/debian/patches/disable-jruby-bindings.patch
index da31e1f..a471f63 100644
--- a/debian/patches/disable-jruby-bindings.patch
+++ b/debian/patches/disable-jruby-bindings.patch
@@ -2,10 +2,10 @@ Description: Disable jruby binding until upgraded in Debian
 Author: James Page <james.p...@ubuntu.com>
 Forwarded: not-needed
 
-Index: stapler-debian/pom.xml
+Index: stapler/pom.xml
 ===================================================================
---- stapler-debian.orig/pom.xml        2011-09-29 10:14:15.004583100 +0100
-+++ stapler-debian/pom.xml     2011-09-29 10:14:27.724710651 +0100
+--- stapler.orig/pom.xml       2012-04-26 10:12:32.676641127 +0100
++++ stapler/pom.xml    2012-04-26 10:12:48.995712215 +0100
 @@ -13,7 +13,6 @@
      <module>core</module>
      <module>jsp</module>
diff --git a/debian/patches/fix-groovy-build.patch 
b/debian/patches/fix-groovy-build.patch
index bfd0166..04e4b15 100644
--- a/debian/patches/fix-groovy-build.patch
+++ b/debian/patches/fix-groovy-build.patch
@@ -3,12 +3,12 @@ Description: Groovy module needs ant as well; not pulled in 
automatically
 Author: James Page <james.p...@ubuntu.com>
 Forwarded: not-needed
 
-Index: stapler-old/groovy/pom.xml
+Index: stapler/groovy/pom.xml
 ===================================================================
---- stapler-old.orig/groovy/pom.xml    2011-06-24 15:53:30.456826190 +0100
-+++ stapler-old/groovy/pom.xml 2011-06-24 15:54:00.516826176 +0100
+--- stapler.orig/groovy/pom.xml        2012-04-26 10:12:32.620644253 +0100
++++ stapler/groovy/pom.xml     2012-04-26 10:12:49.283695501 +0100
 @@ -22,6 +22,11 @@
-       <version>1.6.0</version>
+       <version>1.8.3</version>
      </dependency>
      <dependency>
 +      <groupId>org.apache.ant</groupId>
diff --git a/debian/patches/revert-kohsuke-asm3.patch 
b/debian/patches/revert-kohsuke-asm3.patch
new file mode 100644
index 0000000..e9a4c8a
--- /dev/null
+++ b/debian/patches/revert-kohsuke-asm3.patch
@@ -0,0 +1,30 @@
+Description: Stapler uses a forked version of asm3 to ensure that it
+ does not conflict with the asm2 used by Jenkins Core.
+ .
+ However, in Debian and Ubuntu Jenkins Core uses asm3 as well so rather
+ than carry the forked package in the archive we can revert to using
+ stock asm3 in this package.
+Author: James Page <james.p...@ubuntu.com>
+Forwarded: not-needed
+
+Index: stapler/core/src/main/java/org/kohsuke/stapler/ClassDescriptor.java
+===================================================================
+--- stapler.orig/core/src/main/java/org/kohsuke/stapler/ClassDescriptor.java   
2012-04-26 10:11:55.000000000 +0100
++++ stapler/core/src/main/java/org/kohsuke/stapler/ClassDescriptor.java        
2012-04-26 10:33:02.128754376 +0100
+@@ -24,11 +24,11 @@
+ package org.kohsuke.stapler;
+ 
+ import org.apache.commons.io.IOUtils;
+-import org.kohsuke.asm3.ClassReader;
+-import org.kohsuke.asm3.Label;
+-import org.kohsuke.asm3.MethodVisitor;
+-import org.kohsuke.asm3.Type;
+-import org.kohsuke.asm3.commons.EmptyVisitor;
++import org.objectweb.asm.ClassReader;
++import org.objectweb.asm.Label;
++import org.objectweb.asm.MethodVisitor;
++import org.objectweb.asm.Type;
++import org.objectweb.asm.commons.EmptyVisitor;
+ 
+ import java.io.IOException;
+ import java.lang.reflect.Constructor;
diff --git a/debian/patches/series b/debian/patches/series
index e863e2e..51c6641 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,5 +1,6 @@
-asm3-compat.patch
 beanutils18-compat.patch
 disable-jruby-bindings.patch
 fix-groovy-build.patch
 disable-jrebel-bindings.patch
+revert-kohsuke-asm3.patch
+servlet25-compat.patch
diff --git a/debian/patches/servlet25-compat.patch 
b/debian/patches/servlet25-compat.patch
index f908b34..6e81585 100644
--- a/debian/patches/servlet25-compat.patch
+++ b/debian/patches/servlet25-compat.patch
@@ -1,3 +1,7 @@
+Description: Compatiblity Patch for Servlet 2.5 Specification
+Author: James Page <james.p...@ubuntu.com>
+Forwarded: not-needed
+
 Index: stapler-1.152/core/src/test/java/org/kohsuke/stapler/MockRequest.java
 ===================================================================
 --- stapler-1.152.orig/core/src/test/java/org/kohsuke/stapler/MockRequest.java 
2010-11-16 09:59:49.966017999 +0000

-- 
stapler packaging

_______________________________________________
pkg-java-commits mailing list
pkg-java-comm...@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-commits

Reply via email to