On 05/14/2012 08:18 AM, Jakub Adam wrote:
> In my opinion libswt-gtk-3.5-java and libswt-3-gtk-java are not in
> conflict,
> generally it's ok to have them installed both. The problem is in tuxguitar
> package itself which will not work with SWT 3.5.
> 
> So I suggest that we make tuxguitar to conflict with libswt-gtk-3.5-java
> (and maybe also with libswt-gtk-3.4-java and libswt-gtk-3.6-java I see
> in Grant's package list too).

Hi Jakub,

There are times in the past when tuxguitar explicitly depended on
libswt-gtk-3.5-jar, so it seems odd to say that tuxguitar won't work
with it.  What seems to be the case is that tuxguitar won't work when
both -3.5 and -3 packages are install.

Could it be due to the version of libswt-gtk-3-java that was used when
the tuxguitar binary was built?  (That is, should it be a versioned
dependency on libswt-gtk-3-java?)  Also, I'm able to install both
libswt-gtk-3.5-java and libswt-3-gtk-java in a clean chroot and still
run tuxguitar without a problem.  In any event, I'm not trying to
contradict your assertion; merely understand it.

Cheers,
tony

Attachment: signature.asc
Description: OpenPGP digital signature

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to